rEFInd exit method: boot to hard drive requires extra manual menu input



  • I have PXE as the first boot option, and when there are no tasks scheduled, I’d like my PC to boot my hard drive automatically. I have to use EFI for my setup, so I am using rEFInd (I tried all other exit options, but none worked with EFI). With rEFInd, it goes into a menu where I have to select to manually select an option below (the 2nd one for me) and hit enter to finish booting my PC each time.

    Is there a way around this?

    104f45e6-f165-48fc-b3af-6ef10cec2f9b-image.png



  • @george1421 thanks for pointing me to the conf file! Changing the default option to the 2nd choice did the trick and now it boots straight to OS. I guess it got hung on the 1st choice.

    Here is the line I changed from:
    default_selection 1
    to:
    default_selection grubx64
    in /var/www/html/fog/service/ipxe/refind.conf


  • Moderator

    This is interesting that you are getting the refind menu. It appears that refind is finding multiple boot options so without a clear answer its presenting you with the menu. Normally in a windows environment it only find one boot loader.

    You might want to refine the search by looking at the settings in /var/www/html/fog/service/ipxe/refind.cfg file.


Log in to reply
 

414
Online

6.3k
Users

13.7k
Topics

129.3k
Posts