No Such File or directory when tring to boot external tools?



  • ubuntu 19.04
    dual xeon e5620
    fog 157

    recently I had to redo my linux machine

    I get this error “no such file or directory” no matter what permissions i give to the folder with the boot images in it.

    I have previously had great success with the same config prior to reinstalling and made every note to insure a seamless reinstall yet, no luck

    with that said the regular fog stuff works just fine, but my tools are used often and are very important in my environment.

    my external tools sit in a folder that i have created

    Here is the info of the command = ls -la

    drwxr-xr-x 8 www-data www-data 4096 Oct 16 16:35 .
    drwxr-xr-x 5 root root 4096 Oct 1 21:38 …
    drwxr-xr-x 12 www-data www-data 4096 Apr 26 2018 18.04_64
    drwxr-xr-x 3 www-data www-data 4096 Oct 1 20:14 centos
    drwxr-xr-x 12 www-data www-data 4096 Apr 26 2018 kubuntu-18.04-desktop-amd64
    drwxr-xr-x 11 www-data www-data 4096 Apr 26 2018 kubuntu-18.04-desktop-i386
    drwxr-xr-x 2 www-data www-data 4096 Oct 16 16:35 mac
    drwxr-xr-x 3 www-data www-data 4096 Oct 15 19:39 pmagic

    Here is the error,
    VirtualBox_pxe test_17_10_2019_20_23_35.png

    my exports:
    /images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    /images2 *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=2)
    /images2/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=3)
    #/var/www/html/bootimgs *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /opt/bootimgs *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)

    My parameters:
    kernel http://${fog-ip}/bootimgs/18.04/casper/vmlinuz
    initrd http://${fog-ip}/bootimgs/18.04/casper/initrd.lz
    imgargs vmlinuz.efi root=/dev/nfs boot=casper netboot=nfs nfsroot=${fog-ip}:/bootimgs/18.04/ locale=en_US.UTF-8 keyboard-configuration/layoutcode=la mirror/country=US
    boot || goto failed
    goto start

    am i missing something?



  • @george1421 Thank you once again for great support!!!



  • @george1421 Its fixed

    after symlinking my custom image directory to /var/www/html/fog as noted, it worked.

    its always the little things isnt it
    and i had to change the path on my parameters


  • Moderator

    @dureal99d said in No Such File or directory when tring to boot external tools?:

    what other information would you require to assist me?

    what does the results of this command? ls -la /var/www/html/bootimgs

    I think the problem is already defined in my previous post.



  • I see.

    what other information would you require to assist me?

    Inform and I shall provide what is needed

    additionally…

    if i understand correctly “http” will not work from var/www/html" but rather requires that i symlink from var/www/html/fog

    i failed to paste the proper directory and folder name but in the fog client they are correct.

    i will try to update the link to see what happens


  • Moderator

    You really didn’t supply enough information but looking at the error I can give you a direction to look in.

    The error is http://192.168.2.10/bootimgs/18.04/casper/vmlinz… does not exist.

    So that means you are using the http protocol which has a base directory of /var/www/html/fog from that directory bootimgs/18.04/casper/vmlinz needs to exist. Just looking at the directory you provided there is no base references but I see Ubuntu directory of 18.04_64 which if you translate that to the file not found path 18.04_64 != 18.04 assuming the base path was /var/www/html/fog/bootimgs


Log in to reply
 

534
Online

6.3k
Users

13.7k
Topics

129.3k
Posts