Snap-In not deploying with Image



  • Hello,

    I am hoping you can help me with this one. I successfully deployed an image to three hosts, however the accompanying snap-in still shows in the Active Snap-in Tasks as queued.

    c0b3090c-d663-4825-8f6b-14b2426e7dfe-image.png

    The snap-in is enabled, it is an MSI, actually the FogClient MSI file that I am trying to install on the hosts.

    I just found where the snap-in requires FogClient to already be on the host? If that is the case, then how do I push FogClient to the hosts?

    When I eventually deploy the FogServer I am going to want to put FogClient on all hosts which will allow me to better manage things, but I don’t want to completely re-image every machine at this time, so is there a recommended way to do this?

    Thank you,
    Dave



  • George,

    I have another question, this time about sysprep. Why do we need to go through OOBE for an installation that is all in the same locale? Wouldn’t it be easier to just generalize and be done? And if doing that, do I still need to disable the Fog Client Service before doing it?

    Thank you,
    Dave



  • Thank you, George.

    One more question (hopefully) and then I will try this. The unattend.xml method should work whether or not it is an OEM version of Windows, no? Isn’t unattend used regardless, and therefore anything in it executed regardless?

    Thank you again,
    Dave


  • Moderator

    yes the fog client needs to be on/in the master/golden image. You can install it post deployment either manually, via GPO or via a third party application deployment tool like PDQ Deploy (free). You should deploy the MSI with the appropriate command line switches to identify your fog server and how you want the client to run.

    Here is the command line switches you can use:
    https://wiki.fogproject.org/wiki/index.php/FOG_Client#MSI_Switches


Log in to reply
 

355
Online

6.2k
Users

13.6k
Topics

128.1k
Posts