FOG Client Not Responding To New FOG Server



  • I recently set up a new FOG server and migrated the images and database from the old server to the new. Since then, the FOG client is not responding to any commands from the FOG server.

    • I followed information found here to migrate images & database.

    • I used instructions found here to copy ssl directory from old fog server to new.

    • I have uninstalled and reinstalled the FOG client, but it still does not seem to be properly communicating. For instance, changes to the hostname in the FOG console are not carried out on the workstation.

    According to the log, it seems unable to get the security token. How can I resolve this issue?

    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:28 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:28 PM Client-Info Client OS:      Windows
     9/25/2019 1:28 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:28 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:28 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:28 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:28 PM Client-Info Client OS:      Windows
     9/25/2019 1:28 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:28 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:28 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:28 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:28 PM Client-Info Client OS:      Windows
     9/25/2019 1:28 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:28 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:28 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:28 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:28 PM Client-Info Client OS:      Windows
     9/25/2019 1:28 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:28 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:28 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:28 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:28 PM Client-Info Client OS:      Windows
     9/25/2019 1:28 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:28 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:28 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:28 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:28 PM Client-Info Client OS:      Windows
     9/25/2019 1:28 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:28 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:28 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     9/25/2019 1:28 PM Service Sleeping for 145 seconds
     9/25/2019 1:30 PM Middleware::Communication URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     9/25/2019 1:30 PM Middleware::Response Success
     9/25/2019 1:30 PM Middleware::Communication URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&mac=90:B1:1C:9C:95:75&newService&json
     9/25/2019 1:30 PM Middleware::Authentication Waiting for authentication timeout to pass
     9/25/2019 1:30 PM Middleware::Communication Download: http://10.1.0.23/fog/management/other/ssl/srvpublic.crt
     9/25/2019 1:30 PM Data::RSA FOG Server CA cert found
     9/25/2019 1:30 PM Middleware::Authentication Cert OK
     9/25/2019 1:30 PM Middleware::Authentication No token found at C:\Program Files (x86)\FOG\token.dat, this is expected if the client has not authenticated before
     9/25/2019 1:30 PM Middleware::Authentication ERROR: Could not get security token
     9/25/2019 1:30 PM Middleware::Authentication ERROR: Could not find file 'C:\Program Files (x86)\FOG\token.dat'.
     9/25/2019 1:30 PM Middleware::Communication POST URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&authorize&newService
     9/25/2019 1:30 PM Middleware::Response Invalid security token
     9/25/2019 1:30 PM Middleware::Response Success
     9/25/2019 1:30 PM Middleware::Communication URL: http://10.1.0.23/fog/service/getversion.php?clientver&newService&json
     9/25/2019 1:30 PM Middleware::Communication URL: http://10.1.0.23/fog/service/getversion.php?newService&json
    
     9/25/2019 1:30 PM Service Creating user agent cache
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:30 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:30 PM Client-Info Client OS:      Windows
     9/25/2019 1:30 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:30 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:30 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:30 PM Client-Info Client OS:      Windows
     9/25/2019 1:30 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:30 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:30 PM Client-Info Client OS:      Windows
     9/25/2019 1:30 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:30 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:30 PM Client-Info Client OS:      Windows
     9/25/2019 1:30 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:30 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:30 PM Client-Info Client OS:      Windows
     9/25/2019 1:30 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:30 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:30 PM Client-Info Client OS:      Windows
     9/25/2019 1:30 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     9/25/2019 1:30 PM Client-Info Client Version: 0.11.16
     9/25/2019 1:30 PM Client-Info Client OS:      Windows
     9/25/2019 1:30 PM Client-Info Server Version: 1.5.7
     9/25/2019 1:30 PM Middleware::Response ERROR: Unable to get subsection
     9/25/2019 1:30 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     9/25/2019 1:30 PM Service Sleeping for 130 seconds
    

  • Senior Developer

    @tech04 You don’t need to worry about the FOG Project certificate. This is for verifying the signature of the fog-client software components (needed as we provide auto update in SYSTEM context).

    FOG Server CA is the one you need to exchange.

    Location should be Local Machine\Trusted Authorities. But I don’t have a Windows PC at hand at the moment. This is just from the top of my head.



  • Okay, I will tinker with this. I see two certificates listed:

    • FOG Project

    • FOG Server CA

    Do both of these need to be removed? Where is the location of the correct cert? Thanks.


  • Senior Developer

    @tech04 From the messages we see in this log I am fairly sure the fog-client software on this machine was installed pointing to another FOG server with a different CA and certificate. So this is kind of the worst case that can happen. This cannot be fixed as easy as changing the settings.json file because the certificates are in the Windows cert store.

    There might be a way to remove the old CA cert and deploy new one via remote powershell commands. I have never done this and can’t promise this will work. Play with it and let us know what you get.



  • Here’s the log file.
    fog.log


  • Senior Developer

    @tech04 said in FOG Client Not Responding To New FOG Server:

    After stopping then starting the FOGservice, the log reflected the new IP address, but it also showed an RSA ERROR: Certificate validation failed.

    Right, forgot to mention that you need to restart the service or computer. Please post the full fog-client log here. There is more than one place in the code that would throw the “Certificate validation failed” message.

    Am I looking at having to uninstall/reinstall the FOG client on each workstation?

    I don’t think so. Most things can be fixed without reinstalling the client. As long as you have the certificate migrated from the old server you should be save. As we have seen with the other client it seems to work in generel.

    Possibly this one client was connected to an even older FOG server that had a different certificate?



  • I copied over a settings file with the IP address of the new FOG server, but the log still showed the old IP address. After stopping then starting the FOGservice, the log reflected the new IP address, but it also showed an RSA ERROR: Certificate validation failed. In the FOG console, there is no “Reset encryption data” button for this host. Is there another setting that would need to be changed in the settings file? Am I looking at having to uninstall/reinstall the FOG client on each workstation?


  • Senior Developer

    @tech04 The config you need to change is in C:\Program Files (x86)\FOG\settings.json. There is now way you can do this through FOG as the clients have lost contact. But you can use other means of deploying a new settings file via GPO or other client management tools.



  • @Sebastian-Roth I was able to get the creds sorted out and FOG successfully renamed this machine. Thanks.

    Now for the rest of the workstations: I added all hosts to a group, and then reset the encryption data on the group. I also edited the AD username on the group, which was blank for some reason. But the FOG client on most of these workstations has the IP address of the old server. Is there a way to bulk edit the FOG client configuration for all these workstations to point to the new server IP address?


  • Senior Developer

    @tech04 said in FOG Client Not Responding To New FOG Server:

    HostnameChanger Logon failure: unknown username or bad password, code = 1326

    Always means what the error says. AD logon credentials given are not correct. Try different settings for username like simple username as well as DOMAIN\username.

    It is a known issue that some need to use it with domain notation and others don’t: https://github.com/FOGProject/fog-client/issues/111

    I have not found the time to figure this out but my guess is that it works fine without domain if you use the default Administrator account. Or maybe it’s something to do with MS SBS server… I am not sure yet.



  • @Sebastian-Roth I reset the encryption data for one of the hosts. Looks like it got a little further, but is now running into a credential issue.

    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 7:58 AM Client-Info Client Version: 0.11.16
     9/26/2019 7:58 AM Client-Info Client OS:      Windows
     9/26/2019 7:58 AM Client-Info Server Version: 1.5.7
     9/26/2019 7:58 AM Middleware::Response ERROR: Unable to get subsection
     9/26/2019 7:58 AM Middleware::Response ERROR: Object reference not set to an instance of an object.
     9/26/2019 7:58 AM Service Sleeping for 118 seconds
     9/26/2019 8:00 AM Middleware::Communication URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     9/26/2019 8:00 AM Middleware::Response Success
     9/26/2019 8:00 AM Middleware::Communication URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&mac=90:B1:1C:9C:95:75&newService&json
     9/26/2019 8:00 AM Middleware::Authentication Waiting for authentication timeout to pass
     9/26/2019 8:00 AM Middleware::Communication Download: http://10.1.0.23/fog/management/other/ssl/srvpublic.crt
     9/26/2019 8:00 AM Data::RSA FOG Server CA cert found
     9/26/2019 8:00 AM Middleware::Authentication Cert OK
     9/26/2019 8:00 AM Middleware::Authentication No token found at C:\Program Files (x86)\FOG\token.dat, this is expected if the client has not authenticated before
     9/26/2019 8:00 AM Middleware::Authentication ERROR: Could not get security token
     9/26/2019 8:00 AM Middleware::Authentication ERROR: Could not find file 'C:\Program Files (x86)\FOG\token.dat'.
     9/26/2019 8:00 AM Middleware::Communication POST URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&authorize&newService
     9/26/2019 8:00 AM Middleware::Response Success
     9/26/2019 8:00 AM Middleware::Authentication Authenticated
     9/26/2019 8:00 AM Middleware::Communication URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&mac=90:B1:1C:9C:95:75&newService&json
     9/26/2019 8:00 AM Middleware::Response Success
     9/26/2019 8:00 AM Middleware::Communication URL: http://10.1.0.23/fog/service/getversion.php?clientver&newService&json
     9/26/2019 8:00 AM Middleware::Communication URL: http://10.1.0.23/fog/service/getversion.php?newService&json
    
     9/26/2019 8:00 AM Service Creating user agent cache
     9/26/2019 8:00 AM Middleware::Response Invalid time
     9/26/2019 8:00 AM Middleware::Response No Printers
     9/26/2019 8:00 AM Middleware::Response Module is disabled globally on the FOG server
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:00 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:00 AM Client-Info Client OS:      Windows
     9/26/2019 8:00 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:00 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:00 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:00 AM Client-Info Client OS:      Windows
     9/26/2019 8:00 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:00 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:00 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:00 AM Client-Info Client OS:      Windows
     9/26/2019 8:00 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:00 AM Middleware::Response Success
     9/26/2019 8:00 AM HostnameChanger Checking Hostname
     9/26/2019 8:00 AM HostnameChanger Renaming host to Fog_TestPC
     9/26/2019 8:00 AM HostnameChanger Renaming host inside existing domain binding
     9/26/2019 8:00 AM HostnameChanger Logon failure: unknown username or bad password, code =  1326
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:00 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:00 AM Client-Info Client OS:      Windows
     9/26/2019 8:00 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:00 AM Middleware::Response No snapins
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:00 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:00 AM Client-Info Client OS:      Windows
     9/26/2019 8:00 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:00 AM Middleware::Response No Printers
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:00 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:00 AM Client-Info Client OS:      Windows
     9/26/2019 8:00 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:00 AM Middleware::Response Success
     9/26/2019 8:00 AM PowerManagement Calculating tasks to unschedule
     9/26/2019 8:00 AM PowerManagement Calculating tasks to schedule
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:00 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:00 AM Client-Info Client OS:      Windows
     9/26/2019 8:00 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:00 AM Middleware::Response Success
     9/26/2019 8:00 AM Middleware::Communication URL: http://10.1.0.23/fog/service/usertracking.report.php?action=login&user=MS410_29\bogden&mac=90:B1:1C:9C:95:75&newService&json
    ------------------------------------------------------------------------------
    
     9/26/2019 8:00 AM Service Sleeping for 79 seconds
     9/26/2019 8:02 AM Middleware::Communication URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     9/26/2019 8:02 AM Middleware::Response Success
     9/26/2019 8:02 AM Middleware::Communication URL: http://10.1.0.23/fog/management/index.php?sub=requestClientInfo&mac=90:B1:1C:9C:95:75&newService&json
     9/26/2019 8:02 AM Middleware::Response Success
     9/26/2019 8:02 AM Middleware::Communication URL: http://10.1.0.23/fog/service/getversion.php?clientver&newService&json
     9/26/2019 8:02 AM Middleware::Communication URL: http://10.1.0.23/fog/service/getversion.php?newService&json
    
     9/26/2019 8:02 AM Service Creating user agent cache
     9/26/2019 8:02 AM Middleware::Response Invalid time
     9/26/2019 8:02 AM Middleware::Response No Printers
     9/26/2019 8:02 AM Middleware::Response Module is disabled globally on the FOG server
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:02 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:02 AM Client-Info Client OS:      Windows
     9/26/2019 8:02 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:02 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:02 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:02 AM Client-Info Client OS:      Windows
     9/26/2019 8:02 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:02 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:02 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:02 AM Client-Info Client OS:      Windows
     9/26/2019 8:02 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:02 AM Middleware::Response Success
     9/26/2019 8:02 AM HostnameChanger Checking Hostname
     9/26/2019 8:02 AM HostnameChanger Renaming host to Fog_TestPC
     9/26/2019 8:02 AM HostnameChanger Renaming host inside existing domain binding
     9/26/2019 8:02 AM HostnameChanger Logon failure: unknown username or bad password, code =  1326
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ---------------------------------SnapinClient---------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:02 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:02 AM Client-Info Client OS:      Windows
     9/26/2019 8:02 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:02 AM Middleware::Response No snapins
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:02 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:02 AM Client-Info Client OS:      Windows
     9/26/2019 8:02 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:02 AM Middleware::Response No Printers
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------PowerManagement-------------------------------
    ------------------------------------------------------------------------------
     9/26/2019 8:02 AM Client-Info Client Version: 0.11.16
     9/26/2019 8:02 AM Client-Info Client OS:      Windows
     9/26/2019 8:02 AM Client-Info Server Version: 1.5.7
     9/26/2019 8:02 AM Middleware::Response Success
     9/26/2019 8:02 AM PowerManagement Calculating tasks to unschedule
     9/26/2019 8:02 AM PowerManagement Calculating tasks to schedule
    ------------------------------------------------------------------------------```

  • Senior Developer

    @tech04 Go to the FOG web UI, edit the settings of one of your hosts showing this issue and click the big orange button “Reset Encryption Data”. Then take a look at the fog.log file on the host to see if it comes back to properly communicating with the FOG server.


Log in to reply
 

289
Online

7.1k
Users

14.3k
Topics

135.1k
Posts