ISO Boot Ubuntu 18/19 LTS



  • Hi all,
    Just hoping to get a hand with setting up ISO booting for Ubunti 18/19 LTS.
    I’ve tried following George1421’s guide and am not having luck copying the vmlinuz or boot files to the ftfpboot directory, as they do not exist on my 18.04 ISO.
    Am I able to get a hand with setting this up? Apologies, I’m relatively new to Linux. I’m not fussed on whether I’m using Ubuntu 18 or 19.



  • @xardoniak
    I was using Ubuntu 18 Server install, but I was able to get it working like this.

    I created a /images/os/ubuntu folder and copied the ubuntu ISO file contents in there.

    I created a folder /tftpboot/os/ubuntu
    There I put the initrd and vmlinuz files from the casper folder in the ubuntu iso.

    Here are the parameters I used in FOG.
    kernel tftp://192.168.160.12/os/ubuntu/vmlinuz
    initrd tftp://192.168.160.12/os/ubuntu/initrd
    imgargs vmlinuz initrd=initrd boot=casper root=/dev/nfs netboot=nfs nfsroot=192.168.160.12:/images/os/ubuntu/ ip=dhcp rw
    boot || goto MENU

    This allowed me to start the installer from that usb, but I haven’t got a working live OS running yet, though I hope to have that soon.



  • @george1421 I knew I was doing something stupid… I’ve got the Ubuntu set up screen! Thanks so much!


  • Moderator

    @xardoniak Ah, common mistake. If you leave the ${fog-ip} or what ever it was in the tutorial exactly as it was in the tutorial the fog server will dynamically replace that value with its current IP address. The other option is to just remove the dollar sign, because that is part of the variable name.

    Edit: I just went and grabbed that section of the tutorial. ${fog-ip} is the complete variable name, you can just paste it in directly (but fix the path for the different version of ubuntu)

    kernel tftp://${fog-ip}/os/ubuntu/16.04/vmlinuz
    initrd tftp://${fog-ip}/os/ubuntu/16.04/initrd.gz
    


  • OK, so I have

    • Downloaded vmlinuz file from here and placed it in /tftpboot/os/ubuntu/18.04/
    • Downloaded the netboot.tar.gz file from here, extracted and copied /ubuntu-installer/amd64/initrd.gz to /tftpboot/os/ubuntu/18.04/
    • Updated Peramaters
    kernel tftp://$10.0.70.10/os/ubuntu/18.04/vmlinuz
    initrd tftp://$10.0.70.10/os/ubuntu/18.04/initrd.gz
    imgargs vmlinuz initrd=initrd.gz root=/dev/nfs netboot=nfs nfsroot=$10.0.70.10:/images/os/ubuntu/18.04/ locale=en_US.UTF-8 ip=dhcp rw
    boot || goto MENU
    

    I am now getting this error: https://pasteboard.co/IxKBqW4.png
    Also see to the right, dir outputs for the tftboot and images directory.

    I’m sure I’ve missed something, somewhere…


  • Moderator

    @xardoniak I just downloaded 18.0.4 lts and vmlinuz is in the /casper directory. But again you need to kernel and inits from the netboot download, not what is on the dvd. This is because the netboot kernel and inits have nfs enabled to remote mount the image share.

    For 18.04 the netboot path is here: http://archive.ubuntu.com/ubuntu/dists/bionic/main/installer-amd64/current/images/netboot/



  • @george1421 I’ll copy the vmlinuz file from images/os/ubuntu/18.04/casper into tftpboot, update the parameters and report back!

    Thanks for your time!


  • Moderator

    @xardoniak While I haven’t looked into the new ubuntu version the kernel still should be vmlinuz I would think that mt86plus is wrong.



  • @george1421 Hi George!
    Yeah, I did! I have just removed and replaced my initrd.gz with installer/amd64/initrd.gz from the netboot.tar.gz file here incase I did something wrong.

    Still the same - loads the mt86plus and closes back to the main pxe boot screen once the initrd.gz file has downloaded



  • @Sebastian-Roth Hi Sebastian, thanks for the reply!

    fog@fogproject:~$ ls -al /images/os/ubuntu/18.04/casper
    total 729368
    dr-xr-xr-x 3 fog fog 4096 Nov 29 2018 .
    drwxrwxr-x 12 fog fog 4096 Sep 16 08:16 …
    -r–r--r-- 1 fog fog 14448 Jul 25 2018 filesystem.manifest
    -r–r--r-- 1 fog fog 282 Jul 25 2018 filesystem.manifest-remove
    -r–r--r-- 1 fog fog 526577664 Nov 29 2018 filesystem.squashfs
    -r–r--r-- 1 fog fog 916 Nov 29 2018 filesystem.squashfs.gpg
    -r–r--r-- 1 fog fog 54814433 Jul 25 2018 initrd
    -r–r--r-- 1 fog fog 157184000 Jul 25 2018 installer.squashfs
    dr-xr-xr-x 2 fog fog 4096 Jul 25 2018 maas
    -r–r--r-- 1 fog fog 8257272 Jul 25 2018 vmlinuz
    fog@fogproject:~$ fog@fogproject:~$ ls -al /images/os/ubuntu/18.04/casper


  • Moderator

    @xardoniak Did you read the text in red in my article, but you need to download the netboot versions of these kernels and inits. These are needed to boot ubuntu over the network. But TBH I have not tested ubuntu 18 or 19 with FOG.


  • Senior Developer

    @xardoniak What output do you get from the command ls -al /images/os/ubuntu/18.04/casper? Please post here.



  • @xardoniak said in ISO Boot Ubuntu 18/19 LTS:

    In /images/os/ubuntu/18.04/install I have the file “mt86plus”

    I’m going to make the assumption that the vmlinuz kernel file has been replaced with this, and place mt86plus into the tftp directory and test.

    I will report back!

    Nope, no luck 😞
    PXE appears to load the mt86plus file ok (states “ok” on the screen) and very quickly loads the initrd.gz file but once it hits 100%, it exits back to the main PXE boot screen.

    Server details:
    fog@fogproject:~$ ifconfig
    ens160: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 10.0.70.10 netmask 255.255.255.0 broadcast 10.0.70.255

    fog@fogproject:~$ dir /images/os/ubuntu/18.04/
    boot casper dists EFI initrd.gz install isolinux md5sum.txt mt86plus pics pool preseed README.diskdefines ubuntu

    fog@fogproject:~$ dir /tftpboot/os/ubuntu/18.04/
    initrd.gz mt86plus

    PXE Parameters
    kernel tftp://$10.0.70.10/os/ubuntu/18.04/mt86plus
    initrd tftp://$10.0.70.10/os/ubuntu/18.04/initrd.gz
    imgargs mt86plus initrd=initrd.gz root=/dev/nfs netboot=nfs nfsroot=$10.0.70.10:/images/os/ubuntu/18.04/ locale=en_US.UTF-8 ip=dhcp rw
    boot || goto MENUkernel tftp://$10.0.70.10/os/ubuntu/18.04/mt86plus
    initrd tftp://$10.0.70.10/os/ubuntu/18.04/initrd.gz
    imgargs mt86plus initrd=initrd.gz root=/dev/nfs netboot=nfs nfsroot=$10.0.70.10:/images/os/ubuntu/18.04/ locale=en_US.UTF-8 ip=dhcp rw
    boot || goto MENU



  • Forum mentioned: https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images/5

    A small update, I have managed to get the initrd.gz file and have placed that into the tftp directory though I am still unable to find the vmlinuz file.
    In /images/os/ubuntu/18.04/install I have the file “mt86plus”

    I’m going to make the assumption that the vmlinuz kernel file has been replaced with this, and place mt86plus into the tftp directory and test.

    I will report back!


Log in to reply
 

337
Online

7.4k
Users

14.5k
Topics

136.5k
Posts