Another Domain Join Issue

  • Ever since I started creating images with Windows 10 1903 EDU Pro edition I have been having issues with the computers joining the domain after image. Nothing has changed on the server side. These are brand new machines so it shouldn’t be an issue with old records existing in AD (I have had that issue before). I am sys-prepping them, but I have followed the directions concerning disabling the Fog Service and running the setup complete script. As I said, this is a process I have had great success with for many years… Until now. I don’t see any reference in fog.log to my domain. Any help is appreciated.

  • @Sebastian-Roth No, nothing in the event viewer like the last time. Like I said, if I manually start the service the first time it then automatically starts after about ten minutes or so on subsequent reboots.

  • Developer

    @Jay-Bosworth Do you see if the service is starting and crashing over and over again?

  • @Sebastian-Roth Yes, all of the Windows updates have been applied. I do all of that before I capture my audit image. I even double checked this time before I created it. Other services appear to be starting just fine.

  • Developer

    @Jay-Bosworth Do you have all the latest Windows updates installed on the image before capturing? Just asking because we have reports of the FOG client failing on systems where Windows Update kicks in.

    It sounds strange that the service wouldn’t properly start by itself. Have not seen this before. Do other services start normally?

  • @Sebastian-Roth I think we are close. FOG is still not starting automatically though. I checked the event viewer and there are no errors there so I think it just isn’t getting the command to start as opposed to last time when it was trying but was erroring out. I tried starting it manually and then restarting and it does eventually start running in that case. Without doing that, I have been waiting about 45 minutes and the status hasn’t changed to running yet.

  • @Sebastian-Roth Let me check that. I have had to change my audit and sysprep images so many times through this troubleshooting that it is possible I moved the file you sent into the folder and didn’t rename it to modules.dll.

  • Developer

    @Jay-Bosworth Do you have the file Modules.dll in C:\Program Files (x86)\FOG\??

  • @Sebastian-Roth Is this what you need?


  • Developer

    @Jay-Bosworth Can you please scroll further down in the message for the second event log entry where it says: “Exception Info: System.IO.FileNotFoundException” - does it say which file is not found??

  • @Sebastian-Roth I replaced the code I had in my “setupcomplete” file with what you sent me in the previous message. I am still seeing the same behavior. After deploy, the Fog service is stopped even though it is set to Delayed-Automatic. When I try to start the Fog Service manually, it immediately stops. I don’t see anything in the FOG log that indicates why it is immediately stopping.

    I went into Event viewer and here are the two errors it is showing when I try to start the service.



  • Developer

    @Jay-Bosworth try this (ref):

    sc.exe config FOGService start=delayed-auto
    sc.exe failure FOGService actions= restart/60000/restart/60000/restart/ reset= 120

  • @Sebastian-Roth Okay, I am apparently a bit of a dolt, but it has led to another issue along the same lines… Let me explain.

    Somewhere between upgrading to the new FOG client 0.11.16 and capturing my audit image, I failed to create the scripts folder and add my setup complete file to it. FOG Service was remaining disabled, that is why the log file was recording no information.

    I took care of that and recaptured the image. Now when I deploy the image, it is not starting the FOG service it is setting the service to “automatic” but the service is never actually starting. Each time I go into the system after restarting, the FOG service is stopped. Is there something I needed to change in the setupcomplete file for the new FOG client?

    This is the contents of my setupcomplete file that I have been using flawlessly for the past several years:

    sc config FOGService start= auto
    shutdown -t 0 -r

    Thank you,

  • Developer

    @Jay-Bosworth Ok, re-reading the whole topic again I think we should try to tackle this from scratch again:

    • Have the new 0.11.16 fog-client installed before capturing the image.
    • Exchange the file C:\Program Files (x64)\FOG\Modules.dll with the one downloaded here.
    • Make sure there is no task scheduled for the host you want to test this on (as we have seen in one of the fog.log files)!
    • Enable the checkbox to forced rename/join for this host (FOG web UI -> host list -> test host’s settings -> Active Directory tab -> Name Change/AD Join Forced reboot?

    Now deploy the machine, let it boot up, wait for it to do all the automatic background stuff plus another 10 minutes. Then grab a copy of fog.log and post here.

  • Developer

    @george1421 While we did have several requests about fog-client issues on Windows 10 1903 none of them had clearly to do with 1903 as far as I remember (feel free to prove me wrong on this - I have so many things going on and can’t follow it all 100%).

    @Jay-Bosworth From the logs posted so far I simply can’t see there being a fog-client issue. Don’t get me wrong. I am not saying there is none but we just have not nailed it down if there is one!

  • @george1421 Thanks for the reply. That makes sense to me. I figured it has to be something small and new with 1903 because it never happened before and nothing on my server has changed. Luckily right now I only have a handful of machines to image and I can wait it out until a new version comes out or something. Worst case as you said, I can add it to my unattend file. Thanks again.

  • Moderator

    @Jay-Bosworth That client is awaiting a scheduled reboot as far as I can tell, which is why other actions aren’t happening, you need to sort that out before any useful info is logged to begin with.

  • Moderator

    @Jay-Bosworth Its possible that changes in release 1903 have caused difficulties with the fog client. I’ve noticed a lot of posts regarding the fog client and 1903 lately. There has to be something going on that we don’t understand just jet.

    While I can’t really help with the fog level connect to domain, I can say that I don’t use the fog client for naming the host or connecting it to AD, I let the unattend.xml file do that. I don’t have a problem using this method.

  • @Sebastian-Roth So that’s it? I am just SOL? I can’t really change what it is doing automatically. I did exactly what you asked me to.

  • Developer

    @Jay-Bosworth Sorry but there is no valuable information in that log. every loop cycle on hostname changer is either “Users still logged in and enforce is disabled, delaying any further actions” or “A power operation is pending, aborting module” (offical scheduled reboot via fog-client). We can’t help you if we don’t see what’s exactly going on when it tries to join.

Log in to reply