Missing Data After Fog 1.5.7 Upgrade



  • Was running fog 1.5.6 and i was unable to access the gui, kept getting an error the database couldn’t connect. If i had to guess Ubuntu did an update and broke the connection. I downloaded latest version of fog and ran the installer , however it kept failing on installing the mariadb server and client. So i installed Mariadb 10.3 manually, re ran the setup of maria db server and setup a password. Re ran the fog 1.5.7 installer and still getting the error the db is not accessible. I then went into var/www/fog /lib/configclass.php and entered the new password. Now the issue is fixed on seeing the gui, however now all my data is missing , users, hosts, images. What do i do to fix this ? Thanks for the help.

    Ray


  • Developer

    @Ray-Zuchowski Give this a try:

    sudo -i
    mv /var/lib/mysql /var/lib/mysql-mariadb
    apt-get remove mariadb-client mariadb-server
    cp -a /var/lib/mysql-5.7 /var/lib/mysql
    apt-get install mysql-client mysql-server
    systemctl start mysql
    


  • The folder is there.


  • Moderator

    @Ray-Zuchowski I think uninstall mariadb and install mysql should work fine, I’m not 100% sure, but that’s where I’d start.

    But check the mentioned folder and see if you can find the fog database first.



  • @Quazz How do i do this ?


  • Moderator

    This is a known problem on Ubuntu (the database moving when changing to mariadb)

    You will likely find your fog database in /var/lib/mysql-5.7

    Currently, FOG does not try to move to mariadb on Ubuntu for this reason.

    If possible, going back to mysql would be the best option I reckon.


Log in to reply
 

375
Online

6.2k
Users

13.5k
Topics

127.5k
Posts