No DEFAULT or UI configuration directive found!



  • [EDIT / SOLVED]
    [ Problem of configuration in the options 66 of Windows Server 2003.]

    Hello
    When i’m booting on PXE with my computers, I have the following message:
    [QUOTE]No DEFAULT or UI configuration directive found![/QUOTE]

    My server is Ubuntu server 12.04 and is running fog .32 ; the DHCP service is on a Windows Server 2003 and the options 66 and 67 are configured.
    Do you have any suggestion on what would cause that issue and how to solve it ?

    here’s the whole message ;

    [QUOTE]PXELINUX 4.01 debian-20100714 (etc)
    !PXE enry point found (we hope) at 9B82:00D6
    UNDI code segment at 9B82 len 43C0
    UNDI data segment at 97EA len 3980
    Getting cached packet 01 02 03
    my IP adress seems to be AC11032D 172.x.x.x
    ip=172.x.x.x etc)
    BOOTIF=(…)
    SYSUUID=(…)
    TFTP prefix :
    Trying to load: pxelinux.cfg/default ok
    no DEFAULT or UI configuration directive found!
    boot:[/QUOTE]

    thank you. BTW, i had used FOG in previous job on an 10.04 ubuntu and everything ran smoothly. FOG is really a great and powerful solution of cloning. Thank you for bringing that to us



  • SOLVED !
    Indeed, to reply to your message, I stayed connected to internet during the installation of Fog, and disconnected as soon as possible. I ran the installation twice in fact (once while connected, the other time disconnected).

    Anyway, here’s the cause of the problem -which makes me feel dumb…
    The person who worked before I came configured a 066 option in the extended field.
    I didn’t knew anything about that ; I did my configuration in the main DHCP field.
    His PXE came first and the PXE was done on a server (still in use) that no longer hosts a up to date PXE.

    Thank you for your support. Now It’s (at least) time for fun !! :)


  • Moderator

    FOG requires network connectivity to install itself. part of the install is to grab packages from the web via APT such as DHCP, TFTP, Apache, mySQL, etc.



  • [Up]
    As i’m trying to find out where the problem comes from, i’ve done several tests :

    I’ve installed Ubu desktop 12.04 on a new server.
    I downloaded the fog install, unplugged the server from network & ran the install
    I used the options below ;
    [LIST]
    []-[N] route for DHCP
    [
    ]-[N] DNS server
    [*]-[Y] use fog’s DHCP
    [/LIST]
    I configured it out, and then i found a good old switch. I used it to plug the server and another computer for testing.
    The PXE boot ran without problem.
    I stopped the DHCP on the server ([CODE]#sudo service isc-dhcp-server stop[/CODE])
    I plugged the Good’Old Switch on the network and tested on the server the network connection
    I configured the 66 option on my WS2k3 to point to the server

    and… Still the same message, my Good’Old “[SIZE=1]no DEFAULT or UI configuration directive found!”[/SIZE]

    The problem seems to come from the network, rather than the FOG server.
    Any idea how to find the source of the problem ?[SIZE=1][/SIZE]



  • Thank you for your reply !
    here is the content of
    [CODE]#vi /tftpboot/pxelinux.cfg/default[/CODE] (the smiley’s wrath does fear me ! )

    [CODE]DISPLAY boot.txt
    DEFAULT fog.local

    LABEL fog.local
    localboot 0

    LABEL fog.memtest
    kernel fog/memtest/memtest

    LABEL fog.reg
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000
    ip=dhcp dns=172.17.1.3 mode=autoreg keymap= web=172.17.1.10/fog/ loglevel=4 cons
    oleblank=0

    LABEL fog.reginput
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000
    ip=dhcp dns=172.17.1.3 mode=manreg keymap= web=172.17.1.10/fog/ loglevel=4 conso
    leblank=0

    PROMPT 1
    TIMEOUT 130 [/CODE]

    Does it seems correct ?


  • Moderator

    paste the contents of your /tftpboot/pxelinux.cfg/default file. USE CODE TAGS or suffer the wrath of the smilies…



  • Still the same problem. i’ve tried with “pxelinux.cfg/default” after the “boot:” prompt, and then I have the following message:

    “Invalid or corrupt kernel image.”

    I’ve tried other entries (like fog/memtest/memtest ) but it returns "could not find the kernel image : …"
    I’ve done " # cp /tftpboot/fog/memtest/memtest /tftpboot/pxelinux.cfg/memtest"
    and i have the same issue (could not find… ).
    I’ve tried to make a file with only an entry and to save it to /tftpboot/pxelinux.cfg/test but still it is not found.

    Any idea of where can I search to find out why “pxelinux.cfg/default” returns something and not the other test ?



  • Do you think the problem could come from the routers or the switches between the server and the client ?
    –EDIT
    I’ll give a try to use the 10.04 server on an isolated network. I’ll keep trace of my ( probably bad) process of debuging the issue.
    I still can’t find any valuable instruction to put to the “boot:” prompt I got.

    I’m coming to the idea that Tftp is not enabled on the school’s network. May the loading of the file pxelinux.cfg/default isn’t using that protocole ?
    I hope I can sort it all out !



  • I’ve installed fog .32 on an ubuntu 10.04 and tried to boot on it but the problem is still here. Anyone has an idea about that problem? I’m not familiar with PXE booting, and I can’t sort out where the problem could come from.

    The web interface works but I can’t boot on PXE, neither to display Fog Menu nor to launch a scheduled task.
    And still, i don’t know what can I write at the “boot:” to test or launch manually the menu.

    -sorry for bad english


Log in to reply
 

385
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.