Very slow cloning speed on specific model

  • Hello FOG people!

    I have a strange problem.
    Working with FOG about a year. Version 1.5.4 installed on CentOS 7 at VirtualBox environment. Deploying Win10 image to Dell and HP laptops. Everything was fine, but a new model HP EliteBook 840 G6 unavailable to cloning because of very low speed of Partclone - about 6 MB/min. It can’t be a network issue because of previous HP 840 G5 model and all DELL models are cloning normally. And it isn’t a specific laptop problem, I have checked 3 laptops from this model and all have the same problem.

    Maybe somebody had the same problem?

    Thanks for helping,

  • @oleg-knysh has this continued to work for you? We have a very similar issue with the HP EliteBook 840 G6 laptops but running Fog with Partclone 0.3.12 didn’t help us. All other laptops (Lenovos or 840 G5) work 100% of the time, but out of a batch of 20, only 2 G6 laptops imaged successfully - the rest hang on the initial partclone section or the image deploy is very slow. Hardware and BIOS are the same.

  • Last update:

    Update FOG to didn’t help
    Update FOG kernel to 5.1.16 didn’t help
    Update Partclone to 0.3.12 (see @Quazz post) did help

    Maybe it’s some spontaneous fix as it was before :)
    I’ll update if still will be issues with imaging.

  • Thank you for helping,

    Just now (before upgrading FOG and Partclone) I’ve reimaged one new HP 840 G6 with the same SSD Toshiba, and the same BIOS version. Everything was fine. The speed was 1.5-1.6 GB/min.
    I raise my hands :)
    I don’t know where is the difference between “fast” and “slow” laptops.

    But anyway I’ll upgrade my FOG server.

  • Developer

    @jondeong Just an FYI: the update to dev-branch would have updated the KERNEL RAMDISK SIZE for you to what is going to be the new size requirement. that was almost certainly the cause of the kernel panic.

  • We recently received the new HP 8460 G6 which has a Western Digital PC SN520 NVMe SSD hard drive. We experienced the same problems where the imaging process with partclone was SUPER slow <10MB/min. This same fog installation had no issue with the HP 840 G5 with a Samsung SSD hard drive.
    I first tried the experimental init.xz that @Quazz recommended but it failed with a kernel panic.
    I then upgraded fog to the latest dev-branch and re-tried the init_partclone.xz that @Quazz recommended.
    That solved the issue, I’m imaging the G6 laptop at 1.31GB/min.
    Thank you for solving my problem @Quazz.


  • Moderator

    @oleg-knysh Download the init file from the provided link, put it in /var/www/fog/service/ipxe

    Give it a name that isn’t init.xz (eg init_partclone.xz) so it doesn’t overwrite)

    Then you can change the host init file in the host settings or globally under FOG Settings -> TFTP servers (eg init_partclone.xz)

  • @Quazz Do you have some manual as I can upgrade the Partclone?

  • Moderator

    @oleg-knysh You may also be interested in trying out an experimental init.xz that uses a newer version of partclone. Though the github issue does not indicate this resolves the issue for them, perhaps it will in this case. It’s worth a shot anyway.

  • @Quazz I checked, exactly same disks were in the previous HP laptop model - 840 G5. So I think the next test I’ll do it’s downgrading BIOS version to the previous version.

  • Moderator

    @oleg-knysh Here is the issue on the partclone github:

    Currently still unresolved unfortunately.

    I can only recommend trying to update BIOS and update firmware of the disks.

  • Last status:

    Another “Baggy” laptop with a low Partclone speed:
    HP 840 G6
    SSD: Toshiba KXGZNV512G
    Let’s name it Laptop A

    Good laptop:
    Dell E5470
    SSD Intel
    Let’s name it Laptop B

    Testing process:

    1. SSD A (from a buggy laptop) inserted to laptop B - worked fine (SSD itself is not a problem)
    2. SSD B (from a good laptop) inserted to laptop A - worked fine (the laptop itself is not a problem)
    3. SSD A inserted back to the laptop A - worked very slow

    Very strange situation. Partclone is not working with a specific laptop and specific SSD.

  • @Quazz I’ll check SSD model for the next “baggy” laptop. Today for Crucial P1 NVMe M.2 1TB worked without issues

  • Moderator

    @oleg-knysh I do recall a specific SSD model (or multiple) having absurdly low speeds in partclone.

    Do you know what models they are?

  • The new test ran without this problem. The Partclone ran fast as usual and imaging took less than a minute.
    Maybe it depends on the type of SSD disk…?

  • @Sebastian-Roth I don’t know how, but it helped. Maybe something else happened at the same time. As I wrote need to more tests

  • Developer

    @oleg-knysh This doesn’t make sense. Removing the partitions manually doesn’t influence the speed.

  • The workaround was found.
    When I used diskpart and removed all partitions from the disk before cloning (used boot from regular Win10 installation usb media), after that Partclone ran as usual.
    Need to test on more laptops to be sure.

  • Moderator

    @oleg-knysh This is a very strange issue. The only recommendation/question I have at the moment is what version of the FOS Kernel are you using? The latest version is 4.19.64

    I also wonder if you update to the latest version of FOG (1.5.7) to see if any of the fixes since 1.5.4 will address this issue. I don’t have a high confidence that it will fix this speed issue. I know it will solve some disk structure problems.

Log in to reply