SOLVED TFTP failure for PXE boot

  • Hello,
    I started experiencing this last week. DHCP is managed by an an outside provider, and they insist that setting 66 and 67 have been updated to make fog the PXE boot server. That in mind they just updated their windows server, and and firewall software. I can use terminal to reach it with tftp, and the status is active. I rolled back to a previous snapshot that worked 100% and I get the same timeout.

    Any suggestions?

    Thank you


  • Turns out someone was annoyed that our network went down and plugged in their personal router. Thank you for the advice.

  • Moderator

    @dskinner Two things come to mind

    1. A miss-configured dhcp server
    2. A rouge SOHO dhcp server/router/access point on your network.

    You can find out for sure if you use wireshark on a computer connected to the same subnet as the computer in the picture. Set the capture filter to port 67 or port 68 or use the display filter of bootp. Start wireshark then pxe boot the computer.

    In wireshark you will see a DISCOVER packet from your pxe booting client and then one or more OFFERS from every dhcp server that heard the DISCOVER packet. If you should only have one DHCP server on your network then you should see only one OFFER reply. Every other OFFER than from your main dhcp server should be considered suspicious.

  • @george1421 thank you, that is not the is not an IP that we use in our network. I will look into that.

  • Moderator

    @Sebastian-Roth said in TFTP failure for PXE boot:

    Is really your FOG server IP?

    This is the first thing that stood out to me. Is your fog server or is that your dhcp server/router/gateway? I might understand what is wrong if that is your ISP router.

  • Senior Developer

    @dskinner DHCP server does not seem to send upstream gateway/router information to your client or a firewall is blocking TFTP protocol between the different subnets.

    The other thing I can imagine is you have a rough DHCP server within your network! Is really your FOG server IP?