Fresh Install - CentOS7 - FOG 1.5.7 - "database is updated/installed" - blank screen in browser



  • I have been attempting to install a new instance of FOG onto a fresh install of CentOS 7.
    All seems to be going well right up until I get to the following prompt:

     * You still need to install/update your database schema.
     * This can be done by opening a web browser and going to:
    
       http://<HOST_IP>/fog/management
    
     * Press [Enter] key when database is updated/installed.
    

    I have seen this problem mentioned before in these forums and I have attempted pretty much ALL of the fixes mentioned.

    1. MariaDB service is up and running. I have tried both with blank password and entering a password for root. No difference.
    2. HTTPD error logs show NO problems
    [root@foghost ~]#  tail -100 /var/log/httpd/error_log
    [Mon Aug 12 18:09:30.227899 2019] [core:notice] [pid 3008] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
    [Mon Aug 12 18:09:30.229082 2019] [suexec:notice] [pid 3008] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Mon Aug 12 18:09:30.255955 2019] [lbmethod_heartbeat:notice] [pid 3008] AH02282: No slotmem from mod_heartmonitor
    [Mon Aug 12 18:09:30.272326 2019] [mpm_prefork:notice] [pid 3008] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16 configured -- resuming normal operations
    [Mon Aug 12 18:09:30.272356 2019] [core:notice] [pid 3008] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    
    1. HTTPD Access logs shows a single line with a server error 500
    <MY WKSTN IP> - - [12/Aug/2019:18:09:50 -0400] "GET /fog/management/ HTTP/1.1" 500 - "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0"
    

    If I “refresh” the page, I get a WHOLE bunch of those same entries.
    4. mysql from the command line shows that fog database has not been created, but create/drop of a fog2 db performed as expected. (i.e. it worked to create and delete)

    Any help would be appreciated.

    Thanks, Dave



  • OK, well, as an update, It looks like I was banging my head against a bad repo for the php stuff
    I walked through the logs of a successful install (by a colleague) and compared them.

    All is good now.

    Thanks



  • [root@foghost ~]# getenforce
    Permissive
    [root@foghost ~]# systemctl status firewalld
    Unit firewalld.service could not be found.
    [root@foghost ~]# systemctl status iptables
    Unit iptables.service could not be found.
    [root@foghost ~]# systemctl status ufw
    Unit ufw.service could not be found.
    

  • Moderator

    @InfoOverload

    [Mon Aug 12 18:09:30.227899 2019] [core:notice] [pid 3008] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0

    This tells me that you did not do the prerequisites before installing FOG (maybe).

    1. Set selinux to permissive
    2. Disable the linux firewall

    Do you do these steps?


Log in to reply
 

396
Online

6.1k
Users

13.4k
Topics

126.4k
Posts