• Dear reader,

    Although a lot of information can be found on the Snapin hash does not exist error, I can’t get my problem solved :-(. My goal is to re-use a PowerShell script but, for sake of simplicity, I’m using the 7zip MSI example from the wiki. When creating and running Snapin 7-zip-x64 everything is fine and 7-zip is correctly installed. But when creating a New Snapin (7-zip-x64b) and choosing 7z1900-x64.msi from the Snapin File (exists) drop down menu and running it, I get the Snapin hash does not exist error.

    When I look in the snapins table in the fog database, I see an empty sHash field for the 7-zip-x64b Snapin, so I think the problem is with the FOG server. Or maybe I misinterpreted the Snapin File (exists) drop down menu completely? It seems unlikely that only I am running in to this problem…

    I also rebuild the FOG-client to log the Ideal and Actual Snapin Hash and confirmed snapin.Hash is empty.

    I’m using FOG Version: (1.5.7) with no extra Storage Nodes on a fresh installation of Ubuntu 18.04.3 LTS. The host I’m running the Single Snapin task on is Windows 10 LTSB x64.

    Any help would be greatly appreciated! Needless to say I’m willing to provide more information or create an issue on GitHub if this is indeed a bug.

    J den Hartog

    PS I already ran into this problem on FOG Version: 1.5.6 so it has nothing to do with the recent 1.5.7 release.

  • Hi EduardoTSeoane,

    Thank you! Restarting the FOGSnapinHash service with systemctl restart FOGSnapinHash worked! I did check if this service was running but never thought about restarting it. This gave me some more energy to search the forum.

    I found this post also noting the FOGSnapinHash interval is 30 minutes. Then I found one can change that interval on the FOG server by:
    FOG Configuration >> FOG Settings >> FOG Linux Service Sleep Times >> SNAPINHASHSLEEPTIME from 1800 seconds to …

    I still think it’s very strange someone should have to wait for 30 minutes after creating a Snapin that reuses a file with a default FOG installation, as it seems to be a common thing to do because of the Snapin File (exists) drop down menu in the GUI, but I’m glad and thankful my problem is solved!

    J den Hartog

  • @JdenHartog said in Snapin File (exists):

    .5.7 release.

    do you try to restart de FOGSnapinHash service on the server?