Hi EduardoTSeoane, Thank you! Restarting the FOGSnapinHash service with systemctl restart FOGSnapinHash worked! I did check if this service was running but never thought about restarting it. This gave me some more energy to search the forum. I found this post also noting the FOGSnapinHash interval is 30 minutes. Then I found one can change that interval on the FOG server by: FOG Configuration >> FOG Settings >> FOG Linux Service Sleep Times >> SNAPINHASHSLEEPTIME from 1800 seconds to … I still think it’s very strange someone should have to wait for 30 minutes after creating a Snapin that reuses a file with a default FOG installation, as it seems to be a common thing to do because of the Snapin File (exists) drop down menu in the GUI, but I’m glad and thankful my problem is solved! Best, J den Hartog