No configuration methods succeeded

  • Hello everyone I’n new to the fog ans setting everything up so here goes.
    I originally posted thins under windows issue but now that I think of it it’s not really a winodws issue but a fog one.

    My fog setup is a computer running a VM with 4gb of ram. I have setup fog successfully and have used it on two computers so far without issue. except this one it’s a Lenovo G50-70 laptop the error message it is giving me is No configuration methods succeeded and then it says at the end DHCP failed hit ‘S’ for the iPXE shell: Reboot in 10 secounds.

    I looked in the BIOS and it looks to be setup correctly with legacy PXE boot. I’m at a loss



  • FINALLY!! I figured out the problem. It would always fail the PXE boot in legacy and for some reason I used EFI PXE boot and it now works on this laptop.

  • Update I used a dummy switch i had laying around it’s basically a 10/100 switch that is unmanaged. I have inserted that between my building switch and the PXE computer as mentioned by george. it still doesn’t let me PXE boot on this laptop. Here are my default PXE settings on the laptop. PXE 1.jpg

    PXE 2.jpg

    PXE 3.jpg Is the FOG IP I setup during install.

  • Developer

    @blong10 Still try using a dumb mini switch as suggested by George. Other computers working on the same location doesn’t mean much. Some network cards might just behave differently. Or the port used is configured different.

  • Just a quick update i took this laptop to another location that has FOG and it did the same exact thing. All other computers worked at this location except mine. I believe this to be a hardware issue with my laptop I found a way to edit the config on the PXE but have had no success no far.

  • @Quazz I’m using FOG as a dhcp server how would I go about changing that setting.

  • Moderator

    Sometimes you have to use a different pxe file. So try ipxe.pxe instead of undionly.kpxe at your DHCP server (don’t know if that’s your FOG server or not) as a boot option

  • Moderator

    I’m sure your fog server is setup correctly. I want to focus on your target computer. More specifically the network connection. I feel this is a spanning tree issue. As a quick test, do you have a (dumb) unmanaged switch? The dumber the better, like a cheap $30 amazon switch? If you do insert that between your building switch and your pxe booting computer. See if that resolves your issue.

    If it does then you will need to get your networking group to look into that building switch. They need to change the STP (spanning tree protoocol) from standard STP to one of the fast STP protocols like RSTP, MSTP, fast-STP, port-fast or whatever your switch vendor calls it.

Log in to reply