Snapin hash does not exist

  • Ubuntu 18.04.2

    After migrating my server files and database, I am not able to get the snapins to work.

    In the logs of the client this is what I am seeing:

     8/5/2019 10:49 AM Client-Info Client Version: 0.11.16
     8/5/2019 10:49 AM Client-Info Client OS:      Windows
     8/5/2019 10:49 AM Client-Info Server Version:
     8/5/2019 10:49 AM Middleware::Response Success
     8/5/2019 10:49 AM SnapinClient Running snapin Set IP Address ONLY 
     8/5/2019 10:49 AM SnapinClient ERROR: Snapin hash does not exist

    I have tried based on another thread to go into the database and set null to sHash column. I did do that in MariaDB as it appears that is now the database to which FOG uses. Re-ran the installer. Still getting the same error and database shows nothing in the sHash column.

    Any ideas on how to fix this?

  • @Sebastian-Roth

    Thank you for your help!


    You are absolutely right. I always struggle to keep the copying behavior between Linux and robocopy. Sure enough there was a snapin folder inside of the snapin folder. I thought that I had checked that but probably just saw that files were there and did not pay attention to the path. The hashes now exist and I saw that in the logs that it was generated and deploying of those snapins now work as expected.

    I appreciate everyone’s help and willingness :)

  • Moderator

    If a file doesn’t exist, it won’t get a hash, I believe, so verify that the snapin files still exist.

  • Developer

    @quinniedid Can’t really figure out what’s going wrong here. Would you be able to add some debug print outs to the PHP code to help us figure this out? I’ll give instructions if you confirm.

  • Developer

    @quinniedid Strange. I will take a look at the code as soon as I find a bit of time.

  • @Sebastian-Roth
    Attached is the log. Looks like the hash isn’t ever generated…

  • Developer

    @quinniedid Please upload your full /var/log/fog/fogsnapinhash.log here.

  • @Sebastian-Roth

    Here is the command output:

    admin@fog-server:/var/www/fog/service/ipxe$ ps ax | grep FOGSnapinHash
     31163 ?        Ss     0:00 /usr/bin/php -q /opt/fog/service/FOGSnapinHash/FOGSnapinHash &
     31186 ?        S      1:06 /usr/bin/php -q /opt/fog/service/FOGSnapinHash/FOGSnapinHash &
    113518 pts/1    S+     0:00 grep --color=auto FOGSnapinHash

  • Developer

    @quinniedid Is the FOGSnapinHash service running on your FOG server? Run ps ax | grep FOGSnapinHash and post output here.

Log in to reply