PXE-E53: No boot filename recieved



  • Hi team, I am trying to image my windows 7 home and I have some problem using PXE boot. I got the error when the computer was booting. I think the target computer did not detect the fog server computer. Even IP address did not appear.
    alt text
    And I have started the dnsmasq service in the Ubuntu computer which installed fogs server. And have configured it with correct content.



  • @george1421 I got some tricky ways to find if dnsmasq is using the configuration that we created. In the directory /etc/dnsmasq.d/, we created the configuration file, but if there is no other file called README, I think dnsmasq did not use the configuration file. But after I updated dnsmasq, there is a new file called README. And it works!!! I am not sure if my thoughts was right. But it got working in my case.



  • @Sebastian-Roth Thank you Sebastian. I got it worked. Thank you so much for your patient help. I really appreciate.


  • Moderator

    @weidongyan And you have confirmed that dnsmasq is running on the fog server ps aux|grep dnsmasq AND the pxe booting client are on the same subnet?



  • @george1421 Hi George, it worked!!! After I made update for dnsmasq. I was thinking about that dnsmasq did not use the configuration that I created to run. So I was updating it and it worked. Thank you.



  • @george1421 Hi, George. Unfortunately, I still got the same problem here with that issue fixed. My configuration is like this

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,192.168.88.40
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,192.168.88.40
    dhcp-boot=net:UEFI,ipxe.efi,,192.168.88.40
    dhcp-boot=net:UEFI64,ipxe.efi,,192.168.88.40
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=192.168.88.40,proxy
    

  • Moderator

    @Sebastian-Roth said in PXE-E53: No boot filename recieved:

    Please check your config again. All the places where you have <192.168.88.40> should actually be 192.168.88.40 without the tag characters!!

    +1 That’s exactly the problem.

    There is another tutorial on how to install dnsmasq service here: https://forums.fogproject.org/topic/12796/installing-dnsmasq-on-your-fog-server


  • Developer

    @weidongyan said in PXE-E53: No boot filename recieved:

    dhcp-range=<192.168.88.40>,proxy

    Please check your config again. All the places where you have <192.168.88.40> should actually be 192.168.88.40 without the tag characters!!



  • @Sebastian-Roth I was having trouble with starting dnsmasq service, saying bad dhcp-range which pointed to the end of the configuration was something wrong. I tried to reinstall dnsmasq service and now it is working now. I am not sure if there is some connection between these two problem.



  • @Sebastian-Roth Status of dnsmasq:

    ● dnsmasq.service - LSB: DHCP and DNS server
       Loaded: loaded (/etc/init.d/dnsmasq; generated)
       Active: active (exited) since Tue 2019-07-30 16:02:47 EDT; 9min ago
         Docs: man:systemd-sysv-generator(8)
      Process: 4654 ExecStop=/etc/init.d/dnsmasq stop (code=exited, status=0/SUCCESS
      Process: 4655 ExecStart=/etc/init.d/dnsmasq start (code=exited, status=0/SUCCE
    
    Jul 30 16:02:47 genesicadmin-PowerEdge-840 systemd[1]: Starting LSB: DHCP and DN
    Jul 30 16:02:47 genesicadmin-PowerEdge-840 systemd[1]: Started LSB: DHCP and DNS
    

    The content of the configuration:

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,<192.168.88.40>
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<192.168.88.40>
    dhcp-boot=net:UEFI,ipxe.efi,,<192.168.88.40>
    dhcp-boot=net:UEFI64,ipxe.efi,,<192.168.88.40>
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=<192.168.88.40>,proxy
    

  • Developer

    @weidongyan Please run sudo systemctl status dnsmasq and post output here. As well I may ask you to post the full content of your dnsmasq configuration file.



  • Because I cannot control the DHCP, so I did what it says in the article.


Log in to reply
 

517
Online

6.2k
Users

13.6k
Topics

128.2k
Posts