Install Debian 10 and Fog getting asked for tftp server.



  • Using:
    Intel® Xeon® CPU X5450 @ 3.00GHz, 4 cores
    32gb Memory
    8TB drive space
    Debian 10
    Apache version 2.4.38
    MySQL version 10.4.6-MariaDB
    ISC DHCPd version 4.4.1

    I can enter my Server ip: 10.10.2.58 and it will continue

    here is my dhcpd.conf file(it is not formatting right here)

    # DHCP Server Configuration file.
    # see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    
    
    # DHCP Server Configuration file.
    # see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    
    
    option space PXE;
    option PXE.mtftp-ip    code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16; # RFC4578
    
    
    
    
    
    subnet 10.10.2.0 netmask 255.255.255.0 {
    option routers 10.10.2.1;
    option domain-name-servers 10.10.1.140, 10.10.1.141;
    option domain-name "co.merced.ca.us";
    option subnet-mask 255.255.255.0;
    default-lease-time 21600;
    max-lease-time 43200;
    }
    
    
    
    subnet 10.6.254.0 netmask 255.255.255.0 {
    option routers 10.6.254.1;
    range 10.6.254.100 10.6.254.200;
    option domain-name-servers 10.10.1.140, 10.10.1.141;
    option domain-name "co.merced.ca.us";
    option subnet-mask 255.255.255.0;
    default-lease-time 21600;
    max-lease-time 43200;
        class "UEFI-32-1" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
        filename "i386-efi/ipxe.efi";
        }
    
        class "UEFI-32-2" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
         filename "i386-efi/ipxe.efi";
        }
    
        class "UEFI-64-1" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
         filename "ipxe.efi";
        }
    
        class "UEFI-64-2" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
        filename "ipxe.efi";
        }
    
        class "UEFI-64-3" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
         filename "ipxe.efi";
        }
    
        class "Legacy" {
        match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
        filename "undionly.kkpxe";
        }
    }
    

    [Mod note] added code block for readability -Geo


  • Moderator

    @MTrejo2019 Ok the {next-server} tag is missing from your config file.

    ref: https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence#Example_1

    next-server 192.168.1.1;

    should be in the dhcp block for the imaging network.



  • that worked, I added the other lines from that section also.

    Thanks, Moe. make as solved please

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 10.10.2.58;
    authoritative;
    

  • Moderator

    @MTrejo2019 Ok the {next-server} tag is missing from your config file.

    ref: https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence#Example_1

    next-server 192.168.1.1;

    should be in the dhcp block for the imaging network.



  • yes linux not fog. They are on the same server though.


  • Moderator

    @MTrejo2019 So just to be clear you are running your dhcp server in linux but not on the FOG server?


Log in to reply
 

385
Online

7.5k
Users

14.6k
Topics

137.5k
Posts