Windows 7 Machines on Network pickup Fog Server as DHCP Server



  • Some of the Windows 7 machines on the network that have nothing to do with Fog are picking up the Fog server address as the DHCP server (as listed when I run ipconfig /all), but they are still able to get an IP address from our normal DHCP server (running on our domain controller). When this happens, their connection to the network doesn’t work properly and they can’t get on the Internet. I setup the Fog server to be a proxyDHCP and I’m able to capture images/image machines just fine. I thought maybe it was any Windows client that was on the same subnet as the Fog server, but that is not the case since there are many machines on that subnet that don’t have this issue.

    Has anybody seen a situation like this? Any help would be appreciated.

    Thank you!



  • @Sebastian-Roth Thanks for your help! That fixed the issue.


  • Developer

    @jramos76 The isc-dhcp-server and dnsmasq ProxyDHCP are two separate things so stopping and disabling one doesn’t influence the other one.

    sudo systemctl stop isc-dhcp-server
    sudo systemctl disable isc-dhcp-server
    

    The later command disables the DHCP server so it doesn’t come back up on reboots.



  • @Sebastian-Roth Here is the result of the command:

    administrator@fog:~$ sudo systemctl status isc-dhcp-server
    [sudo] password for administrator:
    ● isc-dhcp-server.service - ISC DHCP IPv4 server
    Loaded: loaded (/lib/systemd/system/isc-dhcp-server.service; enabled; vendor
    Active: active (running) since Fri 2019-07-26 09:16:09 PDT; 5min ago
    Docs: man:dhcpd(8)
    Main PID: 1317 (dhcpd)
    Tasks: 1 (limit: 4915)
    CGroup: /system.slice/isc-dhcp-server.service
    └─1317 dhcpd -user dhcpd -group dhcpd -f -4 -pf /run/dhcp-server/dhcp

    It looks like it is running. How do I stop it and if I stop it, will that stop the proxyDHCP which I want running for our clients we need to image using PXE boot?


  • Developer

    @jramos76 Possibly you installed for with DHCP enabled? Run sudo systemctl status isc-dhcp-server (or systemctl status dhcpd if you have CentOS/RHEL) to see if the service is running.


Log in to reply
 

418
Online

6.1k
Users

13.4k
Topics

126.3k
Posts