Cannot create Tasks, Task Manager Blank



  • Trying out Fog and trying to create an image and was getting to do my first upload to create the image and I ran into a problem creating a task to do the upload.

    I click on my Host Management, then select the Host I want to make an image from then click on “Basic Tasks” on the left side and selected “Upload”. Once I left click “Upload” it takes me to the Task Management section but all I have is a blank page with the Fog Menu at the top and below that it says Task Management and doesn’t allow me to do anything else.



  • Thanks rma (a year later), that solved my issue too! For anyone else running FOG headless, this single command fixes it:

    sed ‘s:&$tmp:$tmp:’ -i /var/www/fog/management/includes/tasks.confirm.include.php

    For those unfamiliar with sed, the command simply replaces “&$tmp” with “$tmp” in the file.



  • This post is deleted!


  • Amazing… it worked perfectly :)


  • Moderator

    Newer versions of PHP no longer accept function calls with arguments explicitly passed by reference. It’s been deprecated for several releases of PHP, but still worked. It does not work anymore. The function definition must specify whether the argument is passed by value or by reference, and the function call just needs to specify the variable name or value without the &



  • It’s just magic, i replaced the “&$tmp” and it works for me.
    Anyone knows what’s the source problem?

    A php update?

    Thanks for the help gents!

    Regards,
    Fred



  • Well, thank you for your suggestions chad-bisd; I think we’ve found a solution. Every time I would try to schedule a task I’d see another error similar to the one above show up in the apache logs. At the end of the line I found “&$tmp”. After removing the ‘&’ symbol I would get another error, but referencing new line, which would of course have “&$tmp” at the end. I finally did a search/replace on all instances of “&$tmp” replacing them with “$tmp” (just removing the & symbol). Immediately after that I tried to schedule an upload and was met with the correct confirmation screen under task management.

    Thank you for your help.

    For other users with this issue, here is specifically what I did. I can’t guarantee it will work for everyone, but it seems to have corrected it for me at least:

    gksu gedit /var/www/fog/management/includes/tasks.confirm.include.php
    Search Menu > Replace
    Search for: &$tmp
    Replace with: $tmp
    Replace All (there were somewhere around twenty instances)
    Save
    Close
    Then try to schedule your upload task again.


  • Moderator

    try to schedule a task again, look at the apache logs, see what the errors are now, ignoring the undefinded index errors.



  • I tried removing the ‘&’ symbol from the argument list, but that doesn’t seem to have made a difference.


  • Moderator

    The undefined index errors can be ignored. The call-time pass-by-reference is probably the culprit. Take a look at the code in the /var/www/fog/management/includes/tasks.confirm.include.php line 754 and take the “&” out of the function call argument list. Save the file and try again.



  • Hi Chad. Thanks for the response. I tried different browsers and from different machines with the same result. I am fairly noobish when it comess to linux, but I managed to find the apache logs. here’s what I am seeing:

    [QUOTE]
    [Wed Nov 14 08:14:05 2012] [error] [client xxx.xxx.xxx.xxx] PHP Notice: Undefined variable: SERVER in /var/www/fog/management/includes/mainmenu.include.php on line 32, referer: [url]http://xxx.xxx.xxx.xxx/fog/management/index.php?node=tasks&sub=listhosts[/url]

    [Wed Nov 14 08:14:05 2012] [error] [client xxx.xxx.xxx.xxx] PHP Notice: Undefined index: confirm in /var/www/fog/management/includes/tasks.include.php on line 5, referer: [url]http://xxx.xxx.xxx.xxx/fog/management/index.php?node=tasks&sub=listhosts[/url]

    [Wed Nov 14 08:14:05 2012] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error: Call-time pass-by-reference has been removed in /var/www/fog/management/includes/tasks.confirm.include.php on line 754, referer: [url]http://xxx.xxx.xxx.xxx/fog/management/index.php?node=tasks&sub=listhosts[/url]
    [/QUOTE]

    I’m not sure what that means though - like I said, I’m new to this. Did I not configure something corrrectly?


  • Moderator

    Gimic, when posting for help, please include information about the version of FOG you have installed, the version of the OS you are running, and any updates/modifications you have installed. Any bit of info helps.

    Have you tried in multiple browsers? I know sometimes things don’t show up in Chrome, but work fine in IE/Firefox. If that doesn’t work, you can try looking at the apache log files as you try to schedule a task and see if an error is being reported there.



  • Just finished setting up Fog 0.32 on Ubuntu 12.10 today, and I am experiencing exactly the same problem. I’ve got a host & image created, but when I attempt to upload it sends me to a blank Task Management page with no options or buttons. Anyone have ideas or suggestions? Thanks.


Log in to reply
 

442
Online

38947
Users

10698
Topics

101511
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.