Mounting failed, connection refused



  • Hello guys, i hope you can help me

    what happened simply is that i’m in a company and they use fog on a machine running Linux

    it was working fine until yesterday i tried to basically delete some old images so i i thought of copying them manually to external hard disk just as a backup i used filezilla as i don’t have the credentials for the PC it self only for the fog from the web page

    fog.jpg

    and today i can’t capture image as you see the error message everything is fine until this step
    is it some kind of fisk permission changed since i used FTP?


  • Moderator

    @faresalandlos Well at this point I don’t think its a firewall issue, but to answer your question for ubuntu this is the command to disable the firewall sudo ufw disable

    So what do I think:

    1. You need to understand why nfs is not starting on that system.
    2. your exports are right and once nfs is running the when you run the showmount command you should see what is posted in the /etc/exports file. The exports file is configured correctly.
    3. Your /images/dev directory is not complete. You are missing the post init scripts directory.
      Your directory should look like this:
    [root@sonic ~]# ls -la /images/dev
    total 428
    drwxrwxrwx  5 fog  fog    4096 Jun 24 13:11 .
    drwxrwxrwx 18 fog  root   4096 May 28 11:11 ..
    -rwxrwxrwx  1 fog  fog       0 Mar 16  2016 .mntcheck
    drwxrwxrwx  2 fog  root   4096 Oct  4  2018 postinitscripts
    

    You may need to just rerun the fog installer and it should fix this file path.

    1. For your nfs service there are a number of sub services like portmapper and such that nfs depends on. Does running sudo systemctl status nfs.service give you any clue to why nfs is not starting?


  • @george1421 said in Mounting failed, connection refused:

    @faresalandlos Well at this point I don’t think its a firewall issue, but to answer your question for ubuntu this is the command to disable the firewall sudo ufw disable

    So what do I think:

    1. You need to understand why nfs is not starting on that system.
    2. your exports are right and once nfs is running the when you run the showmount command you should see what is posted in the /etc/exports file. The exports file is configured correctly.
    3. Your /images/dev directory is not complete. You are missing the post init scripts directory.
      Your directory should look like this:
    [root@sonic ~]# ls -la /images/dev
    total 428
    drwxrwxrwx  5 fog  fog    4096 Jun 24 13:11 .
    drwxrwxrwx 18 fog  root   4096 May 28 11:11 ..
    -rwxrwxrwx  1 fog  fog       0 Mar 16  2016 .mntcheck
    drwxrwxrwx  2 fog  root   4096 Oct  4  2018 postinitscripts
    

    You may need to just rerun the fog installer and it should fix this file path.

    1. For your nfs service there are a number of sub services like portmapper and such that nfs depends on. Does running sudo systemctl status nfs.service give you any clue to why nfs is not starting?

    thank you so much for all the help turning off the firewall fixed the problem! it’s like the system was not happy that i used FTP to play with the folders


  • Moderator

    @faresalandlos Well at this point I don’t think its a firewall issue, but to answer your question for ubuntu this is the command to disable the firewall sudo ufw disable

    So what do I think:

    1. You need to understand why nfs is not starting on that system.
    2. your exports are right and once nfs is running the when you run the showmount command you should see what is posted in the /etc/exports file. The exports file is configured correctly.
    3. Your /images/dev directory is not complete. You are missing the post init scripts directory.
      Your directory should look like this:
    [root@sonic ~]# ls -la /images/dev
    total 428
    drwxrwxrwx  5 fog  fog    4096 Jun 24 13:11 .
    drwxrwxrwx 18 fog  root   4096 May 28 11:11 ..
    -rwxrwxrwx  1 fog  fog       0 Mar 16  2016 .mntcheck
    drwxrwxrwx  2 fog  root   4096 Oct  4  2018 postinitscripts
    

    You may need to just rerun the fog installer and it should fix this file path.

    1. For your nfs service there are a number of sub services like portmapper and such that nfs depends on. Does running sudo systemctl status nfs.service give you any clue to why nfs is not starting?


  • @george1421 said in Mounting failed, connection refused:

    Did the firewall get turned on, on the fog server?

    From the fog server key in the following command to show the nfs shares showmount -e 127.0.0.1 post the results here.

    Also lets look at the permissions for /images/dev with ls -la /images/dev (I don’t think its a file permission issue but its not known what was done via FTP)

    how to deal with this firewall



  • @george1421

    20190724_125455890_iOS 1.jpg

    20190724_130019094_iOS.jpg

    20190724_125755534_iOS.jpg

    so what do you think?


  • Moderator

    @faresalandlos said in Mounting failed, connection refused:

    when i write showmount and the IP it says only one host name is allowed

    Will you provide the output of this command. cat /etc/exports ?


  • Moderator

    @faresalandlos OK from the messages I see

    1. NFS or one of its subservices doesn’t appear to be running on the FOG server
    2. The /images/dev directory is missing some files and the files (directories) it has are old botched captures (the directories that appear to be mac addresses). These directories can be removed since they are just hanging about taking up space. Also the command I asked to use was `ls -la

    Your first issue is resolving the nfs mount problem. When you get the showmount -e command to show you the nfs network shares you will have the permission denied problem solved.



  • when i write showmount and the IP it says only one host name is allowed



  • @george1421 said in Mounting failed, connection refused:

    Did the firewall get turned on, on the fog server?

    From the fog server key in the following command to show the nfs shares showmount -e 127.0.0.1 post the results here.

    Also lets look at the permissions for /images/dev with ls -la /images/dev (I don’t think its a file permission issue but its not known what was done via FTP)

    fog error m.jpg



  • well, i simply copied images files from two old Images folders and deleted what was inside them without deleting the main Image folder, today i checked the permission for both folders images and dev and both has all rights granted
    i will try to get the password for the linux machine


  • Moderator

    Did the firewall get turned on, on the fog server?

    From the fog server key in the following command to show the nfs shares showmount -e 127.0.0.1 post the results here.

    Also lets look at the permissions for /images/dev with ls -la /images/dev (I don’t think its a file permission issue but its not known what was done via FTP)


Log in to reply
 

329
Online

7.4k
Users

14.5k
Topics

136.5k
Posts