iMac USB - FOS script - kernel panic



  • Hi All,

    so I’ve been reading and reading - I was active in a thread last year ‘new to imaging macs’ where a guy had put together a little ISO for usb booting macbooks. I was able to image MBP’s sporadically whenever I needed to until now.

    I’ve ran into every problem I could have so far with imaging iMacs. Finally found the thread about making the USB-FOS image, and putting it on USB. Now I’m having a different issue, and doesn’t seem to be MAC-specific.

    alt text

    This issue is happening on my imacs, and some latitude e6530’s (tried to rule out the imac, pxe boot works fine on the 6530)

    I’ve modified the USB script to grab my local fog’s copy of the memtest, memdisk, ipxe.krn and ipxe.efi files. still no luck.

    any ideas on what could be causing this? i’ve tried two different flash drives, 5 different machines, and even reimaged the machine to make sure nothing was wrong with its grub installs, so i reinstalled grub and re-ran the script again. same exact issue.

    also, I’ve got the whole week in this school to play with these imacs (and the rest of the school year if i really want to…but have to get these imaged this week) so if anyone wants to play around with different ideas.
    i’m between 10.12.5 and trying to roll out 10.14 now. nothing is t2. most have bootcamp.

    i’m tagging george since its his script. THANKS GEORGE
    @george1421



  • @george1421 you are a wizard.

    thats fixed!

    now onto my next thing. heres to hoping that once i can grab a HDD big enough for my images that can support these ginormously underused HDD’s in these labs…that all is good :)


  • Moderator

    If you grabbed the latest kernel and inits you will need to make a modification to the grub.conf file.

    You need to up the kernel parameter for virtual memory from 127000 to 275000

    ramdisk_size=127000 would become ramdisk_size=275000

    i.e. where:

    menuentry "1. FOG Image Deploy/Capture" {
     echo loading the kernel
     linux  $myimage loglevel=$myloglevel initrd=init.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=$myfogip/fog/ boottype=usb consoleblank=0 rootfstype=ext4
     echo loading the virtual hard drive
     initrd $myinits
     echo booting kernel...
    }
    

    would become

    menuentry "1. FOG Image Deploy/Capture" {
     echo loading the kernel
     linux  $myimage loglevel=$myloglevel initrd=init.xz root=/dev/ram0 rw ramdisk_size=275000 keymap= web=$myfogip/fog/ boottype=usb consoleblank=0 rootfstype=ext4
     echo loading the virtual hard drive
     initrd $myinits
     echo booting kernel...
    }
    

    You need to change it in all spots


Log in to reply
 

426
Online

6.1k
Users

13.4k
Topics

126.3k
Posts