Unable to register Host on Fog



  • Good day

    We recently bought new dell desktops and laptops which are giving the issue. We have 4 fog servers at different sites which are all running on Ubuntu 12.04 and fog 1.2.0 and can fog all old equipment fine no issues.

    Old devices uses legagy mode and work fine
    Old devices using UEFI boot does not seem to detect any server or boot file ?

    Only issue is with the new devices, able to boot to network get an IP using legacy mode and select quick registration, then it does not complete the host registration but seems to go into a loop with blinking underscore.

    Again with the UEFI option on the new devices unable to see any bootloader image just keeps going to back to the screen unable to find boot device.

    any assistance with checking logs or advise on which drivers can be installed if this is driver related.

    A new server has been commissioned to try and see if these issues will be resolved but seem to be broken more than the current working server.



  • @george1421 thank you for this. I have hit a bit of a snag as I made some network changes on the VM without a snapshot and am experiencing connectivity issues. once I have resolved I will test and advise.
    1.I have registered a host manually
    2. I have scheculed a debug deploy
    3. I will feedback once I have resolved my network issues with step 3-6


  • Moderator

    @sehume Well this is an interesting issue…

    The next steps are to see what the pxe booting client is seeing, because something is going on there. I have a suspicion, but lets test it.

    1. Manually register this host from the picture.
    2. Schedule a debug capture or deploy (don’t care). Before you schedule the task, tick the debug checkbox, then schedule the task.
    3. PXE boot the target computer. After a few screens of text where you have to clear with the enter key you should be dropped to a linux command prompt. You may get the same error message about connecting to the fog server, just press enter like you did before.
    4. At the FOS Linux command prompt, on the target computer, key in ip addr show confirm that eth0 has an IP address. Please post a clear picture of the output of that command here.
    5. Ping the fog server from the target computer. Post the results of the test.
    6. Next we are going to do the http test from the target computer. Key in the following command curl -Ikfs http://10.245.220.30/fog/management/index.php --connect-timeout 5
      The success response will start out with
    HTTP/1.1 200 OK
    

    Lets see what info those tests provide.



  • @george1421 subnet mask is 255.255.0.0 that is correct
    Fog server IP is 10.245.220.30
    there is no routers or firewalls
    Fog server is running on VMware and there is 2 dedicated switch port that connects the vm to the clients we want to fog (I have tried to keep all settings the same as the old server to minimize any other configs on the switch)


  • Moderator

    @sehume ok for this network your subnet mask is 255.255.0.0 or also known as /16?

    Also just to confirm your fog server is 10.245.220.30?

    I just want to confirm that you don’t have any routers or firewalls between the FOG server and the pxe booting client. What I’m seeing from here is it should be working. There is a caveat, but it appears to be getting an IP address at this point so its not a spanning tree issue.



  • @george1421
    noted with regards to the IP addresses, I have reattached the pictures.
    will stick with 1.5.5 for now
    Yes - the 2nd picture is the result of pressing enter on the 1st picture
    fog.jpg
    Host registration error.jpg

    Yes Fog server and booting computer are on same subnet

    Kind regards

    the


  • Moderator

    @sehume As long as you are using one of the private ranges (10.x.x.x, 172.16-31.x.x, 192.168.x.x) its helpful to see IP addresses when trying to debug. If you are using public internet addresses then privacy matter. But if your fog server is at 192.168.100.15, from a security standpoint it doesn’t do me any good trying to hack into your network.

    For the fog release, stick with 1.5.5 for a bit longer. I’m hearing reports of issues with 1.5.7 so a newer release may be in the works.

    From your top picture it looks like FOS is getting a dhcp address, so it must be failing trying to contact your fog server. Is the pxe booting computer and the FOG server on the same subnet?

    Is the second picture the results of you pressing enter in the first picture?



  • @george1421
    thank you for the prompt response.
    I understand that the old server is outdated with the both OS and FOG application, I am happy to leave it as is for now.

    I had already spun a VM running Ubuntu 18.04 and loaded Fog 1.5.5 a while back before 1.5.7 was a stable release.
    quite a few issues experienced and other projects that took priority put this on the backseat however it has become critical to get the new server up and running.

    On the new server OS was installed updates ran and downloaded fog and installed successfully after a couple of failures.
    had an issue with the DHCP server as well but this was resolved but I seem to still be having issues:
    booting to UEFi on the new server fails
    Legagy boots up but I get the following error when I try to register a device(please see attached error received)

    fog_LI.jpg

    Press enter to continue and I get host registration failedfog host registration failed.jpg


  • Moderator

    @sehume said in Unable to register Host on Fog:

    A new server has been commissioned to try and see if these issues will be resolved but seem to be broken more than the current working server

    <snark>I might take exception to this… its broken FOG install worse than 1.2.0 not working for you?</snark>

    What the issue is fog 1.2.0 doesn’t understand uefi, nvme disks, gpt format, new hardware, and…

    The short answer is to spin up a NEW fog server on a modern and supported operating system. Ubuntu 12.04 went EOL in 2017. Trying to a current release of FOG on that old operating system will lead to install failures.

    Again I recommend spinning up a new fog server just because there are so many differences between 1.2.0 and 1.5.7 that migration can be problematic. You can copy over your image files. You will probably have to hand create the image definitions, but having the web ui’s side by side, its just a simple copy and paste exercise. Plus you don’t run the risk of breaking your 1.2.0 install while you are bringing the new FOG server online.

    If you insist on keeping 1.2.0 as your FOG server you can “try” to download the latest kernels from here: https://fogproject.org/kernels/

    You will want to download Kernel.TomElliott.4.19.6.64 and save it as bzImage
    You will want to download Kernel.TomElliott.4.19.6.32 and save it as bzImage32

    Move these files to your fog server in /var/www/fog/service/ipxe directory. Do this after you rename the existing kernels. Since I can’t remember 1.2.0 if you don’t have a bzImage32 file in the path above then FOG 1.2.0 was only 32 bit. Then take the bzImage32 that you downloaded copy it to the fog server and then rename it to bzImage. Remember that case is important to linux. In newer version of FOG bzImage file is 64 bits and bzImage32 is the 32 bit kernel. IF you mix them up FOS will not boot.

    Understand updating the kernels will only “fix” being able to see new hardware. You will still have the issues with nvme disk, gpt format, and windows 10.


Log in to reply
 

383
Online

7.4k
Users

14.5k
Topics

136.7k
Posts