Install problem on Ubuntu 18.04.2 LTS (Hyper-V)



  • I’m installing FOG version 1.5.6 on Ubuntu 18.04.2 LTS

    This is actually on Hyper-V. I have integration services installed, and checked the instructions at: https://optionkey.blogspot.com/2017/06/setting-up-fog-project-on-hyper-v-and.html

    Everything seems similar.

    My install has five times now (on 2 different host machines) locked up at:

    * Installing package: lftp....................................OK
    * Installing package: libapache2-mod-php7.2...................OK
    * Skipping package:   libc6...................................(Already Installed)
    * Skipping package:   libcurl4................................(Already Installed)
    * Installing package: liblzma-dev.............................OK
    * Installing package: m4......................................OK
    * Installing package: mysql-client............................OK
    * Installing package: mysql-server............................OK
    * Skipping package:   net-tools...............................(Already Installed)
    * Installing package: nfs-kernel-server.......................OK
    * Skipping package:   openssh-server..........................(Already Installed)
    * Installing package: php7.2..................................OK
    * Installing package: php7.2-bcmath...........................OK
    * Skipping package:   php7.2-cli..............................(Already Installed)
    * Installing package: php7.2-curl.............................OK
    * Installing package: php7.2-fpm..............................OK
    * Installing package: php7.2-gd...............................OK
    * Skipping package:   php7.2-json.............................(Already Installed)
    * Installing package: php7.2-ldap.............................OK
    * Installing package: php7.2-mbstring.........................OK
    * Installing package: php7.2-mysql............................OK
    * Skipping package:   php7.2-mysql............................(Already Installed)
    * Installing package: php-gettext.............................OK
    * Skipping package: sysv-rc-conf..............................(Does not exist)
    * Skipping package:   tar.....................................(Already Installed)
    * Installing package: tftpd-hpa...............................OK
    * Installing package: tftp-hpa................................OK
    * Skipping package:   unzip...................................(Already Installed)
    * Installing package: vsftpd..................................OK
    * Skipping package:   wget....................................(Already Installed)
    * Installing package: xinetd..................................OK
    * Skipping package:   zlib1g..................................(Already Installed)
    * Updating packages as needed.................................
    

    I’ve let it sit for 15 hours. Plenty of disk space. top shows “apt-get” runs sporadically.

    It never goes past the install into the configuration portion.

    I’m repeating an install on Debian this time. Running into some package issues, we’ll see if we get any further.

        == John ==


  • @Sebastian-Roth

    Interesting, and good questions. I definitely didn’t install anything, but curl, and openssh.

    The Ubuntu install was a stock “Quick Create” on Hyper-V; the first thing I did with all 5 VM’s was to download and install Fog.

    My exact steps were this:

    sudo apt-get install net-tools
    sudo apt-get install openssh-server
    sudo apt-get update
    
    sudo apt-get install curl
    curl https://codeload.github.com/FOGProject/fogproject/tar.gz/1.5.6 --output 1.5.6.fog.tar.gz
    tar -xzvf 1.5.6.fog.tar.gz
    cd fogproject-1.5.6/bin
    sudo ./installfog.sh
    

    This was based on this page: https://fogproject.org/download

    Side note: Ah ha! sudo -i works on a Raspberry Pi. Su does not; root is disabled, so I got in the habit of doing “sudo” for everything. So it never occured to me the sudo ./installfog.sh was a problem. I get you on the path issues; I ran into this with Debian, so much so I just ran “su” there and did everything as root :)

    The root user is disabled on Raspbian (I do a lot of work on embedded systems), so I got out of the habbit of su.

    I had hoped to run Fog on a PineH64, but couldn’t get it to boot with Armbian, and the supporters of Armbian said “I was wasting their time” trying to debug why it wouldn’t boot without a $20K payment to them. I won’t be doing Fog with Armbian! I may try it on the Pi 4, it’s got a Gigabit network, and USB3, so might get some OK speeds. If I get it in time, I’ll let everyone know.

    For now, I’ll use the Debian VM, but for completeness will check the above commands.

    The proposed fix here again more or less hung stuff up.

    sig@sig-fog-3:~$ sudo fuser -vki /var/lib/dpkg/lock
    [sudo] password for sig: 
    sig@sig-fog-3:~$ sudo apt purge snapd
    E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
    sig@sig-fog-3:~$ sudo dpkg --configure -a
    Setting up libgstreamer-plugins-base1.0-0:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1) ...
    Setting up libpython3.6-stdlib:amd64 (3.6.8-1~18.04.1) ...
    Setting up gstreamer1.0-plugins-base:amd64 (1.14.4-1ubuntu1.1~ubuntu18.04.1) ...
    Setting up gir1.2-gtk-3.0:amd64 (3.22.30-1ubuntu3) ...
    Setting up libdrm-amdgpu1:amd64 (2.4.97-1ubuntu1~18.04.1) ...
    Setting up libedataserver-1.2-23:amd64 (3.28.5-0ubuntu0.18.04.2) ...
    Setting up cups-browsed (1.20.2-0ubuntu3.1) ...
    Setting up plymouth-label (0.9.3-1ubuntu7.18.04.2) ...
    Setting up usb-creator-gtk (0.3.5ubuntu18.04.1) ...
    Setting up gstreamer1.0-pulseaudio:amd64 (1.14.4-1ubuntu1~ubuntu18.04.1) ...
    Setting up plymouth-theme-ubuntu-text (0.9.3-1ubuntu7.18.04.2) ...
    update-initramfs: deferring update (trigger activated)
    Setting up gvfs-fuse (1.36.1-0ubuntu1.3.3) ...
    Setting up libgnome-bluetooth13:amd64 (3.28.0-2ubuntu0.2) ...
    Setting up libgbm1:amd64 (19.0.2-1ubuntu1.1~18.04.1) ...
    Setting up libevdocument3-4:amd64 (3.28.4-0ubuntu1.2) ...
    Setting up python3.6-minimal (3.6.8-1~18.04.1) ...
    Setting up cups-ppdc (2.2.7-1ubuntu2.6) ...
    Setting up libebackend-1.2-10:amd64 (3.28.5-0ubuntu0.18.04.2) ...
    Processing triggers for initramfs-tools (0.130ubuntu3.8) ...
    update-initramfs: Generating /boot/initrd.img-4.15.0-47-generic
    Setting up libqmi-glib5:amd64 (1.22.0-1.2~ubuntu18.04.1) ...
    Setting up libqmi-proxy (1.22.0-1.2~ubuntu18.04.1) ...
    Setting up libebook-contacts-1.2-2:amd64 (3.28.5-0ubuntu0.18.04.2) ...
    Setting up snapd (2.39.2+18.04) ...
    md5sum: /etc/apparmor.d/usr.lib.snapd.snap-confine: No such file or directory
    snapd.failure.service is a disabled or a static unit, not starting it.
    snapd.snap-repair.service is a disabled or a static unit, not starting it.
    

    Just in case I messed something up … I’ll create a sixth Ubuntu “quick start” 18.0.4 LTS image for Hyper-V and immediately check the snapd stuff.

        == John ==

  • Developer

    @JGwinner said:

    This is actually on Hyper-V. I have integration services installed, and checked the instructions at: https://optionkey.blogspot.com/2017/06/setting-up-fog-project-on-hyper-v-and.html

    Just had a quick look through this and sudo ./installfog.sh jumped at me. Please do not run the installer this way!!! While it might work (in some cases?) it can cause issues that are very hard to track down. Running the installer through sudo is different than running it in a proper root shell! Use sudo su - or sudo -i if you prefere to open a proper root command shell (all environment variables set and such) and start the installer script in that as plain ./installfog.sh!

    Do you know the author of this? Would you mind contacting him and asking him to change the article to reflect the above?!

    Ok, back to the topic. As George said, we do automated install testing and Ubuntu 18.04.2 is running fine at the moment: http://fogtesting.theworkmans.us/ (see Branch master for 1.5.6 right now)

    So my guess is that you have some kind of issue in your setup that is causing this. Possibly you installed Ubuntu with some extra packages that we don’t use and which are causing this (very unlikely) or you have some packages that were not properly installed in the first place. The messages from the logs definitely point to the later:

    Setting up snapd (2.39.2+18.04) …
    Installing new version of config file /etc/apparmor.d/usr.lib.snapd.snap-confine.real …
    md5sum: /etc/apparmor.d/usr.lib.snapd.snap-confine: No such file or directory
    snapd.failure.service is a disabled or a static unit, not starting it.
    snapd.snap-repair.service is a disabled or a static unit, not starting it.
    

    The proposed fix from the link you posted should help in this case:

    sudo fuser -vki /var/lib/dpkg/lock
    sudo apt purge snapd
    sudo dpkg --configure -a
    sudo apt update
    sudo apt upgrade
    sudo apt dist-upgrade
    

    On the other hand I really wonder if you want to have snapd installed on a plain FOG server. You should not need it and I’d highly recommend not to.


  • Moderator

    @JGwinner So do we know the root of the ubuntu issue? FOG installs are tested daily against the major linux distributions. This is the first time (recently) I heard of an install failure.

    In the fwiw bucket, if FOG takes more than 30 minutes to install, the install is botched and will never install correctly.



  • This post is deleted!


  • :) Sorry, was in the middle of running the other install, I usually put more stuff up.

    I got Debian to work! So Ubuntu 18.04 is less of an issue.

    But, in the hopes it’ll help someone else:

    1. Direct access. (apt-get works fine)
    2. tarball
    3. I did review it, wasn’t obvious to me. Will paste the tail of it at the end.
    4. If you mean in general, sudo apt-get install <package> works, yes, package installation works fine. If you mean that specific package, I can’t test, as the install is still running (after 2 days). Checking one of the other 4 VM’s where I killed the install after 10 hours … that caused issues, running dpkg cleanup on that VM. Huh … that seems to have paused as well, but at snapd.

    So I think snapd.snap-repair.service is the problem, it’s the last line in the apt repair as well as the install log.

    Ok, I think the fix (for others that might need it) is here:

    https://askubuntu.com/questions/1037431/receiving-the-error-snapd-snap-repair-service-is-a-disabled-or-a-static-unit-n

    sig@sig-fog-vm:~$ sudo apt-get install nfs-kernel-server
    [sudo] password for sig:
    E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
    sig@sig-fog-vm:~$ sudo dpkg --configure -a
    Setting up snapd (2.39.2+18.04) …
    md5sum: /etc/apparmor.d/usr.lib.snapd.snap-confine: No such file or directory
    snapd.failure.service is a disabled or a static unit, not starting it.
    snapd.snap-repair.service is a disabled or a static unit, not starting it.
    ^Cdpkg: error processing package snapd (–configure):
    installed snapd package post-installation script subprocess was interrupted
    Setting up firefox (68.0+build3-0ubuntu0.18.04.1) …
    Please restart all running instances of firefox, or you will experience problems.
    Processing triggers for man-db (2.8.3-2ubuntu0.1) …
    Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) …
    Processing triggers for hicolor-icon-theme (0.17-2) …
    dpkg: dependency problems prevent configuration of gnome-software-plugin-snap:
    gnome-software-plugin-snap depends on snapd; however:
    Package snapd is not configured yet.

    dpkg: error processing package gnome-software-plugin-snap (–configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    snapd
    gnome-software-plugin-snap
    sig@sig-fog-vm:~$ sudo dpkg --configure -a
    Setting up snapd (2.39.2+18.04) …
    md5sum: /etc/apparmor.d/usr.lib.snapd.snap-confine: No such file or directory
    snapd.failure.service is a disabled or a static unit, not starting it.
    snapd.snap-repair.service is a disabled or a static unit, not starting it.


    Installation log errors on current (hanging) install:

    sig@sig-fog-3:~/fogproject-1.5.6/bin/error_logs$ tail fog_error_1.5.6.log
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
    Setting up libpython3.6-minimal:amd64 (3.6.8-1~18.04.1) …
    Setting up libcamel-1.2-61:amd64 (3.28.5-0ubuntu0.18.04.2) …
    Setting up libcupsimage2:amd64 (2.2.7-1ubuntu2.6) …
    Setting up snapd (2.39.2+18.04) …
    Installing new version of config file /etc/apparmor.d/usr.lib.snapd.snap-confine.real …
    md5sum: /etc/apparmor.d/usr.lib.snapd.snap-confine: No such file or directory
    snapd.failure.service is a disabled or a static unit, not starting it.
    snapd.snap-repair.service is a disabled or a static unit, not starting it.


  • Moderator

    Ok so lets start with some questions

    1. Does your fog server have direct internet access or can it get there via a proxy server?
    2. Are you using the tarball or the git repo to install fog?
    3. If you review the error log file in the …/bin/error_logs directory (one directory below where the installfog.sh script is) does it give you any clues?
    4. If you run sudo apt-get install nfs-kernel-server does it install the package?

    ref fog install testing: http://fogtesting.theworkmans.us/


Log in to reply
 

309
Online

6.1k
Users

13.4k
Topics

126.4k
Posts