Hanging/Freezing on bzimage and init.xz

  • I’ve seen similar post about this issue but I haven’t come across a solution.

    I received a new model of industrial grade computer and I configured the BIOS as I normally do.
    UEFI - Disabled
    Legacy Boot - Enabled
    Load OPROM - ALL

    The system booted into the fog UI, deploy image, full registration… Since I’m going to Capture an Image I started with Full Registration. Things were seeming to work until it got to bzImage… % where it slowed to a crawl after some time it got to a 100% and then got stuck on init.xz.

    I manually added the host to Fog and scheduled a Capture task. Same results, got stuck on bzimage and init.xz.

    I removed the task, booted back into fog and selected “Client System Information Compatibility” and got the same results, hanging up again.

    I’ve tired a dozen Official Published Kernels but have had no luck.

    I’m running Fog Version 1.4.4

  • @Sebastian-Roth Thanks you!!! I swapped out the ipxe.kpxe file and it worked.

  • @Sebastian-Roth I’m using intel.pxe and it’s hanging up at the same point. thumbnail_IMG_4165.jpg

  • @Sebastian-Roth Thanks for that info. I’ve tried a number of iPXE binary but not the intel.pxe.

    Something I did find interesting is that if I force the host to use bzimage32 it doesn’t hang up at this step. However it doesn’t matter if I use init.xz or init_32.xz, it still hangs up.

    This is the network card I’m using.

  • Senior Developer

    @duanekaeb I can imagine this being a problem with the old version of FOG you are using. While we can’t backport any fixes I might still be able to help you here.

    The bzImage and init.xz loading is done by iPXE and so I expect that to have trouble with the network driver. So first thing you can try is using a different iPXE binary. Suppose you use undionly.kpxe at the moment. If so then try ipxe.pxe. If that doesn’t help, then try to figure out which network card you have in the client machine and use a specific iPXE binary if we have that, e.g. intel.pxe or realtek.pxe.

    If that all doesn’t help then download the very latest iPXE binary from our github repo and put it in /tftpboot on your FOG server - move the original one so you still have a backup copy of it! See if that helps with the new model you have.