SOLVED Client Stops Loading After refind_x64.efi

  • Hi all,

    I have an intermittent issue with clients. I’ve successfully captured and deployed images on different machines, however sometimes I will randomly run into the below. The only fix I’ve found so far is to remove the host from the GUI and re-register. This has happened pre and post-registration, as well as pre and post deployment. Everything is fine up until here and the system will hang indefinitely.

    It’s more of a bother to me that a real issue, since I seem to have found a work-around, however I’d love some insight on this. Having a hard time searching the issue as it’s not directly related to the boot exit types.

    Thanks in advanced.

    Edit: Has happened on Lenovo and a Dell machine. Workaround the same for both.


  • Would just like to add to this - I recently ran into this same issue again. Racked my brain trying to figure out what I did wrong or what setting could have possibly changed. Here’s what I found out.

    I was using the above PC again after cleaning and prepping to capture another image. This PC was already registered in FOG. I deleted the host and attempted to PXE boot again and everything went smooth as butter. Looks like there’s an issue booting if the device is already registered. I’m not sure what the issue is, but deleting the host and re-registering solved it.

  • @Sebastian-Roth Sounds good to me.

    Thank you for your help here, I appreciate it a ton! Off to tackle AD joining so I’ll catch ya around.

    Also, to the powers that be - I’m not sure how to mark this as solved.

  • Senior Developer

    @Chad said in Client Stops Loading After refind_x64.efi:

    I guess my question now is, do Windows PCs need to have Legacy boot disabled?

    I don’t think so in general. But obviously there are machines around that do things a little different. It’s interesting you get a chainloading error when you have legacy enabled and BOOT EXIT TYPE set to “EXIT” as this is working for many models - but surely not all. So it’s always a bit of a playing with the settings to get it right for each of your machines.

    Using Legacy Boot and CSM support us up to you. I’d want to have it clear Legacy OR UEFI - not just because if FOG but more important to have the OS installed the way I want it to in the first place!

  • @Sebastian-Roth The global settings I’ve been using are REFIND_EFI for both.
    I do not have any host specific settings.

    This client did however have the following enabled in the BIOS.

    Without changing FOG boot exit types, I changed the UEFI/Legacy Boot to: UEFI Only. PC booted right away.

    Changing the BOOT EXIT TYPE to EXIT (with UEFI/Legacy Boot back to the above screenshot setting), results in chainloading failed. Tried GRUB and GRUB_FIRST_FOUND_WINDOWS and both failed - assuming GRUB will fail here since this is Windows (again, sorry the the lack of knowledge in the area).

    Further answers to your questions: No, The FOG menu did not load prior to my change in the client BIOS. I do have other clients PXE booting and have only seen the original timeout error happening on a Dell Desktop client.

    I guess my question now is, do Windows PCs need to have Legacy boot disabled? I believe I read about this somewhere in the FOG wiki however can’t find it now.

  • Senior Developer

    @Chad Please take a look at the exit type settings in the FOG web UI:

    • Global setting: FOG Configuration -> FOG Settings -> FOG Boot Settings: here you find BOOT EXIT TYPE (legacy BIOS) and EFI BOOT EXIT TYPE (UEFI)
    • Host specific setting: Hosts -> edit settings for one host: again you have the two options Host Bios Exit Type and Host EFI Exit Type

    Play with those settings to see if it makes a difference.

    Allow me some more questions: Do you actually see the menu when booting this client? Do you have other clients to test PXE booting? All behaving the same?

  • @Sebastian-Roth

    To answer your first question - This is the normal boot process I’ve seen prior to the device hitting the FOG menu. I’ve seen all my devices pull the above files.

    I wish I could answer your second question confidently, however I’m still fairly new to this legacy/uefi bios PXE booting world.

  • Senior Developer

    @Chad This sounds really strange. Especially the part of how you are able to get around this issue by removing and re-adding the client.

    Do I get this right? On the picture it looks like we see a client that tries to chainload from the local disk after it went to the FOG menu. I expect you have disabled/hidden the menu!?

    Just trying to make sense of this?!? Ahhh, there is something that jumps at me. In the iPXE feature line I see bzImage which makes me think this is a legacy BIOS machine booting undionly.(k)pxe or ipxe.pxe. So why do we see it call out for rEFInd at all?!??!