Printer Management Not adding printer unless one is added manually



  • I have what is a weird problem to me. I have a group of 12 computers (running windows 10 1903) that I have been using FOG to image, and the image goes fine. However, the printers I set up for them do not add right away. Fog is fully managing the printers, but the 1 printer I have added for each computer does not come up until I manually add a printer. The printer I add hasn’t mattered so far, but within 30 seconds of adding that printer, the FOG client removes it and adds the correct one. Is this normal/intended behavior? Should I add a random printer to my image? (does sysprep remove printers?)

    Like I mentioned, FOG is fully managing printers. fog.log says the printer is already added before I’ve added the extra printer, even though it doesn’t show up.



  • @awellis i see that you’ve solved the problem, can you share the solution, because it seems to me that i have the same thing.



  • OK thanks! I really appreciate how active you guys are here!


  • Senior Developer

    @awellis Thanks for the quick reply. I’ll mark this solved for now but feel free to raise this topic again when you run into the issue.



  • @Sebastian-Roth It actually started working for us. I had it setup initially as “Only Assigned Printers” when it wasn’t working originally, save for 2 of the computers. The next day, I changed it to “FOG Managed Printers” though, and they all started showing up (without having to manually add a printer this time).

    Driver was in the same place on every computer (the computers were imaged with it in place) so that shouldn’t be the issue. The logs may have been different because I have 12 computers, and each pair share 1 of 6 printers (which is why I’m wanting to use this vs AD). I wish I could figure out how to replicate the issue, but the lab is currently live and I can’t take it down for testing. If you want, I can try to work on it again when the labs are free in about a week though.


  • Senior Developer

    @awellis Couldn’t get to look into this until now. Just too many other things needed attention.

    I’ve just tested printer management in Windows 10 (though 1803!) again and from my point of view it works well. Not saying that there is no problem but seems like I am not able to properly replicate what you see so far.

    In the picture I see as printer driver you have C:\prn...inf and I am wondering if the INF file is really located in that place?! As well the printer name in the picture does not match the one we see in the logs. Just trying to make sense of this.

    The interesting thing I see in the log from the computer you seem to not have the printer added:

     7/3/2019 11:54 AM Client-Info Client Version: 0.11.16
     7/3/2019 11:54 AM Client-Info Client OS:      Windows
     7/3/2019 11:54 AM Client-Info Server Version: 1.5.5
     7/3/2019 11:54 AM Middleware::Response Success
     7/3/2019 11:54 AM PrinterManager PrintUI return code = 0
     7/3/2019 11:54 AM PrinterManager PrintUI return code = 0
     7/3/2019 11:54 AM PrinterManager PrintUI return code = 0
     7/3/2019 11:54 AM PrinterManager PrintUI return code = 0
     7/3/2019 11:54 AM PrinterManager Adding printers
     7/3/2019 11:54 AM Printer Adding: 1064-printer
     7/3/2019 11:54 AM PrinterManager PrintUI return code = 0
     7/3/2019 11:54 AM PrinterManager Restarting spooler
    

    Here it calls the printUI command several times. My guess is that it removes other printers here. So I am wondering which printer setting you have in that host’s settings? Edit the host and go to the “Printers” tab at the top. Is it set to “FOG Managed Printers” or “Only Assigned Printers”? While it should work in both cases I am just wondering about your setting?!

    Please try the following: Open the Windows Services view (start menu type “services.msc”) and stop FOGService. Now open the Print Management dialog (start menu type “Administrative Tools” -> Print Managment) and manually delete printer and driver and make sure it’s all gone (hit F5…)! Now back to the Services start FOGService again and keep an eye on the Print Management as well as the FOG log (I use powershell command: Get-Content -Wait C:\fog.log). Does it add the printer and tell so in the logs?

    Copy & paste the logs here again. Possibly I need to add more debug output at some point.



  • Alrighty Here’s a screenshot of the settings: https://imgur.com/a/BOFyJvG

    Here’s a pastbin of the log for a computer that did have the printer added: https://pastebin.com/raw/WuyZYuc1
    and here’s one for a computer that did not have it added: https://pastebin.com/raw/4Rb0Hzv6 - 3:10PM is where it looks like it added the printer, but it isn’t there.

    For the second one (not added), I actually tried adding the computer first as I did with some of the others, and the fog client deleted it without actually adding the one I need.


  • Senior Developer

    @awellis Unfortunately printer management has been a bit of an issue in earlier versions of Windows and it’s not getting any better with Windows 10. The timing of the spooler and things seem a bit different.

    On the other hand I have to admit that we have not put much work into the printer management lately as we have very little requests on this in the forums and it’s very hard to replicate (and therefore find and fix the issues).

    To be able to help I’d at least need the exact printer config you set in the web UI (screenshot) as well as the full client log file. Possibly need even more information but that should to for starters.


Log in to reply
 

299
Online

7.4k
Users

14.5k
Topics

136.5k
Posts