SOLVED Storage Node only half working

  • Hi All,

    I have just added a storage node which I built in one office and moved to a remote site today. The IP ranges are different so I allowed the node to get DHCP address when on the remote network, made that static and then adjusted the fog settings accordingly.

    So far I have the node added, it is reporting disk usage on the fog dashboard but when looking in log viewer I get “invalid IP” for all log options on the node and “unauthorized” when looking at kernal version.

    I have so far re-run the installer, checked the .fogsettings and the config.class.php and all seem correct. I have also updated the node settings in the web UI and even deleted and recreated the node.

    Any help would be great.

  • Senior Developer

  • @Sebastian-Roth Hi, We are currently running most recent version on all nodes and the master server.

    I think I have checked the user/pw in all locations on both servers, could you confirm all locations to check please?


  • Senior Developer

    @CoxM said in Storage Node only half working:

    Looks like my previous issue was running mixed versions.

    Well you might want to share this very important information with us as well. Which version(s) do you have right now on the different nodes?

    About the FTP login error. Most likely username or password are not correct.

  • This has moved on slightly, but still not quite working.

    Looks like my previous issue was running mixed versions.

    I now get the following error within the main fog server replication log -

    [07-03-19 5:16:28 pm] * Type: 2, File: /var/www/fog/lib/fog/fogftp.class.php, Line: 464, Message: ftp_login(): Login incorrect., Host:, Username: fog

    This image shows that file and line, its the line with the cursor on it.