Windows 10 Image Deploying to Automatic Repair



  • I work for a small computer refurbisher and I’ve recently inherited responsibility for our two FOG servers and Windows 10 images.

    One of our servers has had issues this month. Our two (newly updated) Windows 10 images go into automatic repair when deployed. I tried a few of the fixes on this forum. Those are detailed in a later section.

    The FOG server is a Dell Optiplex 790 with an i5-2400, 16GB RAM and two drives:

    • A 256GB SSD on which Ubuntu is installed. It’s in the ‘Default’ storage group and contains the two Windows 10 images that go into automatic repair.
    • A 1TB HDD with three more Windows 10 images. It’s in a storage group called ‘ImageStorageGroup2’. I added this drive recently and moved the three images from the 256GB SSD. These haven’t been updated and we’ve had no trouble with them.

    I use VMWare VirtualBox to update and capture our images. All of them are in audit mode. After deploying an image, we install drivers (using a program called Snappy Driver Installer Origin), run a burn test, and then Sysprep.

    The two images in the ‘Default’ storage group deployed just fine before I updated and captured them. That lead me to believe it was an issue with the image. Here are the things I initially changed:

    1. I updated Windows 10 – from 4/27/19 to 6/11/19
    2. I used a third party partition manager to move 6GB of empty space from our recovery partition to the system partition
    3. Changed our in-house testing software with a newer version.

    Below are the steps I’ve taken so far to remedy the issue. I captured and deployed between each of these.

    1. Manually updated the kernel to 4.19.36
    2. Matched credentials on all storage nodes, the ‘fog’ user, and the .fogsettings file
    3. Captured and deployed without the partition changes
    4. Captured and deployed without the Windows updates

    I’m currently capturing the image after Sysprep /generalize’ing into audit mode.

    I’m at a loss as to where to go from here. Does anyone have any ideas?

    Thank you!



  • It looks like a sysprep /generalize into audit mode before capture solved the problem. Thank you for your help!


  • Moderator

    You want to sysprep (with generalize switch) before capture, not after deploy.

    If you want clients to get the OOB experience, you can simply go back into audit mode on first boot of windows after deploy, install drivers, etc and sysprep (without generalize switch) to make it ready.

    That said, it’s not necessarily what is causing your issues.


Log in to reply
 

461
Online

6.1k
Users

13.4k
Topics

126.4k
Posts