After moving to HTTPS FogClient not communicating with FOG Server



  • Recently moved to using HTTPS and now clients with both existing and newly installed fogclient are not communicating with the server. If I install the client on a new machine it does not show up as a pending host in fog server. Running 1.5.6.4 dev build.

    Do I need to specify HTTPS in the fog URL in the installer?


  • Senior Developer

    @astrugatch You need to change a fog-client setting. Edit C:\Program Files (x86)\FOG\settings.json and change parameter HTTPS to 1.

    I know this is not ideal as you’ll have some trouble fixing all your existing clients now. On the other hand you could disable the HTTPS forced redirect in the apache config for now so clients would still work over HTTP. Let me know if you want to go that route and need assistance.

    For new fog-client installations you need to use command line options to let them use HTTPS by default: https://wiki.fogproject.org/wiki/index.php/FOG_Client#FOG_Client_0.10.0.2B_Installation_Options (there is no installer GUI option yet I think)



  • @Sebastian-Roth

    I can safely assume my devices are all running the latest version so I created a group policy to replace the settings.json with a fixed copy on a network share. Which is fine for what I need and I will just update my base images to reflect the correct setting.

    Thanks for the help


  • Senior Developer

    @astrugatch Well, the fog-client is just a normal installed software, so if you have some kind of software management tool that can give you the details…

    Other than that you could try parsing the fog.log file as it is printing the version in there.

    On the other hand the current version 0.11.16 has been released more than a year ago and as AutoUpdate is usually enabled for all clients I’d think all your hosts have this version installed already. There are only two exceptions to that:

    • If you still have machines that use the very old legacy fog-client
    • If you disabled AutoUpdate in FOG web UI: FOG Configuration -> FOG Settings -> FOG Client -> CLIENT AUTOUPDATE Edit: After having done some research I think this option does not do anything at the moment and it has never I reckon. Might be wrong here but digging through the client and server code I get the impression this was added but never properly implemented.


  • @Sebastian-Roth

    Is there a way to report on the client version that my currently deployed machines are running? I can push a new settings.json with group policy but I don’t want to have incorrect settings within it and I can’t guarantee that all my users have the same version.


  • Senior Developer

    @astrugatch You need to change a fog-client setting. Edit C:\Program Files (x86)\FOG\settings.json and change parameter HTTPS to 1.

    I know this is not ideal as you’ll have some trouble fixing all your existing clients now. On the other hand you could disable the HTTPS forced redirect in the apache config for now so clients would still work over HTTP. Let me know if you want to go that route and need assistance.

    For new fog-client installations you need to use command line options to let them use HTTPS by default: https://wiki.fogproject.org/wiki/index.php/FOG_Client#FOG_Client_0.10.0.2B_Installation_Options (there is no installer GUI option yet I think)


Log in to reply
 

381
Online

7.4k
Users

14.5k
Topics

136.6k
Posts