FOG Can't Access Windows 10 Hard Drive



  • The client computer has windows 10 version 1809, build 17763.557
    The FOG server is a 32-bit Ubuntu 16.04 with Fog version 1.5.6
    I changed Windows 10 to legacy boot mode to access the boot process

    I was able to register the client machine with the FOG server, which shows they can communicate without a problem.

    When the client machine is started, the pxe initiates normally and, when it sees there are no FOG commands, the white menu box appears with the default highlighted command being to boot from the hard drive, just like it normally does. The problem is that a black screen appears with a blinking cursor and remains indefinitely. There is no boot to the hard drive. If I boot and manually cancel the pxe boot with a keystroke, it has no problem booting from the hard drive. The problem seems to be with FOG correctly accessing the hard drive from its boot menu. Any ideas what to do?


  • Moderator

    @Tony-Fiorentino Ok now the next steps is to make that dhcp option 67 dynamic. You would typically do this by following the instructions I provided about uefi bios coexistence. But since your dhcp server is older than windows 2012 you still have options without touching your primary dhcp server. You would do this by installing dnsmasq on your FOG server, and then let dnsmasq provide the proper pxe boot information based on the pxe booting client. If you have a single subnet, where your fog server and pxe booting clients are on the same subnet you just need to install dnsmasq and your’d done. If your clients are on a different subnet than your fog/dnsmasq server you need to add the fog server’s IP address in the last position of your dhcp-helper/dhcp-relay service on your subnet router, just like your main dhcp server. Once that is done your FOG server will issue pxe boot information for all subnets.

    Setting up dnsmasq literally takes about 10 minutes with my tutorial. It is the way to go when your dhcp server doesn’t support dynamic boot files.



  • @Tony-Fiorentino

    Success! Your solution of changing option #67 to ipxe.efi was correct. When I tried to implement it the first time, I inadvertently unchecked #66. Doesn’t work too well when there is no boot server address! LOL

    Note: Undionly.kpxe doesn’t work with Windows 10 even if it is changed to Legacy boot mode. It has to be the ipxe.efi with Windows 10 in uefi boot mode.

    Thank you!! You guys are the best!


  • Moderator

    @Tony-Fiorentino said in FOG Can't Access Windows 10 Hard Drive:

    When the client machine is started, the pxe initiates normally and, when it sees there are no FOG commands, the white menu box appears with the default highlighted command being to boot from the hard drive, just like it normally does. The problem is that a black screen appears with a blinking cursor and remains indefinitely. There is no boot to the hard drive.

    ok lets not focus on the uefi side of things. Lets focus on what is in bold above.

    I want to make sure we are thinking the same. If I understand how you have things setup, when a computer boots up every time you see the fog iPXE menu. If you don’t touch the keyboard after a few seconds the iPXE menu should exit and boot from the hard drive. This is where its stopping??

    If you change the boot order so that it does not network boot, but starts the OS directly from the hard drive it works OK. Do I understand what you are saying?


  • Senior Developer

    @Tony-Fiorentino said in FOG Can't Access Windows 10 Hard Drive:

    UEFI Only… It showed, “TTFP …” and then went to a dark screen with a blinking cursor.

    Best if you can take a picture or even video of that screen and post here. Sometimes there is something that we see that could lead to a solution.



  • @Tony-Fiorentino

    I changed #67 to ipxe.efi and tried uploading an image from the Win10 client with “UEFI Only” chosen in the BIOS.

    It showed, “TTFP …” and then went to a dark screen with a blinking cursor. I tried “Legacy Only”, and I also tried “Auto” where it would look at both modes. No dice, I’m afraid. So, I changed #67 back to “undionly.kpxe” so it would at least work with my Win7 population.


  • Moderator

    @Tony-Fiorentino said in FOG Can't Access Windows 10 Hard Drive:

    @george1421

    No, it’s older.

    If it was 2012 or newer then you could use this wiki to dynamically support both bios and uefi systems: https://wiki.fogproject.org/wiki/index.php/BIOS_and_UEFI_Co-Existence#Using_Windows_Server_2012_.28R1_and_later.29_DHCP_Policy

    That way you would not be locked into booting one specific hardware style.

    Another option would be to install dnsmasq on your fog server to supply only the dynamic pxe boot information for network booting. The reset of the dhcp options (like client IP address) would continue to come from your existing dhcp server.



  • @george1421

    No, it’s older.


  • Moderator

    @Tony-Fiorentino Let me ask one more question. What device is your dhcp server? Is it a windows 2012 or later dhcp server?



  • Thank you for responding! 🙂

    Points I didn’t clarify: My FOG “server” is not actually a server with RAID. It is an ordinary
    computer with an Ubuntu 32-bit 16.04 installed and FOG installed. DHCP option is set for
    “undionly.kpxe”. Also, the whole thing has worked fine up to now for my Windows 7 machines.
    I’m able to register, upload an image, and farm out images without any problem.

    1. The target computer is a Lenovo ThinkCentre M710S
      It has a 1 TB 7200 RPM Sata hard drive.
      It has 4 GBs of DDR4 RAM

    2. Since it is not a Dell, I did not follow the advice given for step 2.

    3. I hesitate to change option 67 to “ipxe.efi” because I don’t know if my Windows 7 machines will still
      work with FOG if I do. We are just starting to convert to Windows 10, so I still have a huge family of
      Windows 7 machines. My Windows 7 machines boot in legacy mode, so would FOG still work with
      them if I change option 67 now?


  • Moderator

    I guess there are a few unanswered questions here.

    1. What is the target computer hardware, both manufacture and model?
    2. It sounds like the target computer is in uefi mode. If this is a dell and uefi mode is turned off, change the disk controller from raid-on mode to ahci mode. That will allow FOS to see the hard drives behind the raid controller.
    3. If the target computer is in uefi mode, what pxe boot file are you sending to it? ipxe.efi I hope, this is set by dhcp option 67.

    If everything works fine (image capture and deploy) except the exit to hard disk then its a different issue.


Log in to reply
 

364
Online

7.4k
Users

14.5k
Topics

136.6k
Posts