SOLVED PXE boot BItdefender Rescue CD fails

  • I am trying to network boot Bitdefender Rescue CD (latest iso file downloaded from bitdefender’s website) following instructions from the wiki :

    PXE booting client => I get NFS mounting failed error. From the shell I can’t mount X.X.X.X:/images/dev neither with nfs version3 nor v4 (NFS server supports v3,v4 UDP & TCP).

    lsmod shows NFS module is loaded. I tried on another ubuntu machine and I succeed to mount no matter which NFS version I use, so I guess the server side is working. I also tried with Fog 1.5.6 & got the same result.

    I spent quite some time on this one so I’d be happy if someone could help me. Thanks alot

  • @george1421 I totally share your point of view. Be sure I’ll let them know

  • Moderator

    @jd272 So the question is, why are these files missing and should you notify the bitdefender folks that their documents setup does not work as outlined?

    I understand you found an path forward for you (well done by the way), but shouldn’t what you discovered be fixed by the developers? If it isn’t fixed, you will have to do the same thing next time as well as others will run into the same wall as you. Understand my perspective is from the open source community where we are all good open source neighbors.

    While your issue isn’t fog related in any way, if you want to go ahead a write a tutorial in the fog tutorial forum, everyone would appreciate it. Maybe it will help someone out in the future with the same struggles.

    But in the end well done finding a solution to your problem and to use FOG in a different way than it was designed. It goes to show the flexibility of the FOG open source platform.

  • @george1421 At last I succeeded to network boot latest Bitdefender Rescue CD

    What helped me is when I dropped to the client shell, I saw /lib/modules/$KERNEL/modules.order was listing nfsv3.ko, nfsv4.ko & other .ko files related to nfs, but they were missing in /lib/modules/$KERNEL/fs/nfs & /lib/modules/$KERNEL/fs/nfs_common …

    Basically what I did is extract init file (initfs.i386-pc) file provided in Bitdefender’s iso and extract the filesystem (livecd.squashfs)
    Then rsync both /lib/modules/$KERNEL/fs/ directories to inject missing .ko files in the initfs, and recompress to a new initfs. Then modify ipxe settings to point to the updated initfs.i386-pc and …

    I guess you can mark this one as solved, if you want I can detail all the steps or provide the working initfs.i386-pc file. Thanks for your support

  • @george1421 There isnt /var/log directory at all,

    dmesg doesnt return any error, this all I found regarding NFS :

    Capture du 2019-06-23 17-48-37.png

    Honestly I m kind of stuck right now, I came here because I really have no clue …

  • Moderator

    @jd272 Interesting, I just don’t know what that client is needing then. I kind of suspected nfsv2 because they are only supplying a 32 bit kernel. on that pxe booting client there isn’t anything in the log directory? And demsg doesn’t return anything either?

    It can’t be the firewall and selinux is enabled on the fog server because you were able to connect via the ubuntu server. I don’t know if the fog server would have any logs of the nfs server to see if the client is trying to do something strange, like maybe the credential being used to connect to the share are not allowed… but then again it should tell us that not protocol error.

  • @george1421 I can’t find any logs at all when Im at the linux shell

    On the fog server nfs supports v3 & v4 :

    Capture du 2019-06-23 16-46-09.png

    I edited nfs server conf to enable v2 support

    Capture du 2019-06-23 16-50-28.png

    Same result from the test client with vers=2 :

    Capture du 2019-06-23 16-57-52.png

  • Moderator

    @jd272 OK, when you are at the linux shell on the remote system (second picture below) when you get the protocol not supported, is there anything helpful in /var/logs to what protocol its try to support.

    Since I don’t have a fog server console handy at the moment, what do you get when you run this on the fog server rpcinfo -p | egrep "service|nfs" Note: you may have to use the fog server’s real IP address if that doesn’t return any useful information.

    Its possible that the supplied kernel only supports something like nfs v2. It would be odd, but possible.

  • Sorry I wasn’t clear enough so I took a few captures, hopefully it will help :

    Here is the error I get with my diskless test client


    Drop to the shell and trying to manually nfs mount the fog server :

    Capture du 2019-06-23 14-38-17.png

    Then nfs mounting the fog server from my Ubuntu 18.04 host :

    Capture du 2019-06-23 14-41-51.png

    As you can see, it worked :

    Capture du 2019-06-23 14-42-21.png

  • Moderator

    So just to be clear you can mount the fog server /images/dev directory for a second linux computer but your bitdefender OS can not?

    When you drop to the OS shell on the bitdefender OS you can’t manually nfs mount the fog server?

    I’m asking because looking at the wiki page it appears the boot syntax is very similar to ubuntu live boot. You need a specific netboot kernel for ubuntu to do this.