PXE boot failed 1.5.6





  • @george1421

    Thanks for the help Pinging @Sebastian-Roth


  • Moderator

    @astrugatch Ok then the issue is that the iPXE boot loader doesn’t understand https or the certificate of the FOG server is not inline with the certificate used to locally compile the iPXE kernels (undionly.kpxe and ipxe.efi).

    Unfortunately I don’t know the next steps. I know where the issue is, but not how to fix it since I hanven’t needed to setup ssl on my FOG server. You were in the right neighborhood with the buildpxe.sh command.



  • @george1421 said in PXE boot failed 1.5.6:

    https://10.10.70.4/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00

    Yup

    #!ipxe
    set fog-ip 10.10.70.4
    set fog-webroot fog
    set boot-url https://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture https://10.10.70.4/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0xff0000 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk initrd=memtest.bin iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=https://10.10.70.4/fog/ consoleblank=0 rootfstype=ext4 storage=10.10.70.4:/images/ storageip=10.10.70.4 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=https://10.10.70.4/fog/ consoleblank=0 rootfstype=ext4 storage=10.10.70.4:/images/ storageip=10.10.70.4 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=https://10.10.70.4/fog/ consoleblank=0 rootfstype=ext4 storage=10.10.70.4:/images/ storageip=10.10.70.4 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar https://10.10.70.4/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

  • Moderator

    @astrugatch OK for the next test

    From a windows browser, can you go to this web site?

    https://10.10.70.4/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00

    This should give you a bunch of text, which is the text behind the FOG iPXE boot menu.



  • @george1421 said in PXE boot failed 1.5.6:

    netstat -an|grep :443

    Yup. That works. I can get to the web UI over https

    root@fogimaging:~# netstat -an|grep :443
    tcp6 0 0 :::443 :::* LISTEN
    tcp6 0 0 10.10.70.4:443 10.10.10.21:63466 TIME_WAIT


  • Moderator

    @astrugatch OK the next step is to see if apache is listening on the https port.

    netstat -an|grep :443

    It should respond with something like this:

    tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN
    


  • @george1421 said in PXE boot failed 1.5.6:

    ls -la /var/www/html/fog/service/ipxe/*.php

    I do have SSL enabled. The installer was originally run with -S
    The installer completed successfully

    root@fogimaging:~# ls -la /var/www/html/fog/service/ipxe/*.php
    -rw-r–r-- 1 fogproject www-data 1958 Jun 19 08:37 /var/www/html/fog/service/ipxe/advanced.php
    -rw-r–r-- 1 fogproject www-data 1139 Jun 19 08:37 /var/www/html/fog/service/ipxe/boot.php
    -rw-r–r-- 1 fogproject www-data 592 Jun 19 08:37 /var/www/html/fog/service/ipxe/index.php

    It does find it. What do I need to change?


  • Moderator

    yeah the buildpxe.sh isn’t the issue here.

    I noticed you have https:// , do you have ssl enabled on your FOG server? The boot.php is manged by the fog installer so it should be there if the installer completed correctly.

    So if you run this command from the fog server linux console ls -la /var/www/html/fog/service/ipxe/*.php does it find boot.php? If it does then its probably the https vs http.



  • I installed using force HTTPS so I tried running the buildpxe.sh and that didn’t fix the issue. I did a git pull and reran the whole installer. Still no dice.


Log in to reply
 

577
Online

6.2k
Users

13.6k
Topics

128.2k
Posts