Unable to start task, Unable to connect to tftp server.



  • Hallo Guys,

    When i want to upload a image and click on the “upload image” button i get the following error: “Unable to start task, Unable to connect to tftp server.”

    I v changed the fog password on linux (passwd fog) and in the web gui. I also change the tftp password in Other information > FOG settings > tft SERVER > FOG_TFTP_FTP_PASSWORD.

    I v also changed the file /var/www/html/fog/commons/config.php to include the new password.

    But still no joy :( I installed fog on a clean Cent OS 6.3 server and along side an existing DHCP server.
    The DHCP server options are 66: ipaddress fog server and 67: pxelinux.0

    vsftpd is running and iptables are cleared.



  • I figured it out. went into fog setting through the web management and changed the TFTP password from there and everything started working fine.



  • I also am having this issue. I thought maybe i messed something up during install so started from clean install and again same issue. I am on Ubuntu 12.04.1 fog0.32. Any thoughts. I have tried to ftp in and that worked fine i was able to log in.

    Thanks,



  • omg… i found my problem.

    I added the user “fog” to the /etc/vsftpd/ftpusers file because of my initial problem with the fog password. Just to debug something. But totally forgot that all the users in the file are blocked from the ftp server.

    So everything is working now.

    Thanks a million for pointing me in the right direction!



  • I’m pretty sure you need TCP 20 open as well. One of them is used for control while the other is for data. The username and password being used are the linux username and password, which need to match the FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD listed under FOG Settings in the web UI.



  • yes i restarted several times.

    Open TCP ports:
    PORT STATE SERVICE
    21/tcp open ftp
    22/tcp open ssh
    80/tcp open http
    111/tcp open rpcbind
    2049/tcp open nfs
    3306/tcp open mysql

    when i connect to the ftp service i get a login incorrect… so the problem is related to the ftp service!

    Trying 127.0.0.1…
    Connected to localhost (127.0.0.1).
    220 (vsFTPd 2.2.2)
    Name (localhost:root): fog
    331 Please specify the password.
    Password:
    530 Login incorrect.
    Login failed.

    thx for the tip! Now i need to find why i can’t login to the ftp server.



  • You remembered to restart/reload vsftpd following the fog password change?
    [url]http://www.fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP[/url]"

    Can you ftp into your FOG server using an ftp client(filezilla, the ftp command, map drive) using the fog username and the fog password and upload a file?



  • The error about the TFTP server is actually referring to FTP. When a task is created the web server FTPs a MAC address specific task file to the TFTP server. What you need is TCP ports 20 and 21 open to the web server. If this is all on the same server then you can just make it open to localhost.



  • oeps…
    PORT STATE SERVICE
    69/udp open|filtered tftp

    The IP has never changed: 10.148.48.18

    web settings:
    [IMG]https://dl.dropbox.com/u/2172654/fog_tftp.PNG[/IMG]

    config.php:
    define( “IS_INCLUDED”, true );
    define( “TFTP_HOST”, “10.148.48.18” );
    define( “TFTP_FTP_USERNAME”, “fog” );
    define( “TFTP_FTP_PASSWORD”, “+++++” );
    define( “TFTP_PXE_CONFIG_DIR”, “/tftpboot/pxelinux.cfg/” );
    define( “TFTP_PXE_KERNEL_DIR”, “/tftpboot/fog/kernel/” );
    define( “PXE_KERNEL”, “fog/kernel/bzImage” );
    define( “PXE_KERNEL_RAMDISK”, 127000 );
    define( “USE_SLOPPY_NAME_LOOKUPS”, “1”);
    define( “MEMTEST_KERNEL”, “fog/memtest/memtest” );
    define( “PXE_IMAGE”, “fog/images/init.gz” );
    define( “PXE_IMAGE_DNSADDRESS”, “10.148.48.8” );
    define( “STORAGE_HOST”, “10.148.48.18” );
    define( “STORAGE_FTP_USERNAME”, “fog” );
    define( “STORAGE_FTP_PASSWORD”, “+++++” );
    define( “STORAGE_DATADIR”, “/images/” );
    define( “STORAGE_DATADIR_UPLOAD”, “/images/dev/” );
    define( “STORAGE_BANDWIDTHPATH”, “/fog/status/bandwidth.php” );
    define( “CLONEMETHOD”, “ntfsclone” ); // valid values partimage, ntfsclone
    define( “UPLOADRESIZEPCT”, 5 );
    define( “WEB_HOST”, “10.148.48.18” );
    define( “WEB_ROOT”, “/fog/” );
    define( “WOL_HOST”, “10.148.48.18” );
    define( “WOL_PATH”, “/fog/wol/wol.php” );
    define( “WOL_INTERFACE”, “eth0” );
    define( “SNAPINDIR”, “/opt/fog/snapins/” );
    define( “QUEUESIZE”, “10” );
    define( “CHECKIN_TIMEOUT”, 600 );
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “” );
    define( “DB_TYPE”, “mysql” );
    define( “DB_HOST”, MYSQL_HOST );
    define( “DB_NAME”, MYSQL_DATABASE );
    define( “DB_USERNAME”, MYSQL_USERNAME );
    define( “DB_PASSWORD”, MYSQL_PASSWORD );
    define( “DB_PORT”, null );
    define( “USER_MINPASSLENGTH”, 4 );
    define( “USER_VALIDPASSCHARS”, "1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijk$
    define( “NFS_ETH_MONITOR”, “eth0” );
    define(“UDPCAST_INTERFACE”,“eth0”);
    define(“UDPCAST_STARTINGPORT”, 63100 ); $
    define(“FOG_MULTICAST_MAX_SESSIONS”, 64 );
    define( “FOG_JPGRAPH_VERSION”, “2.3” );
    define( “FOG_REPORT_DIR”, “./reports/” );
    define( “FOG_THEME”, “blackeye/blackeye.css” );
    define( “FOG_UPLOADIGNOREPAGEHIBER”, “1” );
    define( “FOG_VERSION”, “0.32” );
    define( “FOG_SCHEMA”, 23 );
    DEFINE(‘BASEPATH’, rtrim($_SERVER[‘DOCUMENT_ROOT’], ‘/’) . rtrim(WEB_ROOT, ‘/’)$



  • nmap -sT will not detect the TFTP server, because -sT is a TCP connection scan, TFTP uses UDP instead of TCP. Is the IP address correct for the server, in the config.php and in the web settings?



  • Some extra info:
    Fog version: 0,32
    Disabled SELINUX

    I got a nice fog boot screen when booting a client with pxe…
    When i run nmap -sT -O localhost i cant see any 69 port open

    tftp in /etc/xined.d/:
    service tftp
    {
    socket_type = dgram
    protocol = udp
    wait = yes
    user = root
    server = /usr/sbin/in.tftpd
    server_args = -s /tftpboot
    disable = no
    per_source = 11
    cps = 100 2
    flags = IPv4
    }

    chkconfig --list:
    services based on xinetd:
    chargen-dgram: uit
    chargen-stream: uit
    daytime-dgram: uit
    daytime-stream: uit
    discard-dgram: uit
    discard-stream: uit
    echo-dgram: uit
    echo-stream: uit
    tcpmux-server: uit
    tftp: aan
    tftp.fogbackup: aan
    time-dgram: uit
    time-stream: uit

    I am realy stuck here. I guess my tftp server is working just fine because i can pxe boot the clients…

    [IMG]https://dl.dropbox.com/u/2172654/Fog_Error.PNG[/IMG]


Log in to reply
 

463
Online

38969
Users

10710
Topics

101654
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.