Problem to boot with PXE



  • Hi,

    I work with VM on virtualbox.
    I have a fog server in 10.23.2.1.
    I have configured the file /etc/dhcp/dhcpd.conf.

    When I try to start a VM with PXE, I get a IP configuration but I have this error :

    http://192.168.51.71/fog/service/ipxe/boot.php… Network unreachable (http://ipxe.org/280a6011)
    could not boot : Network unreachable (http://ipxe.org/280a6011)”

    My dhcp file configuration :

    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    
    
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    #subnet 192.168.51.0 netmask 255.255.255.0{
    subnet 10.23.2.0 netmask 255.255.255.0{
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 10.23.2.10 10.23.2.254;
    default-lease-time 21600;
    max-lease-time 43200;
    #option routers 0.0.0.0
    #option routers 0.0.0.0
    next-server 10.23.2.1;
    class "Legacy" {
    match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
    filename "undionly.kkpxe";
    }
    class "UEFI-32-2" {
    match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
    filename "i386-efi/ipxe.efi";
    }
    class "UEFI-32-1" {
    match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
    filename "i386-efi/ipxe.efi";
    
    

    Sorry for my english, I’m not english…

    Thanks





  • Excuse me I was tired I wrote in french…

    I do a apt-get update because it’s an old VM.
    So after done IP modification, I have my server in 172.16.0.1.

    I have tftp error on my server when I launch it.
    failed to start LSB : tftp-hpa’s tftp server (picture 1)

    And when I try to start the VM since OS, I get an IP adress (172.16.0.10) but I see a tftp error (tftp open timeout) (picture 2)

    2019-06-12_08h21_23.png

    2019-06-12_08h34_01.png

    Edit : in the /tftpboot/pxelinux.cfg/default file I had a bad IP. I change it


  • Developer

    @idiart33 I suggest you open a new topic if you have new issues/problems! Please post a picture of the error so we know what exactly has happened. We can’t help you otherwise.



  • J’ai une erreur de tftp au démarrage du serveur…

    J’ai dû changer de config IP.

    J’ai adapté les fichiers de conf et depuis l’interface d’administration du serveur.

    D’où ça peut venir ?



  • I solved the problem.
    So my VM with Windows 7 and the VM since OS are recorded.
    I create a picture.
    I went to host management/list all hosts to create an upload task.
    So I restart my master, but I have an error : mounting file system… failed



  • I found this page after.

    I am following this page : https://doc.ubuntu-fr.org/fog
    I already done the Full Host Registration and Inventory with the VM which has no OS.
    But when I try to boot on PXE with a Windows 7 VM I obtain an IP config but I have a DHCP failed error.


  • Developer

    @idiart33 The config you posted seems complete now!

    The only one file to edit is /etc/dhcp/dhcpd.conf right ?

    Why do you think this is the only file you need to change? There are many different places where you need to manually do the IP change. See here: https://wiki.fogproject.org/wiki/index.php/Change_FOG_Server_IP_Address



  • Here is my full initial conf :

    # DHCP Server Configuration file\n#see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    #Definition of PXE-specific options
    # Code 1: Multicast IP Address of bootfile
    # Code 2: UDP Port that client should monitor for MTFTP Responses
    # Code 3: UDP Port that MTFTP servers are using to listen for MTFTP requests
    # Code 4: Number of seconds a client must listen for activity before trying
    #         to start a new MTFTP transfer
    # Code 5: Number of seconds a client must listen before trying to restart
    #         a MTFTP transfer
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    subnet 192.168.51.0 netmask 255.255.255.0{
        option subnet-mask 255.255.255.0;
        range dynamic-bootp 192.168.51.10 192.168.51.254;
        default-lease-time 21600;
        max-lease-time 43200;
        #option routers 0.0.0.0
        #option routers 0.0.0.0
        next-server 192.168.51.71;
        class "Legacy" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000$
            filename "undionly.kkpxe";
        }
        class "UEFI-32-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002$
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-32-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006$
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-64-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007$
            filename "ipxe.efi";
        }
        class "UEFI-64-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008$
            filename "ipxe.efi";
        }
        class "UEFI-64-3" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009$
            filename "ipxe.efi";
        }
        class "SURFACE-PRO-4" {
            match if substring(option vendor-class-identifier, 0, 32) = "PXEClient:Arch:00007$
            filename "ipxe7156.efi";
        }
        class "Apple-Intel-Netboot" {
            match if substring(option vendor-class-identifier, 0, 14) = "AAPLBSDPC/i386";
            option dhcp-parameter-request-list 1,3,17,43,60;
            if (option dhcp-message-type = 8) {
                option vendor-class-identifier "AAPLBSDPC";
                if (substring(option vendor-encapsulated-options, 0, 3) = 01:01:01) {
                    # BSDP List
                    option vendor-encapsulated-options 01:01:01:04:02:80:00:07:04:81:00:05:2a$
                    filename "ipxe.efi";
                }
            }
        }
    }
    


  • Re: Problem to boot with PXE

    Thanks for your suggestions.

    1. In fact, this VM whas in a deployment network in 192.168.51.X.
      I copied this VM.
      I want to change the second VM for using it in an other network in 10.23.2.X.
      So I changed the IP of the server (10.23.2.1) and I am currently editing the DHCP configuration.

    edit : I try to use the old VM and it works.
    So I delete the server in 10.23.2.1 and I copy/past again the old server.

    The only one file to edit is /etc/dhcp/dhcpd.conf right ?

    1. If I am not mistaken, I had post the full config file since the :
      class “UEFI-32-2” {
      }

  • Developer

    @idiart33 Two things that come to mind reading this:

    1. You have a commented line with the 192.168.51.x suchet. My guess is that you were using those addresses when you first installed FOG. Did you change the IP at some Pointe??
    2. Did you post your full config file? Just wondering because this on is missing one closing curly bracket. Possibly when you made the config changes and tried to restart the DHCP service it might fail because IT cannot properly read your sonnig?!

Log in to reply
 

499
Online

5.9k
Users

13.3k
Topics

125.0k
Posts