Fog not joining my PCs to the domain



  • Hi

    Created an XP SOE, Sysprepped etc as per writeup on the wiki

    Setup the host, and completed the AD attributes using a Fog crypted password.

    No matter what i do, the machine images, sysprep runs, it reboots, gets to login screen, sits for a bit then reboots, but no domain join

    see log from a machine i just done

    [CODE] 5/11/2012 4:46 PM FOG::HostnameChanger Starting hostname change process…
    5/11/2012 4:46 PM FOG::HostnameChanger Yielding to other subservices for 3 seconds.
    5/11/2012 4:46 PM FOG::PrinterManager Starting interprocess communication process…
    5/11/2012 4:46 PM FOG::PrinterManager interprocess comm startup: OK
    5/11/2012 4:46 PM FOG::AutoLogOut Starting process…
    5/11/2012 4:46 PM FOG::ClientUpdater Sleeping for 421 seconds.
    5/11/2012 4:46 PM FOG::SnapinClient Starting snapin client process…
    5/11/2012 4:46 PM FOG::PrinterManager Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::HostRegister Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::TaskReboot Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::SnapinClient Sleeping for 484 seconds.
    5/11/2012 4:46 PM FOG::UserTracker Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::PrinterManager Module is disabled on this host.
    5/11/2012 4:46 PM FOG::TaskReboot Module is active…
    5/11/2012 4:46 PM FOG::TaskReboot Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::UserTracker Module is active…
    5/11/2012 4:46 PM FOG::AutoLogOut Module is disabled on this host.
    5/11/2012 4:46 PM FOG::DisplayManager Module is disabled globally on the FOG Server.
    5/11/2012 4:46 PM FOG::HostRegister Module is active…
    5/11/2012 4:46 PM FOG::HostRegister Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::TaskReboot No job exists for 24:BE:05:1B:3D:31|24:BE:05:1B:3D:31
    5/11/2012 4:46 PM FOG::TaskReboot No task found for client.
    5/11/2012 4:46 PM FOG::HostRegister No action was taken.
    5/11/2012 4:46 PM FOG::HostnameChanger Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::HostnameChanger Module is active…
    5/11/2012 4:46 PM FOG::HostnameChanger AD mode requested, confirming settings.
    5/11/2012 4:46 PM FOG::HostnameChanger Hostnames are different - WINGECAR-1C23ED - WSC04632
    5/11/2012 4:46 PM FOG::HostnameChanger Attempting to unregister from domain…
    5/11/2012 4:46 PM FOG::HostnameChanger Domain Error! (‘Unknown Error’ Code: 2692)
    5/11/2012 4:46 PM FOG::HostnameChanger Using default fog method.
    5/11/2012 4:46 PM FOG::HostnameChanger Computer is about to restart.
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::UserCleanup Starting user cleanup process…
    5/11/2012 4:46 PM FOG::UserCleanup Attempting to connect to fog server…
    5/11/2012 4:46 PM FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM N/A Mananged restart method failed, attempting unmanaged api call.
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:46 PM FOG::GUIWatcher Message found, attempting to notify GUI!
    5/11/2012 4:46 PM FOG::GUIWatcher Dispatch Failed!
    5/11/2012 4:47 PM FOG Service Engine Version: 3
    5/11/2012 4:47 PM Starting all sub processes
    5/11/2012 4:47 PM 13 modules loaded
    5/11/2012 4:47 PM * Starting FOG.AutoLogOut
    5/11/2012 4:47 PM * Starting FOG.SnapinClient
    5/11/2012 4:47 PM * Starting FOG.DirCleaner
    5/11/2012 4:47 PM * Starting FOG.DisplayManager
    5/11/2012 4:47 PM * Starting FOG.GUIWatcher
    5/11/2012 4:47 PM * Starting FOG.HostNameChanger
    5/11/2012 4:47 PM FOG::GUIWatcher Starting GUI Watcher…
    5/11/2012 4:47 PM * Starting FOG.HostRegister
    5/11/2012 4:47 PM * Starting FOG.MODDebug
    5/11/2012 4:47 PM FOG::MODDebug Start Called
    5/11/2012 4:47 PM FOG::MODDebug Sleeping for 100 Seconds
    5/11/2012 4:47 PM * Starting FOG.PrinterManager
    5/11/2012 4:47 PM * Starting FOG.SnapinClient
    5/11/2012 4:47 PM * Starting FOG.TaskReboot
    5/11/2012 4:47 PM * Starting FOG.UserCleanup
    5/11/2012 4:47 PM FOG::TaskReboot Taskreboot in lazy mode.
    5/11/2012 4:47 PM * Starting FOG.UserTracker
    5/11/2012 4:47 PM FOG::TaskReboot Starting Task Reboot…
    5/11/2012 4:47 PM FOG::UserTracker Starting user tracking process…
    5/11/2012 4:47 PM FOG::DirCleaner Sleeping for 56 seconds.
    5/11/2012 4:47 PM FOG::HostnameChanger Starting hostname change process…
    5/11/2012 4:47 PM FOG::HostRegister Starting host registration process…
    5/11/2012 4:47 PM FOG::UserCleanup Sleeping for 18 seconds.
    5/11/2012 4:47 PM FOG::ClientUpdater Starting client update process…
    5/11/2012 4:47 PM FOG::ClientUpdater Sleeping for 446 seconds.
    5/11/2012 4:47 PM FOG::PrinterManager Starting interprocess communication process…
    5/11/2012 4:47 PM FOG::PrinterManager interprocess comm startup: OK
    5/11/2012 4:47 PM FOG::AutoLogOut Starting process…
    5/11/2012 4:47 PM FOG::SnapinClient Starting snapin client process…
    5/11/2012 4:47 PM FOG::SnapinClient Sleeping for 392 seconds.
    5/11/2012 4:47 PM FOG::TaskReboot Attempting to connect to fog server…
    5/11/2012 4:47 PM FOG::PrinterManager Attempting to connect to fog server…
    5/11/2012 4:47 PM FOG::HostRegister Attempting to connect to fog server…
    5/11/2012 4:47 PM FOG::DisplayManager Attempting to connect to fog server…
    5/11/2012 4:47 PM FOG::UserTracker Attempting to connect to fog server…
    5/11/2012 4:47 PM FOG::DisplayManager Module is disabled globally on the FOG Server.
    5/11/2012 4:47 PM FOG::TaskReboot Module is active…
    5/11/2012 4:47 PM FOG::TaskReboot Attempting to connect to fog server…
    5/11/2012 4:47 PM FOG::UserTracker Module is active…
    5/11/2012 4:47 PM FOG::HostRegister Module is active…
    5/11/2012 4:47 PM FOG::HostRegister Attempting to connect to fog server…
    5/11/2012 4:47 PM FOG::TaskReboot No job exists for 24:BE:05:1B:3D:31|24:BE:05:1B:3D:31
    5/11/2012 4:47 PM FOG::TaskReboot No task found for client.
    5/11/2012 4:47 PM FOG::AutoLogOut Module is disabled on this host.
    5/11/2012 4:47 PM FOG::HostRegister No action was taken.
    5/11/2012 4:47 PM FOG::PrinterManager Module is disabled on this host.
    5/11/2012 4:48 PM FOG::HostnameChanger Attempting to connect to fog server…
    5/11/2012 4:48 PM FOG::HostnameChanger Module is active…
    5/11/2012 4:48 PM FOG::HostnameChanger AD mode requested, confirming settings.
    5/11/2012 4:48 PM FOG::HostnameChanger Hostname is up to date
    5/11/2012 4:48 PM FOG::HostnameChanger Attempting to join domain if not already a member…
    5/11/2012 4:48 PM FOG::HostnameChanger Domain Error! (‘Unknown Error’ Code: 87)
    5/11/2012 4:48 PM FOG::UserCleanup Starting user cleanup process…
    5/11/2012 4:48 PM FOG::UserCleanup Attempting to connect to fog server…
    5/11/2012 4:48 PM FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    5/11/2012 4:48 PM FOG::DirCleaner Starting directory cleaning process…
    5/11/2012 4:48 PM FOG::DirCleaner Attempting to connect to fog server…
    5/11/2012 4:48 PM FOG::DirCleaner Module is active…
    5/11/2012 4:48 PM FOG::DirCleaner Determining which directories should be cleaned…
    5/11/2012 4:48 PM FOG::DirCleaner No directories are configured to be cleaned.
    5/11/2012 4:48 PM FOG::DirCleaner Starting directory cleaning loop…
    5/11/2012 4:48 PM FOG::DirCleaner Module has finished work and will now exit.
    5/11/2012 4:49 PM FOG::MODDebug Reading config settings…
    5/11/2012 4:49 PM FOG::MODDebug Reading of config settings passed.
    5/11/2012 4:49 PM FOG::MODDebug Starting Core processing…
    5/11/2012 4:49 PM FOG::MODDebug Operating System ID: 5
    5/11/2012 4:49 PM FOG::MODDebug Operating System Minor: 1
    5/11/2012 4:49 PM FOG::MODDebug MAC ID 0 24:BE:05:1B:3D:31
    5/11/2012 4:49 PM FOG::MODDebug MAC ID 1 24:BE:05:1B:3D:31
    5/11/2012 4:49 PM FOG::MODDebug MAC POST String: 24:BE:05:1B:3D:31|24:BE:05:1B:3D:31
    5/11/2012 4:49 PM FOG::MODDebug No user is currently logged in
    5/11/2012 4:49 PM FOG::MODDebug Hostname: WSC04632
    5/11/2012 4:49 PM FOG::MODDebug Attempting to open connect to: http://192.168.1.210/fog/service/debug.php
    5/11/2012 4:49 PM FOG::MODDebug Server responded with: Hello FOG Client
    5/11/2012 4:49 PM FOG::MODDebug Module has finished work and will now exit.
    5/11/2012 4:50 PM FOG::UserTracker Event: LOGIN for WSC04632\Administrator
    5/11/2012 4:50 PM FOG::UserTracker Record processed by server!
    [/CODE]


  • Moderator

    Make sure the account you are using to join computers has been delegated rights to add and remove computer accounts to the domain. A default user can only add so many before being denied and cannot remove or modify any computer accounts.



  • It looks like it is doing what mine does. I get the same error on some of my windows 7 machines. Once rebooted, they join without problem. Just ran into this today so unsure as to what is causing it as of yet.



  • I am certainly no expert on the FOG Service (although it does work fine for me) but I would venture to guess that your image was joined to the domain/network before it was uploaded. This is not the way to do it; it should be joined to a WORKGROUP (any workgroup).

    I have had co-workers swear up and down that “it was [U][B]not[/B][/U] joined to the domain and that it [U][B]was[/B][/U] joined to WORKGROUP” before uploading the image. Then we go and check it and they put:

    Member of:
    Domain:
    WORKGROUP

    Workgroup:
    (blank, greyed out)

    Obviously this is wrong…

    I am not saying for sure that is your problem, but maybe. It does look like the FOG service successfully changed the name of your workstation; it was just not able to join the domain.

    In my environment I have had the best results with the FQDN as the FOG_AD_DEFAULT_DOMAINNAME and the FQDN%USERNAME% as the FOG_AD_DEFAULT_USER (example):

    FOG_AD_DEFAULT_DOMAINNAME: scrantonpa.internal.contoso.com – Not just [B]scrantonpa[/B] (primary domain name)
    FOG_AD_DEFAULT_USER: scrantonpa.internal.contoso.com\contosoadmin

    Also make sure that your user account (contosoadmin in my example) has full AD privileges to join machines to the domain; IMHO that account does need to be a Domain Admin.

    Also the “FOG Passkey” cannot be the same as the password for your Domain Admin account. I foolishly tried this once and it would not work. After I just changed the “FOG Passkey” to something different and re-encrypted my AD password, everything worked great!

    Also you did copy over hostnamechange.dll to the FOG service installation directory after you re-compiled it, correct? You MUST have that in place and often people, myself included, forget that step when installing the FOG service on a new image.

    Cheers!


 

398
Online

41.5k
Users

12.0k
Topics

113.5k
Posts