Configuration serveur FOG menu pxe redirection vers serveur ubuntu 18.04 LTSP



  • Bonjour,

    Je suis novice sur fog et il faut de que je configure une redirection depuis le menu PXE fog vers un serveur LTSP.
    Quelles sont les commandes à respecter dans l’interface du menu PXE FOG ?

    Bien cordialement

    Hello,

    I am new to fog and I need to configure a redirection from the PXE fog menu to an LTSP server.
    What are the commands to follow in the PXE FOG menu interface?

    Best regards



  • @george1421 C’est bon j’ai trouvé !!!

    J’ai remplis ceci dans le menu IPEX de FOG :
    It’s good I found !!!

    I filled this out in the FOG IPEX menu:

    set net0/next-server 10.20.14.210
    set net0/filename ltsp/amd64/pxelinux.0
    chain tftp://10.20.14.210/ltsp/amd64/pxelinux.0
    

    Et la !! ça marche !!!

    Merci beaucoup pour votre réactivité et surtout pour le temps passé !!
    Bonne soirée
    @@@+++

    And the !! it works !!!

    Thank you very much for your responsiveness and especially for the time spent!
    Good night
    @@@+++


  • Moderator

    @franck25 So we were very close in my early posts. I’m glad you now have a solution!!!



  • @george1421 C’est bon j’ai trouvé !!!

    J’ai remplis ceci dans le menu IPEX de FOG :
    It’s good I found !!!

    I filled this out in the FOG IPEX menu:

    set net0/next-server 10.20.14.210
    set net0/filename ltsp/amd64/pxelinux.0
    chain tftp://10.20.14.210/ltsp/amd64/pxelinux.0
    

    Et la !! ça marche !!!

    Merci beaucoup pour votre réactivité et surtout pour le temps passé !!
    Bonne soirée
    @@@+++

    And the !! it works !!!

    Thank you very much for your responsiveness and especially for the time spent!
    Good night
    @@@+++


  • Moderator

    @franck25 Well what I see only gives me a head ache, because I see the iPXE kernel loading (what FOG’s using but not this version) but then its calling pxelinux (syslinux). The confusion is that syslinux and iPXE are competing technologies. You would normally use one or the other but not both.

    Forget what I just said, I see you are using virtualbox (that software) uses iPXE as its boot ROM.

    Lets change direction and try something new.

    In the /var/lib/tftpboot/ltsp/amd64 on your LTSP server there is a file called pxelinux.cfg, please posts it contents here so I can review it. It should be a small text file.



  • @george1421 Je précise que quand mon serveur LTSP démarre (sans passer par fog) j’ai ceci qui s’affiche :
    I specify that when my LTSP server starts (without going through fog) I have this displayed:
    image30.jpg

    Si ça peux aider
    If it helps



  • @franck25 depuis une machine virtuel et physique même résultat.



  • @george1421 Ok je comprend le principe. Merci pour l’explication.
    On avance mais il y a tjs quelque chose qui bloque…

    Ok I understand the principle. Thanks for the explanation.
    In advance but there is something that has chosen to block …

    Pour :
    For :
    set 209:string ltsp/amd64/pxelinux.0
    set 210:string tftp://10.20.14.210
    chain tftp://10.20.14.210/ltsp/amd64/pxelinux.0

    Message erreur : Failed to load ldlinux.c32

    Pour :
    For :

    set pxeserver:ipv4 10.20.14.210
    set next-server ${pxeserver}
    chain tftp://${pxeserver}/ltsp/amd64/pxelinux.0

    La un peut bizarre, quand je valide LTSP dans le menu fog. je vois une fraction de seconde un menu pxe à l’ancienne avec dans le menu un onglet fog (impossible de vous faire un imprime ecran ca va trop vite) et le pc relance un boot en pxe.

    Bien cordialement

    One can be odd, when I validate LTSP in the fog menu. I see a fraction of a second old pxe menu with a fog tab in the menu (you can not print a screen that goes too fast) and the pc restart a boot in pxe.

    Best regards


  • Moderator

    @george1421 This one may have been the solution: https://forums.fogproject.org/post/90507

    set pxeserver:ipv4 10.20.14.210
    set next-server ${pxeserver}
    chain tftp://${pxeserver}/ltsp/amd64/pxelinux.0
    

    One of these solutions has to be the answer. I know its possible we just need to release control from iPXE and take over with syslinux.


  • Moderator

    @george1421 said in Configuration serveur FOG menu pxe redirection vers serveur ubuntu 18.04 LTSP:

    This looks close to what I remember:

    set 209:string ltsp/amd64/pxelinux.0
    set 210:string tftp://10.20.14.210
    chain tftp://10.20.14.210/ltsp/amd64/pxelinux.0
    

  • Moderator

    @franck25 said in Configuration serveur FOG menu pxe redirection vers serveur ubuntu 18.04 LTSP:

    set net0/next-server 10.20.14.210
    set filename ltsp/amd64/pxelinux.0

    I feel these methods are wrong. I’ve configured something like what you are doing but I’m sure I use different commands. What we have to do is fill the environment like it came from dhcp and then chain to it.



  • @george1421 J’ai refait le test :

    I redid the test:

    set net0/next-server 10.20.14.210
    set filename ltsp/amd64/pxelinux.0
    chain tftp://10.20.14.210/ltsp/amd64/pxelinux.0

    Erreur :Capture du 2019-05-29 23-48-59.png

    Je vous fait une petite copie du répertoire /var/lib/tftpboot/ltsp/amd64 :
    I give you a little copy of the repertoire /var/lib/tftpboot/ltsp/amd64 :

    srv-ltsp@srvltsp:/var/lib/tftpboot/ltsp/amd64$ ls -lh
    total 71M
    -rw-r–r-- 1 root root 212K févr. 7 12:10 config-4.18.0-15-generic
    -rw-r–r-- 1 root root 104K mai 24 18:07 gpxelinux.0
    drwxr-xr-x 5 root root 4,0K mai 24 17:30 grub
    lrwxrwxrwx 1 root root 28 mai 24 18:12 initrd.img -> initrd.img-4.18.0-15-generic
    -rw-r–r-- 1 root root 58M mai 24 18:08 initrd.img-4.18.0-15-generic
    lrwxrwxrwx 1 root root 28 mai 24 18:13 initrd.img-generic -> initrd.img-4.18.0-15-generic
    -rw-r–r-- 1 root root 114K mai 24 18:07 ldlinux.c32
    -rw-r–r-- 1 root root 2,6K mai 24 18:13 lts.conf
    -rw-r–r-- 1 root root 179K janv. 28 2016 memtest86+.bin
    -rw-r–r-- 1 root root 181K janv. 28 2016 memtest86+.elf
    -rw-r–r-- 1 root root 181K janv. 28 2016 memtest86+_multiboot.bin
    -rw-r–r-- 1 root root 41K mai 24 18:07 pxelinux.0
    drwxr-xr-x 2 root root 4,0K mai 24 18:13 pxelinux.cfg
    -rw-r–r-- 1 root root 4,1M févr. 7 12:10 System.map-4.18.0-15-generic
    lrwxrwxrwx 1 root root 25 mai 24 18:12 vmlinuz -> vmlinuz-4.18.0-15-generic
    -rw-r–r-- 1 root root 8,2M févr. 10 01:25 vmlinuz-4.18.0-15-generic
    lrwxrwxrwx 1 root root 25 mai 24 18:13 vmlinuz-generic -> vmlinuz-4.18.0-15-generic

    Si ça peut vous aidez.
    If it can help you.


  • Moderator

    @franck25 Ah OK, the first one looked promising, but I see from your second test I missed a value.

    set net0/next-server 10.20.14.210
    set filename ltsp/amd64/pxelinux.0
    chain tftp://10.20.14.210/ltsp/amd64/pxelinux.0
    

    Also ensure that pxelinux.0 is located on 10.20.14.210 in /tftpboot/ltsp/amd64 directory.

    Our goal here is to transfer control from FOG’s iPXE to LTSP’s syslinux. The first screen shot does what we want. The second and third test you provided iPXE is still in control. You are very close to having it work.



  • @george1421 Bonjour,

    J’ai pu tester 2 ou 3 paramétrages dans le menu fog.
    Alors !
    1er essai :

    I was able to test 2 or 3 settings in the fog menu.
    So !
    1st test:

    set net0/next-server 10.20.14.210
    set filename pxelinux.0
    chain tftp://10.20.14.210/pxelinux.0

    Message erreur :Capture du 2019-05-29 23-48-59.png

    2eme essais :
    2nd tests:

    set net0/next-server 10.20.14.210
    set filename pxelinux.0
    chain tftp://10.20.14.210/ltsp/amd64/pxelinux.0

    Message erreur :
    Capture du 2019-05-29 23-52-35.png

    3eme essais :
    3rd tests:

    chain tftp://10.20.14.210/pxelinux.0

    Message erreur :

    Capture du 2019-05-30 00-05-03.png

    Compliquer tout ça ^^
    Complicate all that ^^

    Cordialement


  • Moderator

    @franck25 Ok lets see if we can make this work.

    This will be for the fog iPXE menu configuration
    Menu Item: LTSP
    Description: Boot into the LTSP environment
    Parameters:

    set net0/next-server 10.20.14.210
    set filename pxelinux.0
    chain tftp://10.20.14.210/pxelinux.0
    

    Manu Show with: All Hosts

    You might be able to skip the set commands and just use the chain from above.

    chain tftp://10.20.14.210/pxelinux.0
    

    I have not tested this but “maybe” will work.



  • Merci pour votre réactivité.
    Si je configure mon serveur DHCP pour démarrer sur le serveur LTSP je renseigne:
    nom du fichier: ltsp / amd64 / pxelinux.0
    serveur suivant: 10.20.14.210
    Pour mon serveur FOG je renseigne:
    nom du fichier: undionly.kpxe
    serveur suivant: 10.20.14.12

    Cordialement

    Thank-you for your prompt response.
    If I configure my DHCP server to start on the LTSP server I inform:
    file name: ltsp / amd64 / pxelinux.0
    next server: 10.20.14.210
    For my FOG server I inform:
    filename: undionly.kpxe
    following server: 10.20.14.12

    cordially



  • This post is deleted!

  • Moderator

    Lets start with this, if fog was not used, how would you boot into LTSP? If we know this answer then we can build a custom fog iPXE menu to boot into LTSP.


Log in to reply
 

278
Online

7.4k
Users

14.5k
Topics

136.5k
Posts