• Hi guys, I’ve been trying relentlessly just to get an image of Windows 7 to deploy.

    I’ve tried single and multi-partition styles, before and after sysprep, vmware and hardware, with and without the 100mb partition.

    The problem is after any deploy, either the mbr or partition’s bootsector is corrupt or wrong, and the machine won’t boot!

    I’ve followed tutorials and the user guides on the wiki to no avail, any ideas?

  • Alright, I finally managed to get it working using just fogprep and mutli-partition non-resizable. I suppose that will have to do.

  • Have you updated to the latest BIOS on the test machines? Also check your AHCI/ATA settings in the BIOS; it probably should be set to AHCI but try ATA just for the heck of it.

    I do not have much experience with FOG on Linux 12; we are sure that 12.04 works correctly?

    Even though no one would use XP, it would help to test the system.

    Also have you checked that your image definition is correct syntax and set to Windows 7 type? I know it sounds silly, but often these kinds of problems have a very simple answer.

    The only other thing I can think of that would cause that would be bad sectors on the hard drive (source or destination), or bad RAM; but my guess is that you have tried it on enough different hardware to eliminate that possibility??

  • Yes, I’ve tried non-VM as well, running Fog on 12.04 desktop 32-bit(supported 12.10 is not, had troubles with that aplenty.)

    I don’t have anybody who will be using XP so even if that worked it would get me nowhere. I’ve tried both partitioning styles with and without 100mb partition(see first post.)

  • No problem!

    Have you tried a non-vmware image to/from an actual Optiplex 755, with kernel 3.3.3, with basic sysprep? That would be a pretty default setup. Also, I should have asked what version of Ubuntu you use for the FOG server? Version 12 of Ubuntu is not supported by FOG 0.32 by default.

    Beyond that, try a Windows XP image, or yes, a Linux image although be aware you have to install GRUB, etc. to successfully upload/deploy Linux images. If partitions and files are created when you deploy then it does not seem like a problem with FOG, per se, but something to do with your image. I know that my default setup for Windows 7 images is “single partition, re-sizable” and it works fine even though I do use the 100mb partition at the beginning. I know that this is slightly confusing, but this is the default setup for FOG 0.32 images of windows 7, not the “multi partition, non resizable”; but obviously try both since you are having problems.

    I am trying to think of what else it could be…

  • Thanks by the way for all of your help so far.

    I’m doing sysprep /OOBE and /generalize, with no fanciness in the image itself, clean installation.

    I did the startup repair from the windows disk to fix the MBR when it said no boot device found, I was never able to get the missing bootsector one resolved. Both of these are post-BIOS, pre-boot. I never get a W7 logo unless I manage to fix the MBR. I have a WDS server, and can capture and install with it just fine.

    I really don’t know how to describe it further, it seems to me to be the simplest of setups because I’m just trying to get anything at all to work at this point. Even re-installed Ubuntu, FOG, and the Windows client from scratch, including building a custom FOG kernel to capture the VMWare SCSI drive. Maybe I should try a Linux image and see how far that gets…

  • I am not aware of any way to run automatic diagnostics on the image file itself; that is a good idea though. Of course you can check the size, date, etc. manually and look for obvious errors like a tiny image file or wrong date stamp.

    You say that a “windows repair” fixes the machine and it will boot, but earlier you said that BIOS displayed “No Boot Device”; this is slightly confusing to me and slightly contradictory, forgive me. Describe the exact “boot error” process including screens, text, etc; this should be fairly easy to replicate the exact same thing every time.

    I have definitely done 755’s successfully with Windows 7 but I have also had a few problems with them. If the outline of the colored windows 7 logo appears for a brief millisecond and the machine cold restarts (with no text) [U]in a constant reboot loop[/U] where the windows 7 logo never “comes together” in the center of the screen, that is almost certainly a sysprep issue; either it is not active or it is not set up correctly. This is a pain, but in windows 7 it does often need sysprep even to deploy the exact same image to/from the exact same machine (slightly mind boggling!). My advice would be to create the most generalized, basic sysprep image that you can (WITH OOBE and WITHOUT unnattend.xml just to test things out) and see if you can get that to load. You want to just run sysprep from a basic windows 7 installation without any fanciness just to test the environment before adding unnattend.xml parameters, etc.

    I know that it seems stupidly simple, but see this link for the absolute most basic sysprep deployment:

    I have to head out of the office now and I will be in my garage tonight, so I will not reply immediately, but describe it further and I will see what I can dig up.


  • I’ve monitored it to completion and it does create the NTFS partition just fine. This is a fresh install of Windows, so no other utility-esque partitions to be concerned with. If I fix the MBR or bootsector, Windows boots fine, but I can’t do this remotely of course.

    I’m trying to image onto Optiplex 755s (at the moment), if it makes a difference.
    My setup is pretty basic as far as the FOG-server and clients go, just a shop test at the moment. I plan to use FOG in school-lab environments.

    The imaging process appears(from my little experience with FOG) to go fine. It seems the image itself is the problem.

    Is there any way to run a diagnostic of some sort on the image file?

  • Are you watching the progress bar to make sure that the imaging task completes to 100%? If it stops at 20%-40% and just dumps out (and task scheduler thinks that it is in fact complete!) then you do have a corrupt image or another software problem. I missed this a few times because I was doing something else while it imaged; you get in the habit of not watching because usually it is fine and watching progress bars is boring, but occasionally you have to watch just to make sure…

    Also check that your BIOS is fully up to date; that can help. And have you tried a Windows XP image just to test the system? Also you said that you have tried with and without 100mb partition for BitLocker, that is good; but could there be other (utility) partitions on your source hard disk? Check this with Gparted or similar. Also try wiping the disk and checking it with Gparted immediately post-image; are there NTFS partitions created? Or just nothing? If the partitions do exist maybe you can explore them from a test system to see if your files, sofware, etc. are intact post-image.

    Beyond that, just send over some more information about your setup and what you have and have not tried; and maybe that will point us in the right direction.


  • I’ve tried 3 images, before and after sysprep and a vm-image, so I doubt that its a corrupt image issue.
    And they had chkdsk run before-hand.

    Tried installing to 2 separate machines that had previously run Windows 7 just fine.

    After imaging the BIOS says "No boot device found(bad MBR right?), or after the VM-image it said no Operating System found(bad bootsector right?).

  • Sounds like the image that you have captured on your FOG server is corrupted somehow…

    Have you tried running chkdsk and re-uploading it? Also try different hard drives and different RAM if you have not already because bad hardware can cause things like this.

    Maybe if you describe your scenario and how it behaves when it won’t boot, or how you are figuring out that the mbr or bootsector is corrupt, that would help shed some light on it.