Upgrade 1.5.5 to 1.5.6 failed



  • tech@DCSO-Fogserver:~/Downloads/fogproject-1.5.6/bin$ ./installfog.sh
    [sudo] password for tech: 
    Installing LSB_Release as needed
     * Attempting to get release information.......................Done
    systemd
    
    
       +------------------------------------------+
       |     ..#######:.    ..,#,..     .::##::.  |
       |.:######          .:;####:......;#;..     |
       |...##...        ...##;,;##::::.##...      |
       |   ,#          ...##.....##:::##     ..:: |
       |   ##    .::###,,##.   . ##.::#.:######::.|
       |...##:::###::....#. ..  .#...#. #...#:::. |
       |..:####:..    ..##......##::##  ..  #     |
       |    #  .      ...##:,;##;:::#: ... ##..   |
       |   .#  .       .:;####;::::.##:::;#:..    |
       |    #                     ..:;###..       |
       |                                          |
       +------------------------------------------+
       |      Free Computer Imaging Solution      |
       +------------------------------------------+
       |  Credits: http://fogproject.org/Credits  |
       |       http://fogproject.org/Credits      |
       |       Released under GPL Version 3       |
       +------------------------------------------+
    
    
       Version: 1.5.6 Installer/Updater
    
    
     * Found FOG Settings from previous install at: /opt/fog/.fogsettings
    
     * Performing upgrade using these settings
    
    
      Starting Debian based Installation
    
    
     *** Detected a potential need to reinstall apache and php files.
     *** This will remove the /etc/php* and /etc/apache2* directories
     ***  and remove/purge the apache and php files from this system.
     *** If you're okay with this please type Y, anything else will
     ***  continue the installation, but may mean you will need to
     ***  remove the files later and make proper changes as 
     ***  necessary. (Y/N): 
    y
     * Removing apache and php files...............................Done
     * Stopping web services.......................................Failed
     * Removing the apache and php packages........................Done
     * Resetting our variables to specify php version..............Done
    
       ######################################################################
       #     FOG now has everything it needs for this setup, but please     #
       #   understand that this script will overwrite any setting you may   #
       #   have setup for services like DHCP, apache, pxe, tftp, and NFS.   #
       ######################################################################
       # It is not recommended that you install this on a production system #
       #        as this script modifies many of your system settings.       #
       ######################################################################
       #             This script should be run by the root user.            #
       #      It will prepend the running with sudo if root is not set      #
       ######################################################################
       #            Please see our wiki for more information at:            #
       ######################################################################
       #             https://wiki.fogproject.org/wiki/index.php             #
       ######################################################################
    
     * Here are the settings FOG will use:
     * Base Linux: Debian
     * Detected Linux Distribution: Ubuntu
     * Interface: eno1
     * Server IP Address: 10.106.120.81
     * Server Subnet Mask: 255.255.255.0
     * Server Hostname: 
     * Installation Type: Normal Server
     * Internationalization: 0
     * Image Storage Location: /images
     * Using FOG DHCP: No
     * DHCP will NOT be setup but you must setup your
     | current DHCP server to use FOG for PXE services.
    
     * On a Linux DHCP server you must set: next-server and filename
    
     * On a Windows DHCP server you must set options 066 and 067
    
     * Option 066/next-server is the IP of the FOG Server: (e.g. 10.106.120.81)
     * Option 067/filename is the bootfile: (e.g. undionly.kpxe)
    
    
     * Are you sure you wish to continue (Y/N) y
    
     * Installation Started
    
     * Testing internet connection.................................Done
     * Adding repository if needed.................................OK
     * Preparing Package Manager...................................OK
     * Packages to be installed:
    
    	apache2 bc build-essential cpp curl g++ gawk gcc genisoimage gzip htmldoc isolinux lftp libapache2-mod-php7.2 libc6 libcurl4 liblzma-dev m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php7.2 php7.2-bcmath php7.2-cli php7.2-curl php7.2-fpm php7.2-gd php7.2-json php7.2-ldap php7.2-mbstring php7.2-mysql php7.2-mysqlnd php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g 
    
    
     * Installing package: apache2.................................Failed! (Will try later)
     * Skipping package:   bc......................................(Already Installed)
     * Skipping package:   build-essential.........................(Already Installed)
     * Skipping package:   cpp.....................................(Already Installed)
     * Skipping package:   curl....................................(Already Installed)
     * Skipping package:   g++.....................................(Already Installed)
     * Skipping package:   gawk....................................(Already Installed)
     * Skipping package:   gcc.....................................(Already Installed)
     * Skipping package:   genisoimage.............................(Already Installed)
     * Skipping package:   gzip....................................(Already Installed)
     * Skipping package:   htmldoc.................................(Already Installed)
     * Skipping package:   isolinux................................(Already Installed)
     * Skipping package:   lftp....................................(Already Installed)
     * Installing package: libapache2-mod-php7.2...................Failed! (Will try later)
     * Skipping package:   libc6...................................(Already Installed)
     * Skipping package:   libcurl4................................(Already Installed)
     * Skipping package:   liblzma-dev.............................(Already Installed)
     * Skipping package:   m4......................................(Already Installed)
     * Skipping package:   mysql-client............................(Already Installed)
     * Skipping package:   mysql-server............................(Already Installed)
     * Skipping package:   net-tools...............................(Already Installed)
     * Skipping package:   nfs-kernel-server.......................(Already Installed)
     * Skipping package:   openssh-server..........................(Already Installed)
     * Installing package: php7.2..................................Failed! (Will try later)
     * Installing package: php7.2-bcmath...........................Failed! (Will try later)
     * Installing package: php7.2-cli..............................Failed! (Will try later)
     * Installing package: php7.2-curl.............................Failed! (Will try later)
     * Installing package: php7.2-fpm..............................Failed! (Will try later)
     * Installing package: php7.2-gd...............................Failed! (Will try later)
     * Installing package: php7.2-json.............................Failed! (Will try later)
     * Installing package: php7.2-ldap.............................Failed! (Will try later)
     * Installing package: php7.2-mbstring.........................Failed! (Will try later)
     * Installing package: php7.2-mysql............................Failed! (Will try later)
     * Installing package: php7.2-mysql............................Failed! (Will try later)
     * Installing package: php-gettext.............................Failed! (Will try later)
     * Skipping package: sysv-rc-conf..............................(Does not exist)
     * Skipping package:   tar.....................................(Already Installed)
     * Skipping package:   tftpd-hpa...............................(Already Installed)
     * Skipping package:   tftp-hpa................................(Already Installed)
     * Skipping package:   unzip...................................(Already Installed)
     * Skipping package:   vsftpd..................................(Already Installed)
     * Skipping package:   wget....................................(Already Installed)
     * Skipping package:   xinetd..................................(Already Installed)
     * Skipping package:   zlib1g..................................(Already Installed)
     * Updating packages as needed.................................OK
     * Installing now everything is updated........................Failed!
    


  • @Sebastian-Roth they recently changed some thing to get to the internet i had entered credentials when first setup this server they must have done an update and I did not get the prompt to enter new credentials all is good now. Thanks for your help!!



  • @Sebastian-Roth Yes i saw that and once i entered my credentials it connected and started the install and looks like it is updating


  • Senior Developer

    @sgtrice said in Upgrade 1.5.5 to 1.5.6 failed:

    Failed to fetch http://hobfpproxy02.nashville.org:8080 … 401 Authorization Required [IP: 10.190.7.10 8080]

    You seem to be behind a proxy server that asks for authentication.



  • root@DCSO-Fogserver:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages were automatically installed and are no longer required:
      libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.2-0 php-common
    Use 'apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    root@DCSO-Fogserver:~# apt-get install apache2
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following package was automatically installed and is no longer required:
      php-common
    Use 'apt autoremove' to remove it.
    The following additional packages will be installed:
      apache2-bin apache2-data apache2-utils
    Suggested packages:
      apache2-doc apache2-suexec-pristine | apache2-suexec-custom
    The following NEW packages will be installed:
      apache2 apache2-bin apache2-data apache2-utils
    0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
    Need to get 1,410 kB of archives.
    After this operation, 5,878 kB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Ign:1 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-bin amd64 2.4.29-1ubuntu4.6
    Ign:2 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-utils amd64 2.4.29-1ubuntu4.6
    Ign:3 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-data all 2.4.29-1ubuntu4.6
    Err:3 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-data all 2.4.29-1ubuntu4.6
      401  Authorization Required [IP: 10.190.7.10 8080]
    Ign:4 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2 amd64 2.4.29-1ubuntu4.6
    Err:1 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-bin amd64 2.4.29-1ubuntu4.6
      401  Authorization Required [IP: 10.190.7.10 8080]
    Err:2 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-utils amd64 2.4.29-1ubuntu4.6
      401  Authorization Required [IP: 10.190.7.10 8080]
    Err:4 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2 amd64 2.4.29-1ubuntu4.6
      401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9hL2FwYWNoZTIvYXBhY2hlMi1iaW5fMi40LjI5LTF1YnVudHU0LjZfYW1kNjQuZGVi&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9hL2FwYWNoZTIvYXBhY2hlMi11dGlsc18yLjQuMjktMXVidW50dTQuNl9hbWQ2NC5kZWI=&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-data_2.4.29-1ubuntu4.6_all.deb  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9hL2FwYWNoZTIvYXBhY2hlMl8yLjQuMjktMXVidW50dTQuNl9hbWQ2NC5kZWI=&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    root@DCSO-Fogserver:~# apt-get install php7.2
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following additional packages will be installed:
      apache2 apache2-bin apache2-data apache2-utils libapache2-mod-php7.2 php7.2-cli php7.2-common php7.2-json php7.2-opcache php7.2-readline
    Suggested packages:
      apache2-doc apache2-suexec-pristine | apache2-suexec-custom php-pear
    The following NEW packages will be installed:
      apache2 apache2-bin apache2-data apache2-utils libapache2-mod-php7.2 php7.2 php7.2-cli php7.2-common php7.2-json php7.2-opcache php7.2-readline
    0 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
    Need to get 5,256 kB of archives.
    After this operation, 22.9 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Ign:1 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-bin amd64 2.4.29-1ubuntu4.6
    Ign:2 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-utils amd64 2.4.29-1ubuntu4.6        
    Ign:3 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-data all 2.4.29-1ubuntu4.6                           
    Err:3 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-data all 2.4.29-1ubuntu4.6                           
      401  Authorization Required [IP: 10.190.7.10 8080]
    Ign:4 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2 amd64 2.4.29-1ubuntu4.6                              
    Ign:5 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-common amd64 7.2.17-0ubuntu0.18.04.1                  
    Err:1 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-bin amd64 2.4.29-1ubuntu4.6                          
      401  Authorization Required [IP: 10.190.7.10 8080]
    Ign:6 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-json amd64 7.2.17-0ubuntu0.18.04.1
    Err:2 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2-utils amd64 2.4.29-1ubuntu4.6
      401  Authorization Required [IP: 10.190.7.10 8080]
    Err:4 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 apache2 amd64 2.4.29-1ubuntu4.6
      401  Authorization Required [IP: 10.190.7.10 8080]
    Ign:7 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-opcache amd64 7.2.17-0ubuntu0.18.04.1                 
    Err:5 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-common amd64 7.2.17-0ubuntu0.18.04.1                  
      401  Authorization Required [IP: 10.190.7.10 8080]
    Ign:8 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-readline amd64 7.2.17-0ubuntu0.18.04.1                
    Err:6 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-json amd64 7.2.17-0ubuntu0.18.04.1
      401  Authorization Required [IP: 10.190.7.10 8080]
    Ign:9 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-cli amd64 7.2.17-0ubuntu0.18.04.1
    Err:7 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-opcache amd64 7.2.17-0ubuntu0.18.04.1
      401  Authorization Required [IP: 10.190.7.10 8080]
    Err:8 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-readline amd64 7.2.17-0ubuntu0.18.04.1
      401  Authorization Required [IP: 10.190.7.10 8080]
    Ign:10 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libapache2-mod-php7.2 amd64 7.2.17-0ubuntu0.18.04.1
    Ign:11 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2 all 7.2.17-0ubuntu0.18.04.1
    Err:11 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2 all 7.2.17-0ubuntu0.18.04.1
      401  Authorization Required [IP: 10.190.7.10 8080]
    Err:9 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-cli amd64 7.2.17-0ubuntu0.18.04.1
      401  Authorization Required [IP: 10.190.7.10 8080]
    Err:10 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libapache2-mod-php7.2 amd64 7.2.17-0ubuntu0.18.04.1
      401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9hL2FwYWNoZTIvYXBhY2hlMi1iaW5fMi40LjI5LTF1YnVudHU0LjZfYW1kNjQuZGVi&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9hL2FwYWNoZTIvYXBhY2hlMi11dGlsc18yLjQuMjktMXVidW50dTQuNl9hbWQ2NC5kZWI=&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-data_2.4.29-1ubuntu4.6_all.deb  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9hL2FwYWNoZTIvYXBhY2hlMl8yLjQuMjktMXVidW50dTQuNl9hbWQ2NC5kZWI=&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9wL3BocDcuMi9waHA3LjItY29tbW9uXzcuMi4xNy0wdWJ1bnR1MC4xOC4wNC4xX2FtZDY0LmRlYg==&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9wL3BocDcuMi9waHA3LjItanNvbl83LjIuMTctMHVidW50dTAuMTguMDQuMV9hbWQ2NC5kZWI=&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9wL3BocDcuMi9waHA3LjItb3BjYWNoZV83LjIuMTctMHVidW50dTAuMTguMDQuMV9hbWQ2NC5kZWI=&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9wL3BocDcuMi9waHA3LjItcmVhZGxpbmVfNy4yLjE3LTB1YnVudHUwLjE4LjA0LjFfYW1kNjQuZGVi&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9wL3BocDcuMi9waHA3LjItY2xpXzcuMi4xNy0wdWJ1bnR1MC4xOC4wNC4xX2FtZDY0LmRlYg==&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://hobfpproxy02.nashville.org:8080/auth/?du=aHR0cDovL3NlY3VyaXR5LnVidW50dS5jb20vdWJ1bnR1L3Bvb2wvbWFpbi9wL3BocDcuMi9saWJhcGFjaGUyLW1vZC1waHA3LjJfNy4yLjE3LTB1YnVudHUwLjE4LjA0LjFfYW1kNjQuZGVi&ip=MTAuMTA2LjEyMC44MTo4MDgw  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/p/php7.2/php7.2_7.2.17-0ubuntu0.18.04.1_all.deb  401  Authorization Required [IP: 10.190.7.10 8080]
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    root@DCSO-Fogserver:~#
    

  • Senior Developer

    @sgtrice Please run the following commands and post output here:

    apt-get upgrade
    apt-get install apache2
    apt-get install php7.2

Log in to reply
 

278
Online

7.4k
Users

14.5k
Topics

136.5k
Posts