• Here is a screenshot of the error I get after my image hits %100 captured.

    “Invalid storage group
    Could not complete tasking (/bin/fog.upload)”
    What exactly does this mean and what steps should I take to fix this?

  • I know this is kind of old, but I had this same issue yesterday. I fixed it by running the installer and upgrading.

    I think it would have been fixed by simply re-running the installer if I didn’t have to upgrade. I was only one version behind. I’ve notice most issues with Fog can be fixed this way.

  • @cary1102 I had this situation earlier today. After changing the local user account from “Fog” to something non"Fog", the issue went away. I also changed the partition settings to Multiple Partition Image - All Disks (Not Resizable) from Single Disk - Resizable - (1).

  • Moderator

    @xisco What is your setup like? Is it just one main FOG server or do you have storage nodes as well?

    Things that happen randomly usually point to changing conditions. I suspect your database/webserver might not always answer the same way it is supposed to. This can happen if you have many hosts with the fog-client installed. How many do you have?

  • @cary1102 hi, same problem here appears randomly. Any solution?? we are using 1.5.6.

  • Hello,
    I had the same problem with version 1.5.6. Downgrading to version 1.5.0, I do not have this problem anymore.
    Version 1.5.6 seems unstable.

    best regards

  • Moderator

    @bigmac really the only issues you will have might be with punctuation and forward and back slashes in the image name. The name of the image or at least the file path needs to be valid for linux. I would also avoid the double byte characters.

  • Just in case anyone in the future runs into this, my coworker had created an image. I think the DB was unhappy with some capital letter, or a space somewhere in the name. I made a new image, just stuck to all lowercase and no special characters and the image completed fine.

  • @george1421 Sorry in advance for not further testing this issue. I have had this issue before is why I have created the thread but my solution this time was simply reinstalling Ubuntu and FOG… I dont have an explanation as to why it works now but it does.
    Anyways, thanks for your assistance!

  • Moderator

    @cary1102 This is an interesting one. All of the things that normally could be wrong are not in this case.

    Lets go ahead an schedule another capture, but this time before you hit the schedule task button tick the check box for debug. Then schedule the task. PXE boot the target computer. After a few screens of text (you will need to push enter between) it will drop you to a linux command prompt.

    At the FOS linux command prompt key in fog to start the deployment. In this mode FOG will single step through the deployment. I think there is an error message earlier in the process that we are not seeing that could give us a clue. Lets see where the very first error is.

    BEFORE you do the deployment, lets make sure you did the two prerequeites.

    1. Disable the linux firewall.
    2. Set selinux to permissive and reboot.

    Did you do both of those? I can see both causing an issue uploading images.

  • @george1421 No, I simply called my account username ‘user’

    Thing is I had FOG working perfectly before but since then I had to redo the setup I am using and therefore had to reinstall FOG.

    Again, really appreciate the fast replies.

  • Moderator

    @cary1102 Hmmm… everything looks good here. I want to be sure you weren’t doing something unexpected with the storage nodes.

    I wonder if the invalid storage group error is actually masked by the updating database issue from the initial post. Do you or have you ever used the linux user named fog or changed its password? That linux user is a service account for FOG’s use only. There are some instructions on the internet for installing fog that says create the linux user called fog and then install FOG with that account. Have you by chance done this?

  • @george1421 Sorry for the duplicate picture. Here is the all storage nodes:allstoragenodes.PNG

    @Sebastian-Roth - To answer your questions, yes it is a new install of FOG, and it never has worked before. As for the install logs I am having trouble finding them. I am new to linux so bear with me please. Thanks for your reply though.

    @george1421 Also here is the output of:
    showmount -e
    df -h


  • Moderator

    @cary1102 We as missing one screen shot “All Storage Nodes”, you duplicated “All Storage Groups” twice.

    While you are grabbing more stuff (like what Sebastian asked for) run this command at the fog server’s linux console:
    showmount -e
    df -h

  • Moderator

    @cary1102 Is this a fairly new install of FOG? Has it ever worked before? Can you please post the install logs so we can check if successfully finished installing? You find those in the directory where you ran the installer script bin/error_logs/*.log.

  • @george1421
    Thanks for the quick reply!
    I have gathered some screenshots. Hopefully I have everything you need to see.

    Here is a list of all of my storage node:

    Here is the configuration for my storage node:

    Here is all of my storage groups:

    And lastly here is my configuration for me HP_Windows7 image:

  • Moderator

    lets look at your web ui settings. This error is saying that your image doesn’t have a proper configuration. I see this is on an image upload.

    In Storage Management post screen shots of all storage nodes and all storage groups. And in image management post the screen shot of the HP_Windows7 configuration data.