SOLVED Sending discover.... DHCP Failed

  • This post is deleted!

  • @george1421 Thank you for the response. The issue was the switch. I put a “dummy” switch in place of my other one and it worked. I ended up enabling fastport on my other switch and success. Appreciate the help!

  • Moderator

    My initial reaction here is that you might have a spanning tree issue. This is where the standard spanning tree is used on the network switch and it doesn’t start forwarding for 27 seconds after the link light goes on.

    You can test this by placing a dumb (cheap unmanaged) switch between the pxe booting computer and the building switch. If it boots and images correctly then you need to look into the setting of the switch that is connected to the target computer.

    The second thing (but we can rule it out because we see enp3s0) is that FOS linux doesn’t have the proper network drivers for the target computer network adapter. But we see enp3s0 which is the driver name for the network adapter. So the network interface must be enabled and ready.

    The third thing is that the target computer has more than one network adapter and FOS linux has selected the incorrect interface for communicating.