UNSOLVED Dell Precision Tower 3420

  • I got a new VP tower
    It has m.2 500 gib
    16 gb of ram
    I7 intel
    2 sata raid 0

    Fogserver and nodes are 1.5.5

    I change image few things and still does not find m.2 drive. I unplug the sata drives and STILL does not find m.2. during the upload it says no hard drive found.
    Help please

  • @george1421
    nothing for grep BUT I started to read messages…
    My raid controller is the problem. I don’t have two m.2 and I have two sata. The controller managed all 3 drives. Because the raid controller said it only has one raid AND that is it in fogs logs. windows knows how to deal with it because the drivers were load in during install.

    I turn off raid mode and rebooted. Found all 3 drives. Now because of my setup, I am going to unplug those sata drives from the board. upload the image. THEN Grab a new one and restore with raid off. Then plug the drives back in. Should just work.

  • Moderator

    @jhalbert So its still not seeing the nvme disk? What do you get if you run grep nvme /var/log/messages ?

    Is this m.2 nvme that is installed in the slot on the mobo, or is there an expansion card in a PCI slot used?

    As for images, 1MB should be ok as long as its in a jpg format. Otherwise upload the picture to pastebin or a google drive/dropbox, share it public and post the link here.

  • @george1421 Sata is being used for backup to the m.2 and m.2 has windows installed on it. Users will use m.2 for everything and I will backup everything to the hard drives and then to a server once the backup is completed.

  • @george1421
    To be clear, raid image works fine. Sata are working in any config. Sata raid not very important in this case. Its just is how this desktop is configure what I wanted to reply to you. I know Fog will image dells because I have 100’s of dells already image and sent out. This dell, is new to us and I built this pc for my VP’s and accounting team.

    I ran the command. It finds the two disks and calls them /dev/sda and sdb. Both are sata drives

    What is the max size of a picture? I tried a 1 mb and says no? I can email them if you like

  • Moderator

    There is a couple of things that could be the problem/solution.

    First, while its not a problem here, ensure that secure boot is disabled

    In regards to raid.
    In fog configuration -> fog settings click on the expand all button. Search for kernel args and add in mdraid=true. Save the settings.

    What this does it tells FOS linux to enable the raid management drivers in the kernel. If you are using the built in, intel rapid store raid you will need this kernel arg enabled. The intel raid, is a hardware assisted software raid. To linux it will present both the physical drives as well as the logical array. Since you are not seeing the nvme disks, this is probably not your current issue but there is no harm to have this feature enabled.

    What I want you to do next is manually register this 3420 and schedule a capture or a deploy (doesn’t matter) but before you schedule the task tick the debug check box then schedule the task. Next power up the target computer but hit F12 a couple of times as soon as you see the dell logo, we want the boot menu to appear so we can do the next test. When the boot menu appears select from the bios menu (not uefi) network boot (if no bios boot options go into the firmware settings and enable legacy roms then reboot). We want to pxe boot the target computer in bios (legacy) mode. There is a known issue with Dell computers with the disk controller set to Raid-On and uefi mode. By booting in bios (legacy) mode we will be able to bypass this known issue.

    When booting in debug mode you should see several screens of text that can be cleared by pressing the enter key. After pressing enter a few times you will be dropped to a linux command prompt. At the linux command prompt I want you to key in
    lsblk and post the results here. This will show us the disks (block devices) that linux sees in this computer. You can either key in what you see here or take a clear picture of the output of that command with a mobile phone and post it here.

    Once we know what we see in bios mode we can guide you to the next steps.

    FWIW I imaged a Dell Precision 3630 last week (with sata drives) with the disks in a raid configuration and I had to switch to bios mode for imaging but the windows image and final firmware settings are uefi. Meaning you can image a uefi computer just fine in bios (legacy) mode even if the final operating mode is uefi.

  • Senior Developer

    @jhalbert said in Dell Precision Tower 3420:

    2 sata raid 0

    RAID detection is not as easy. @george1421 might be able to help you here.