[CentOS 7 - FOG 1.5.5] Boot PXE



  • Hello,

    I’m having trouble booting PXE on my client.

    I see that it receives a dhcp lease by the server FOG.

    avril 11 17:09:56 X [5616]: DHCPDISCOVER from c8:d9:d2:85:f6:93 via ens192
    avril 11 17:09:56 X [5616]: DHCPOFFER on 192.168.0.10 to c8:d9:d2:85:f6...92
    avril 11 17:09:59 X [5616]: DHCPREQUEST for 192.168.0.10 (192.168.0.1) ...92
    avril 11 17:09:59 X [5616]: DHCPACK on 192.168.0.10 to c8:d9:d2:85:f6:9...92
    

    On the client the boot starts but is mistaken on the last phases before the launch of the FOG page.

    IMG_20190411_175449[1].jpg

    I can not trace the files that causes the error.
    I searched in the following files:

    - /opt/fog/.fogsettings
    - /var/www/html/fog/service/ipxe/bg.png
    - /var/www/html/fog/service/ipxe/boot.php
    

    I configured the following files before:
    General parameters of the network:

    /etc/sysconfig/network
    NETWORKING=yes          #Activer le réseau
    

    Configuring the ifcfg-ems192 file

    /etc/sysconfig/network-scripts/ifcfg-ens192
    TYPE=Ethernet
    BOOTPROTO=none
    DEFROUTE=yes
    NAME=ens192
    UUID=X
    DEVICE=ens192
    ONBOOT=yes
    ZONE=public
    IPADDR=192.168.0.1
    NETMASK=255.255.0.0
    NETWORK=192.168.0.0
    HWADDR=X
    

    DHCP pool change

    /etc/dhcp/dhcpd.conf
    subnet 192.168.0.0 netmask 255.255.255.0 {
        subnet-mask option 255.255.255.0;
        range dynamic-bootp 192.168.0.10 192.168.0.254;
        default-lease-time 21600;
        max-lease-time 43200;
        next-server 192.168.0.1;
    

    Can you help me understand the problem? Thank you.
    Best regards.


  • Senior Developer

    @Guillaume-IT As well take a look at the Storage Node definition while you are in the web UI and make sure to correct the interface information there.


  • Moderator

    @Guillaume-IT said in [CentOS 7 - FOG 1.5.5] Boot PXE:

    1 interface: management / web server
    172.17.10.85
    -1 interface: DHCP / client that resets a station.
    192.168.0.1

    OK no problem. What you did “wrong” is when you installed fog you might not have told FOG which interface you wanted as the imaging interface. We see your configuration in situations where there is a dedicated imaging network and then a management network/internet access route.

    So how to fix…

    If you run this command ip addr show from the fog server’s linux command prompt. Note which interface is associated with which IP address. Write these down because you will need to know the imaging network interface name in the next step.

    Edit the hidden configuration file /opt/fog/.fogsettings. Update the interface in there to match the imaging network interface name.

    Then go into the Web UI and goto Fog Configuration->Fog Settings then click on the expand all button. Search the web page for the incorrect interface name and then replace the value with the proper interface name. I know there is at least one instance on that page, there may be two, I don’t remember off the top of my head.

    Now go back to the linux command prompt and rerun the FOG installer from the downloaded git repository. Just pick all of the defaults since it will load all of your settings you picked last time from the .fogsettings file.

    Once the installation is complete confirm that the IP address listed in /tftpboot/default.ipxe is pointing to the correct interface IP address, if not fix it now.

    That should clean up what happened. Its not a big deal, but you need to be aware of which interface name is your imaging network interface when you install FOG and not just pick the default. Just be aware that you can only image on the defined interface. You can’t image with FOG on both interfaces, that part isn’t going to work.


  • Senior Developer

    @Guillaume-IT said in [CentOS 7 - FOG 1.5.5] Boot PXE:

    I have 2 interfaces:

    Who told you this is gonna work??



  • @george1421

    I have 2 interfaces:

    • 1 interface: management / web server
      172.17.10.85
      -1 interface: DHCP / client that resets a station.
      192.168.0.1

  • Senior Developer

    @Guillaume-IT Edit the file /tftpboot/default.ipxe on your FOG server and put in the correct IP address. I guess you have changed the IP of your server somewhere along the way. Make sure you read those two things: https://wiki.fogproject.org/wiki/index.php/Change_FOG_Server_IP_Address and https://github.com/FOGProject/fog-community-scripts/tree/master/updateIP


  • Moderator

    Please tell me how the FOG server knows about the IP address 172.17.10.85?


Log in to reply
 

330
Online

7.4k
Users

14.5k
Topics

136.5k
Posts