UNSOLVED Changed FOG's IP address, system won't boot

  • Possibly related to my old problem, but this is on a separate server.

    Running Debian Jessie, I updated the IP address, and systems will boot into Windows if they boot from the NIC. That part is good.

    I have a Dell laptop that will not load the menu. When I attempt to boot from the NIC, in BIOS mode (no UEFI), it presents me with a GRUB prompt after downloading the iPXE items (not sure what to call it). It will not launch FOG.

    I log into the web interface, find this PC in the list, and start a Deploy (Debug) task, and it will boot me into the Fog OS. It looks good to me, so I type fog and press Enter, then it complains it can’t find the fog.postinit file.

    It was running 1.3.0. I updated to the latest stable release from GIT, updated the MySQL tables in the web interface, and tried again - no change. I cannot load the FOG menu to select anything. I ran the tftp tests from another computer on the same switch, but no change.


  • Sorry for the late reply… Tried on another computer, and I cannot get the FOG menu to appear (this computer has never registered on that FOG server).

  • @george1421 Yes I have. I found that document the first time I ran into the Netboot issue (posted above). I followed it, and the web interface loads (so I thought it was fine). It also let the computers that were stuck in a PXE boot-loop start up and boot into Windows. The current issue is that I can’t image this laptop, or even see the menu. Tomorrow when I’m back on site, I’ll test with another computer as well.

  • Moderator

    @lukebarone In regards to the IP address change of the FOG server after fog was installed, have you reviewed this wiki document: https://wiki.fogproject.org/wiki/index.php/Change_FOG_Server_IP_Address