v1.5.5 with https and fog client



  • Hello, thanks for Fog Project and all your big work on it.

    I’m testing FOG Project v1.5.5 with https and I have a problem with fog client.

    Well, i’m not sure if https causes the problem, but when I do an installation without it the client agent works correctly.

    I follow these steps in htpps installation:
    ./installfog.sh --force-https
    and when it finishes:
    utils/FOGiPXE/buildipxe.sh

    The MD5 sums match in:
    openssl rsa -modulus -noout -in /opt/fog/snapins/ssl/.srvprivate.key | openssl md5
    openssl x509 -modulus -noout -in /var/www/fog/management/other/ssl/srvpublic.crt | openssl md5

    The host is created on the server with “Perform Full Host Registration” on boot. I think all its fields in the DB are correct, MAC especially.

    On client fog.log appears “Invalid MAC address format” constantly on Authentication section:

    Data::RSA FOG Server CA cert found
    Middleware::Authentication Cert OK
    Middleware::Communication POST URL: http://XXX.XX.XX.XX/fog/management/index.php?sub=requestClientInfo&authorize&newService
    Middleware::Response Invalid MAC address format
    Middleware::Response Success

    After that, in all sections:
    Middleware::Response ERROR: Unable to get subsection
    Middleware::Response ERROR: Referencia a objeto no establecida como instancia de un objeto.

    I “Reset Encription Data” on host (when the button appears in it), creating a group with it and manually on DB too.

    MAC is correct in DB. I tried putting manually host in the server and get the same problem.

    Using debugger.exe command “middleware authentication handshake” I get:

    • Middleware : Authentication Error: Could not get security token
    • Middleware : Authentication Error: Clave no válida para utilizar en el estado actual

    There’s a file named token.dat in fog directory of client with current date.

    Now i’m not sure if all my steps in the installation were correct and I’m lost, I don’t know what try, change,… :S

    Thanks in advance 🙂


  • Senior Developer

    @Antonio said in v1.5.5 with https and fog client:

    Middleware::Communication POST URL: http://XXX.XX.XX.XX

    See the URL is not HTTPS. You need to modify the client’s setting file C:\Program Files (x86)\FOG\settings.json and set HTTPS to 1.

    I know we should update the fog-client installer to reflect this option on the GUI installer as well but for now you can use installer parameters to set the option.

    As well the “Invalid MAC address format” is missleading. Sorry for that.



  • Now it works perfectly, thanks!


  • Senior Developer

    @Antonio said in v1.5.5 with https and fog client:

    Middleware::Communication POST URL: http://XXX.XX.XX.XX

    See the URL is not HTTPS. You need to modify the client’s setting file C:\Program Files (x86)\FOG\settings.json and set HTTPS to 1.

    I know we should update the fog-client installer to reflect this option on the GUI installer as well but for now you can use installer parameters to set the option.

    As well the “Invalid MAC address format” is missleading. Sorry for that.


Log in to reply
 

327
Online

7.4k
Users

14.5k
Topics

136.5k
Posts