Issue uploading image to fog, goes to 100% and shows Updating Database failed



  • Hello everyone,

    I work in a highschool in France and I use FOG since July 2016 - Installed on Ubuntu 14.04 LTS.

    So far, everything has always worked perfectly, really it’s my best server, I’m so glad it exists - Uploaded more than 50 images to my server and deployed these over 1,500 clients, all of them on Win7 Pro (we didn’t have rights to install Win10 yet untill just now). I’ve a DNS/DHCP server on a Win2012 R2 Server, no DHCP on FOG.

    Recently we received 10 new PCs, these are the first ones that will be installed with Win10 Pro… I created the master for a new image, and when it was time to upload it, it was hanging at the beginning over the line “Configuring net0 (MAC ADDRESS)…” resulting in" No configuration methods succeeded" and therefore never reaching FOG menu. First time I’ve had this error.

    I’ve seen somewhere that I should change in my DHCP server, the option 67 from “undionly.kpxe” to “ipxe.kpxe” in order to resolve the issue - and a link to download the said file (ipxe.kpxe) to put in TFTP folder (/tftpboot for my fog install).

    So I downloaded it and went to the server to put it in /tftpboot, but I sadly couldn’t remember the password I setup back then - so I went in ubuntu recovery mode and changed password for user “fog” (the only user of the machine) to something else with command passwd.
    I’ve seen I already had ipxe.kpxe file in tftpboot so I didn’t change it. I changed option67 in my server to “ipxe.kpxe” and now new PC can get to fog menu over ipxe - great!

    But now I have a problem, I can’t upload images anymore to FOG - even on old machines.

    It will go all the way up to 100% and shows on screen “Cloned successfully” and about a dozen seconds later “Updating Database… Failed - Error returned: Type 2, File /var/www/html/fog/lib/fog/fogftp.class.php Line: 107, Message ftp_login(): Login incorrect, host: fog ip address Username : fog”
    Image will be stuck on /tmp/pigz1 and won’t go to /images.

    I changed back “ipxe.kpxe” to “undionly.kpxe” in DHCP option 67 but I still have the same Updating database failed error at 100%, so I guess the problem comes from when I changed the fog password on my Ubuntu Server and now maybe it doesn’t have the rights anymore to move files from /tmp to /images …

    Do you have any ideas on how to resolve this issue?

    Thanks in advance !!


  • Senior Developer

    @MepH said:

    so I went in ubuntu recovery mode and changed password for user “fog” (the only user of the machine) to something else with command passwd.

    The issue arises from the fact that FOG is using this account for internal FTP transfers and now that you changed the password this fails. Easy fix: Login to the web UI -> Storage -> edit Storage Node (usually named “DefaultMember”) -> scroll to the bottom and click the eye symbol to see the password. It’s a long string which quite often ends with one or two equal signs. I advise you to set this password for the fog user (again using the command passwd).

    This account is not to be used to administrate the server! As you see it can cause issues when you miss-use this account. 😉



  • I’ve changed fog user password to what was written at the bottom in web UI -> Storage -> DefaultMember as you just said, and it worked perfectly ! I just uploaded one more Image and no error - task complete and I am able to deploy it. Thanks a lot guys !! ISSUE SOLVED


  • Moderator

    @MepH It sounds like you listened to bad advice when you setup your FOG server. You should never use the linux user fog for system administration. That account is owned by the FOG application and maintains control of it. Please use (create) another user account for system administration.

    Sebastian is spot on with telling you how to fix this. I also have a tutorial on this issue because it happens quite often. There are several how-to-install FOG instructions that tell users to create the fog account and then install FOG using it. That is bad advice.

    https://forums.fogproject.org/topic/11203/resyncing-fog-s-service-account-password


  • Senior Developer

    @MepH said:

    so I went in ubuntu recovery mode and changed password for user “fog” (the only user of the machine) to something else with command passwd.

    The issue arises from the fact that FOG is using this account for internal FTP transfers and now that you changed the password this fails. Easy fix: Login to the web UI -> Storage -> edit Storage Node (usually named “DefaultMember”) -> scroll to the bottom and click the eye symbol to see the password. It’s a long string which quite often ends with one or two equal signs. I advise you to set this password for the fog user (again using the command passwd).

    This account is not to be used to administrate the server! As you see it can cause issues when you miss-use this account. 😉


Log in to reply
 

286
Online

7.4k
Users

14.5k
Topics

136.6k
Posts