Fog server refusing connection to clients



  • Hey guys

    So I’m working on mass deploying the Fog client to all of our users computers so I can send images to them. I have the MSI set to install via batch file with the correct parameters.

    msiexec /i "C:\temp\FOGService.msi" /qn USETRAY="1" HTTPS="0" WEBADDRESS="192.168.10.138" WEBROOT="/fog" ROOTLOG="1"
    

    The test computers I have deployed it on are getting the following:

    
    ------------------------------------------------------------------------------
    ----------------------------------AutoLogOut----------------------------------
    ------------------------------------------------------------------------------
     3/20/2019 2:01 PM Client-Info Client Version: 0.11.16
     3/20/2019 2:01 PM Client-Info Client OS:      Windows
     3/20/2019 2:01 PM Client-Info Server Version: 
     3/20/2019 2:01 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    -----------------------------DefaultPrinterManager----------------------------
    ------------------------------------------------------------------------------
     3/20/2019 2:01 PM Client-Info Client Version: 0.11.16
     3/20/2019 2:01 PM Client-Info Client OS:      Windows
     3/20/2019 2:01 PM Client-Info Server Version: 
     3/20/2019 2:01 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------DisplayManager--------------------------------
    ------------------------------------------------------------------------------
     3/20/2019 2:01 PM Client-Info Client Version: 0.11.16
     3/20/2019 2:01 PM Client-Info Client OS:      Windows
     3/20/2019 2:01 PM Client-Info Server Version: 
     3/20/2019 2:01 PM Middleware::Response Success
     3/20/2019 2:01 PM DisplayManager ERROR: Invalid settings provided
    ------------------------------------------------------------------------------
    
     3/20/2019 2:01 PM Service ERROR: Unable to parse sleep time
     3/20/2019 2:01 PM Service ERROR: Input string was not in a correct format.
     3/20/2019 2:01 PM Service Sleeping for 60 seconds
     3/20/2019 2:01 PM Bus::Client ERROR: No connection could be made because the target machine actively refused it
     3/20/2019 2:01 PM Bus::Client ERROR: No connection could be made because the target machine actively refused it
    

    These machines are NOT registered to the server, but I was hoping the client would take care of that as I’ve seen it before for my Windows machines.

    Could someone point where I’m going wrong?



  • @Tom-Elliott

    Chain INPUT (policy ACCEPT)
    target       prot  opt  source                     Destination 
    
    Chain FORWARD (policy ACCEPT)
    target       prot  opt  source                     Destination 
    
    Chain OUTPUT (policy ACCEPT)
    target       prot  opt  source                     Destination 
    

    For iptables. Appreciate the help on this!


  • Senior Developer

    @Samuel1010 Is the fogserver still configured with either selinux and/or firewall?

    sudo sestatus
    sudo iptables -L -n



  • @Tom-Elliott

    Yeah I have it under the A name in my DNS, the actual client for other computers uses IP as well, so both are being used


  • Senior Developer

    @Samuel1010 is there a dns entry for the name fogserver and does it point at your actual fogserver?



  • @Sebastian-Roth

    {
      "HTTPS": "0",
      "Tray": "1",
      "Server": "fogserver",
      "WebRoot": "/fog",
      "Version": "0.11.16",
      "Company": "FOG",
      "RootLog": "1"
    }
    

    Just checked again on my hosts, still only showing the ones I’ve added via registration in pxe


  • Developer

    @Samuel1010 said in Fog server refusing connection to clients:

    Service ERROR: Unable to parse sleep time

    I am wondering if your settings file is corrupt. Can you please take a look at C:\Program Files (x86)\FOG\settings.json and post the full contents here.



  • @Sebastian-Roth

    Sorry for the late reply, had a catastrophe with our server and had to rebuild it.

    The only thing imported are the images and now I’m on Ubuntu.

    The log is on my Windows 7 PC in the user folder, this is the most recent after the server rebuild

    So what I’m expecting is having computers with the FOG client on, to be displayed in the hosts menu in FOG, but they arent listed, they get listed if I register them in PXE.

    My log is reading;

     3/29/2019 8:58 AM Service ERROR: Unable to parse sleep time
     3/29/2019 8:58 AM Service ERROR: Input string was not in a correct format.
     3/29/2019 8:58 AM Service Sleeping for 60 seconds
     3/29/2019 8:58 AM Bus::Client ERROR: No connection could be made because the target machine actively refused it
     3/29/2019 8:58 AM Bus::Client ERROR: No connection could be made because the target machine actively refused it
     3/29/2019 8:59 AM Middleware::Response Success
    
    ------------------------------------------------------------------------------
    ----------------------------------AutoLogOut----------------------------------
    ------------------------------------------------------------------------------
     3/29/2019 8:59 AM Client-Info Client Version: 0.11.16
     3/29/2019 8:59 AM Client-Info Client OS:      Windows
     3/29/2019 8:59 AM Client-Info Server Version: 
     3/29/2019 8:59 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    -----------------------------DefaultPrinterManager----------------------------
    ------------------------------------------------------------------------------
     3/29/2019 8:59 AM Client-Info Client Version: 0.11.16
     3/29/2019 8:59 AM Client-Info Client OS:      Windows
     3/29/2019 8:59 AM Client-Info Server Version: 
     3/29/2019 8:59 AM Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    --------------------------------DisplayManager--------------------------------
    ------------------------------------------------------------------------------
     3/29/2019 8:59 AM Client-Info Client Version: 0.11.16
     3/29/2019 8:59 AM Client-Info Client OS:      Windows
     3/29/2019 8:59 AM Client-Info Server Version: 
     3/29/2019 8:59 AM Middleware::Response Success
     3/29/2019 8:59 AM DisplayManager ERROR: Invalid settings provided
    ------------------------------------------------------------------------------
     
    
     3/29/2019 8:59 AM Service ERROR: Unable to parse sleep time
     3/29/2019 8:59 AM Service ERROR: Input string was not in a correct format.
     3/29/2019 8:59 AM Service Sleeping for 60 seconds
     3/29/2019 8:59 AM Bus::Client ERROR: No connection could be made because the target machine actively refused it
     3/29/2019 8:59 AM Bus::Client ERROR: No connection could be made because the target machine actively refused it
    ```

  • Developer

    @Samuel1010 Please give us some more context. In which log do you see this error? Please post more information or possibly a picture of where you see this.



  • Appears I’ve got somewhere with this, now i’m having the following in my log

    Service ERROR: Input string was not in a correct format.
    


  • @george1421

    Okay interesting, so on mine I have the batch file look for existing installations of FOG, if theres non then just run the MSI, seems to have worked for that one client, but theres no way of telling since registering on the fog server seems sporadic right now

    Also found the firewall things here;

    https://wiki.fogproject.org/wiki/index.php/Client_Setup#Firewall_Exceptions


  • Moderator

    @george1421 I was able to get the MDT server up and running.

    This is the install.cmd file for installing the FOG client in the Golden image before image capture. The only thing different from what you need to do is for the golden image we need to stop the fog service so that it doesn’t start running during WinSetup/OOBE.

    @Echo Off
    start /wait msiexec.exe /i FOGService.msi /quiet USETRAY="0" WEBADDRESS="192.168.1.53"
    net stop "FogService"
    sc config "FogService" start= disabled
    

    I can’t seem to find the firewall command, it was a firewall advanced command syntax. I’ll keep looking for a little bit, but not very long since it appears your systems are starting to chat in.



  • @george1421
    Okay heres something wild, I dont know how but a random users PC just registered itself on the Fog server, though I havent set my script to deploy to anyone, only a specific OU…

    So I guess the good news is that it worked for one machine, the bad news is I think I just pushed Fog out prematurely

    edit: Okay turns out I deployed it somehow, no going back now. At least its worked for one computer!


  • Moderator

    @Samuel1010 I’m going to see if I can resurrect my old Windows MDT server that we used to create the Win7 golden images. I’m pretty sure I had a package to install the fog client command lines and firewall settings. Let me see what I can find.



  • @george1421

    I’m not seeing any in pending, my first ever machine I put the client on did work, and went to pending but two I’ve just installed it on arent showing with the log errors as above, I’m gonna check firewall out


  • Moderator

    Your msi command looks correct. If I remember right the client will talk to the fog server and it will register the hosts in a pending state. You still need to approve the host in the FOG webui. Also you might need to allow the fog client access through the windows firewall. Its been a while since I’ve used and provisioned the FOG client so I can’t say just installing the fog client sets the firewall rule.


Log in to reply
 

319
Online

6.1k
Users

13.5k
Topics

127.2k
Posts