Lenovo X1 Tablet (Gen 3) Stuck at "init.xz...ok"



  • Let me preface this by saying that this is my first experience with a FOG server setup.

    I am trying to image a Lenovo X1 Tablet (Gen 3) and it will show “init.xz…ok” then go to a black screen. I have to use a usb C network adapter as the tablet doesn’t have a built in network port. Below is a list of actions I have taken to try to fix the issue.

    I turned off safe boot and enabled the thunderbolt connection in PXE
    I manually registered the client in FOG and made sure the kernel argument was set to “has usb nic” and had the same results
    ive tried 3 different lenovo branded usb NIC adapters, they all pxe boot to FOG but will not register
    I have been able to register, image and deploy to another laptop with a built in NIC

    I will be happy to provide any other info needed to solve this issue. Thanks in advance!


  • Developer

    @dpusser_CMS Yes, ich can understand that it seems a little over the top to build your very own kernel just having started to use Linux. Bu hey, I think it’s never to early to get your fingers dirty and this is not very hard to do with all the things provided. There is not much you can mess up so I’d encourage you to just give it a go and simply ask if you think something is not going the right way. Just take a picture of the screen with an error or whatever and we’ll guide you the rest of the way!



  • @Sebastian-Roth

    I have looked at the wiki article you suggested about building a kernel but, since this is my first experience with linux, it is a little daunting. I am researching how to start building it though.


  • Developer

    @dpusser_CMS FOG uses the isc-dhcp-server which is part of most Linux distros. Depending on the Linux you have you find the configuration in /etc/dhcpd.conf, /etc/dhcp/dhcpd.conf or /etc/dhcp3/dhcpd.conf.

    Take a look through the config and you’ll find several lines like filename "ipxe.efi"; in there. Change those and restart the service (usually systemctl restart isc-dhcp-server or systemctl restart dhcp or systemctl restart dhcpd).

    Have you looked into building your own kernel yet?



  • @Sebastian-Roth

    My FOG Server is handling DHCP. I have a direct connection from the FOG server machine to the tablet I am trying to image.


  • Developer

    @dpusser_CMS said in Lenovo X1 Tablet (Gen 3) Stuck at "init.xz...ok":

    I’m also willing to try to debug the kernel boot process as you mentioned earlier.

    For this you wanna read our wiki article on building a kernel as a starter. Let us know if you need help with that. From there we can add debugging to find where exactly the kernel hangs.

    I’ve tried to search how to switch the DHCP server config to point to snp.efi or snponly.efi, but I’m not having much luck finding instructions.

    Is your FOG server doing DHCP in your network or do you have another one serving DHCP for you?



  • @Sebastian-Roth said in Lenovo X1 Tablet (Gen 3) Stuck at "init.xz...ok":

    edit your DHCP server config and point to snp.efi or snponly.efi

    There was a UEFI update from 3/10/19 that I installed, unfortunately it didn’t fix the issue. I’ve tried to search how to switch the DHCP server config to point to snp.efi or snponly.efi, but I’m not having much luck finding instructions. I’m also willing to try to debug the kernel boot process as you mentioned earlier.


  • Developer

    @dpusser_CMS I will quote George’s post here:

    @george1421 said in Unable to build FOS:
    We have seen this a few times before. What is happening is the hand-off from the iPXE kernel to uefi and the on to bzImage (FOS) is not working correctly. This is often because of bugs in the uefi firmware. One suggestion is to make sure the firmware is updated on your target computer. We have seen quite a few early in a model production cycle bios with problems that have been later fixed with updates.

    If there is no firmware update available for this device we’d need to debug the kernel boot process on this particular device. As I don’t have a device at hand this would be something you need to do. We can guide you but we can’t do the testing for you.

    Another thing you can try but are more or less unlikely to help is using a different iPXE binary to boot. By default we use ipxe.efi for UEFI-enabled devices. You can edit your DHCP server config and point to snp.efi or snponly.efi and see if that makes a difference.



  • @Tom-Elliott

    yes I did use the correct “has_usb_nic=1” argument and it did not affect the outcome.



  • This post is deleted!

  • Senior Developer

    Does the manually registered client literally have has usb nic as it should really be has_usb_nic=1?

    This wouldn’t necessarily fix the problem, but if you’re going to use the argument, it’d be best to use it as it was intended. Of course, once you make the correction, please try and see if that helps out.


Log in to reply
 

426
Online

6.3k
Users

13.7k
Topics

129.1k
Posts