UNSOLVED ZFS : Error trying to restore gpt partition

  • Hi all,

    I am currently working on FOG for a school project (I’m still learning to use it). I have managed to sysprep and deploy a Windows 10 Image on a disk that had windows installed on it previously, everything works fine. When i tried a deployment on 4 PCs to test my project out on a larger scale, it gave me an error “Error trying to restore GPT partition table. […] Exit returned code 4” on every PC. We have swappable disks that we can use for these types of tests. I then tried again with my original disk i was using and it worked. I figured I would take a look at the file systems on the 4 test disks and dicovered that they have “zfs” file system.
    Does anyone know what my issue could be? Do i need to reformat all these disks for the system to work on a different file system?

    Fog version: V1.5.5


  • Senior Developer

    @nevinconstantin Please keep us posted on the issue and if and how you were able to solve this.

    Resizing to a smaller disk does actually work in many cases. So it is not something FOG is unable to handle in general. But there are partition layouts where the later partition(s) prevent from a full resize.

  • Thanks for the reply. Unfortunatly I dont have access to the server right now but I did see your reply while i was working on it. This made me realize that fog was having issues resizing my image. I did not take into consideration that i was using smaller disks than my master image. Being short on time for my project, i decided my best course of action was to resize the partition before sysprep. This would just allow me to test deployment speed for my project. I was convinced that the ZFS was causing issue but you have put me in the right direction. Many thanks, even though I did not narrow down the problem, at least your answer got me thinking of another way to fix this and I will be able to explain in my documentation as of why it would not deploy.



    PS: Thanks to any developer of this projectthat reads this, I have been working with fog for the past few weeks and it has taught me alot and it was alot of fun 🙂

  • Senior Developer

    @nevinconstantin When deploying to a drive that disk will be wiped beforehand. So doesn’t matter what is on that disk. The issue can be caused by different problems. Mainly the Destination drive not being big enough for the image you want to deploy. Please take a look at the image files on your FOG server in /images/nameofyourimage. Post the contents of the text files d1.minimum.partitions, d1.fixed_size_partitions and d1.partitions here in the forums.