List all hosts - HTTP error 500



  • Hey

    When I click in the web interface hosts and then list all hosts, I get a 500 http error.

    Access log:
    10.121.21.127 - - [11 / Mar / 2019: 20: 22: 46 +0100] “GET /fog/management/index.php?node=host&sub=list HTTP / 1.1” 500 - "http: //fog.odl .vdab.net / fog / management / index.php? node = host “” Mozilla / 5.0 (Windows NT 10.0; Win64; x64) AppleWebKit / 537.36 (KHTML, like Gecko) Chrome / 71.0.3578.98 Safari / 537.36 OPR / 58.0 .3135.79 "

    The access log just says 500 error, no detailed error. The error log is empty.

    I have already raised the memory size in general settings and php.ini, without result.

    Tips?

    Thanks in advance!



  • @george1421
    Increasing PHP-fpm memory did the trick.

    Thx for the thinking together.


  • Moderator

    @Dominique Well we can then try to give php-fpm a little more working memory. You may also need to add 1-2GB to the main OS memory too.

    In the /etc directory there should be a file called www.conf depending on the version of php-fpm that is installed you will need to search for it using find ./ -name www.conf.

    Once you find that file edit it with your favorite linux text editor. Search for this line:

    php_admin_value[memory_limit] = 256M
    

    Change the 256M to 512M.

    Restart php-fpm systemctl restart php-fpm Check your main memory using top before and after you restart php-fpm. Make any main memory adds as needed. I can tell you with 2500 hosts you will probably need at least 4GB of system ram to make that FOG server happy.



  • For what it’s worth, the export hosts link also gives a HTTP 500 error.

    No error logs found, it’s getting a strange problem.

    I can’t upgrade do a dev branch. We use fog as a productive rebuilding tool.


  • Developer

    @Dominique said:

    1. Red Hat 7.6
    2. 1.5.5
    3. 2500+

    In that case I might suggest trying the latest dev-branch (download from github) as there have been performance improvements since the last official release that might prevent the problem you see.


  • Moderator

    @Dominique said in List all hosts - HTTP error 500:

    /fog/management/index.php?node=host&sub=list HTTP/1.1" 500 - "

    I’m in line with what Tom said about out of memory. Understand this isn’t necessarily system memory. With that many hosts I’m thinking its going to php-fpm preallocated memory. The php-fpm error log file should show this memory exhaustion message. Look in the php-fpm directory for log files that have the latest date then tail those logs. If it is php-fpm then we can bump up the memory allocations.



  • @george1421

    Nothing in Apache error log, the line in acces log doesn’t explain a lot:

    ... ] "GET /fog/management/index.php?node=host&sub=list HTTP/1.1" 500 - "http://fog.odl.vdab.net/fog/management/index.php?node=host" "M...
    
    1. Red Hat 7.6
    2. 1.5.5
    3. 2500+

  • Moderator

    @Dominique If you are getting a HTTP 500 error then either the apache error log or in the php-fpm error log. I would start by checking the apache error log.

    Also you should provide a bit more details on your fog installation like:

    1. FOG Server OS
    2. Version of FOG you are using.
    3. Number of target systems you have registered with FOG


  • @Dominique said in List all hosts - HTTP error 500:

    No recent messages in www-error.log, last is from August 2018.

    [20-Aug-2018 12:14:11 UTC] PHP Warning: phpinfo(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /var/www/html/fog/management/phpinfo.php on line 3

    Memory usages of the server is also OK.
    total used free shared buff/cache available
    Mem: 4026376 1362544 1570336 28552 1093496 2251816

    The memory size in general settings is 2048. Should it be raised?

    Thx!

    No one?

    This is still an issue.

    The FOG server’s RAM memory has been expanded to 8. But no luck!



  • No recent messages in www-error.log, last is from August 2018.

    [20-Aug-2018 12:14:11 UTC] PHP Warning: phpinfo(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. in /var/www/html/fog/management/phpinfo.php on line 3

    Memory usages of the server is also OK.
    total used free shared buff/cache available
    Mem: 4026376 1362544 1570336 28552 1093496 2251816

    The memory size in general settings is 2048. Should it be raised?

    Thx!


  • Senior Developer

    @Dominique check the /var/log/php-fpm/www-error.log

    If I were to guess, you have lack of memory. Just a guess though.


Log in to reply
 

352
Online

6.4k
Users

13.8k
Topics

130.3k
Posts