FOG Handling DHCP Services



  • I have been asked to set up a FOG server with this setup:
    Dell PowerEdge R710
    Ubuntu 16.04 server

    I need the FOG server and DHCP server in the same machine.
    I would like FOG to handle the DHCP if possible. I have FOG installed and I selected the option to allow FOG to handle DHCP services.
    My first question is, what exactly happens when I allow the server to handle DHCP on its own? What does it do differently if I were to select no?

    With that being said, I was wondering if I will need to use another service for DHCP on the same machine?


  • Developer

    @cary1102 For that to work you need to push the router/gateway information to the clients in the 10.10.222.0 subnet. Add the following line so your config looks like this:

    subnet 10.10.222.0 netmask 255.255.255.0 {
        option subnet-mask 255.255.255.0;
        option routers 10.10.222.XXX;
    ...
    

    Put in the gateway IP address instead of XXX. I suppose you have a router/gateway that is making communication between the two different subnets possible?!?

    You need to know that there might be other obstacles still in front of you. The clients use a couple different protocols like HTTP (easy), FTP and NFS to communicate with your FOG server and so the gateway needs to forward all those for the clients to be able to work properly.



  • I have gotten my server to hand out the right addresses to clients. The only problem now is that when I try to PXE boot a client the pxe file is not found. It looks for the pxe file with the address 10.10.2.65 but it cannot be found. Any suggestions?



  • I looked over my config file and my range was incorrectly entered. DHCP services start now.



  • Okay so I have decided the best way for me to do this is to use my FOG server on the one interface and host DHCP on another interface. So I have set up DHCP on eno2 and FOG on my eno1 interface. Still the DHCP does not start.

    My interfaces are as shown,
    926fb575-7e9f-47a8-96a5-0d028dd07560-image.png

    And my dhcpd.conf is as shown.
    ec67fc01-9261-469d-bba7-40fb6f8f8de5-image.png



  • @cary1102 said in FOG Handling DHCP Services:

    Awesome. Exactly the reply I needed.

    Another thing I have had trouble with is in the past I tried editing that dhcp file but then after I did so, I did not get the FOG PXE boot anymore.
    By default my FOG server is giving clients addresses on the same network as the FOG server and I need to change this without breaking it.
    For example: A client will receive the address 10.10.2.6.
    I need the DHCP to hand out addresses on my 10.10.222.0 network.

    I will keep trying and report any issues I come across.

    Hi,

    on your ip a s output below i see 10.10.2.65/24 that means 255.255.255.0
    but you told us that you want the dhcp to serve 10.10.222.0 how should that work?

    You need a route to have both networks communicating, FYI DHCP is a non routable protocol.
    Or configure both the fog server and the dhcp range in the same subnet but exclude the fixed addresses (for example the fog server) from being served by the DHCP service.

    Regards X23



  • This is the output of ip a s
    65432aeb-4a1b-4d4e-bd15-eb2ffff0ef3a-image.png


  • Developer

    @cary1102 Please post the output of the command ip a s as well.



  • So I am not able to start my DHCP services for some reason now that I have everything configured.

    I have configured the network interfaces like this:
    interfaces.PNG

    My dhcpconf file is is configured like this:
    dhcpd.conf.PNG

    And lastly, if I start DHCP services and then look at the status of it I get this message:dhcp failed.PNG

    Any advice is much appreciated!
    Thanks.


  • Developer

    @cary1102 Depends on the subnet mask as well. But I guess you are using class C netmask (255.255.255.0) and that would mean 10.10.222.x is in a different subnet. Then you need to add another scope to the dhcpd.conf file:

    subnet 10.10.222.0 netmask 255.255.255.0 {
        option subnet-mask 255.255.255.0;
    ...
    

    But be aware that hosts in different subnets is an advances setup that might need other things like dhcpelay and gateway…



  • Awesome. Exactly the reply I needed.

    Another thing I have had trouble with is in the past I tried editing that dhcp file but then after I did so, I did not get the FOG PXE boot anymore.
    By default my FOG server is giving clients addresses on the same network as the FOG server and I need to change this without breaking it.
    For example: A client will receive the address 10.10.2.6.
    I need the DHCP to hand out addresses on my 10.10.222.0 network.

    I will keep trying and report any issues I come across.


  • Developer

    @cary1102 said in FOG Handling DHCP Services:

    My first question is, what exactly happens when I allow the server to handle DHCP on its own?

    Well, it does exactly what it says. The FOG installer generates a dhcpd.conf file, installs the DHCP server package and Starts it up using that config.

    If you tell the installer to skip DHCP, it won’t do those things and you need to take care yourself. Either set it up on your server manually or use an external DHCP.


Log in to reply
 

458
Online

6.2k
Users

13.6k
Topics

128.0k
Posts